使用 Microsoft 登录
登录或创建帐户。
你好,
使用其他帐户。
你有多个帐户
选择要登录的帐户。

症状

请考虑以下情况:

  • 您的计算机上安装以下软件:

    • 日蚀式 3.5,Eclipse 3.6 或产品基于上述版本之一。

    • Microsoft Visual Studio 团队资源管理器无处不在 2010 Service Pack 1 (SP1) 为 Eclipse

    • Windows Internet Explorer 9

  • 您可以使用团队资源管理器到处 2010年连接到 Microsoft Team Foundation Server (TFS) 服务器。

  • 您尝试保存或查看工作项包含一些 HTML 控件。

在这种情况下,保存或查看操作将失败。 此外,你还会收到以下错误消息:

保存 FailedJava.lang.reflect.InvocationTargetException

原因

由于更改 Internet Explorer 9 中引入的 JavaScript 引擎中发生此问题。 调用代码在受影响的 Eclipse 版本中的更改相冲突。 这种冲突导致 failaure 中包含格式文本存档在团队资源管理器地方 2010 SP1 的控件的工作项的功能。因此,错误消息会弹起。

解决方案

修补程序信息

此修补程序已可供下载,从下面的 Microsoft 下载中心网站: Download 立即下载修补程序软件包。有关如何下载 Microsoft 支持文件的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

119591 如何从联机服务获取 Microsoft 支持文件 Microsoft 已对该文件进行病毒扫描。 Microsoft 使用的是文件发布时可以获得的最新病毒检测软件。 该文件存储在安全性得到增强的服务器上,以防止对文件进行未经授权的更改。 注意:若要安装此修补程序,请执行以下步骤:

  1. 将修补程序包 Tfseclipseplugin updatesitearchive 10.1.0 qfe1.zip 文件保存在本地文件夹中。

  2. 启动 Eclipse。

  3. 单击帮助菜单上的安装新的软件

  4. 单击添加

  5. 名称框中,键入本地团队资源管理器插件存档,然后单击存档

  6. 选择保存在本地文件夹中,该 Tfseclipseplugin updatesitearchive 10.1.0 qfe1.zip 文件,然后单击确定

  7. 安装对话框中,单击以选中复选框中的功能列表中对应于团队资源管理器无处不在。

  8. 单击下一步两次。

  9. 接受 Microsoft 软件许可条款,然后再单击下一步

  10. 单击“完成”。

有关如何安装插件的 Team Foundation Server 和命令行客户端的详细信息,下载,然后查看下面的 Microsoft 网页:

如何安装插件的 Team Foundation Server 和命令行客户端

先决条件

若要安装此修补程序,必须具有 Microsoft Visual Studio 团队资源管理器 2010 Service Pack 1 (SP1) 安装在一台计算机上的任何地方。

重启信息

应用此修补程序后,必须重新启动 Eclipse。

修补程序替换信息

此修补程序不替代以前发布的修补程序。

文件信息

此修补程序的全球版本具有的文件属性 (或更新的文件属性) 在下表中列出。 这些文件的日期和时间按协调世界时 (UTC) 列出。 在查看文件信息时,文件时间将转换为本地时间。 要了解 UTC 与本地时间之间的时差,请使用“控制面板”中“日期和时间”项中的“时区”选项卡。

文件名

文件版本

文件大小

日期

时间

Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip

Not Applicable

12,854,618

24-May-2011

07:17

解决方法

若要变通解决此问题,请执行以下步骤:

  1. 打开 Eclipse 程序文件夹。

  2. 查找,然后在文本编辑器中打开 Eclipse.ini。 例如,用记事本打开该文件。

  3. 在文件末尾添加以下行:

    -Dcom.microsoft.tfs.client.common.ui.controls.generic.html.htmleditor.disable=

  4. 保存的 Eclipse.ini 文件,然后重新启动 Eclipse。

状态

Microsoft 已确认这是在“适用范围”部分中列出的 Microsoft 产品存在的问题。

需要更多帮助?

需要更多选项?

了解订阅权益、浏览培训课程、了解如何保护设备等。

社区可帮助你提出和回答问题、提供反馈,并听取经验丰富专家的意见。

此信息是否有帮助?

你对语言质量的满意程度如何?
哪些因素影响了你的体验?
按“提交”即表示你的反馈将用于改进 Microsoft 产品和服务。 你的 IT 管理员将能够收集此数据。 隐私声明。

谢谢您的反馈!

×