问题
尝试将使用 Microsoft Exchange ActiveSync (EAS) 的移动设备与 Microsoft Office 365 中的Microsoft Exchange Online同步时,设备无法连接。 可能会收到以下错误消息之一,具体取决于你的设备:
无法获取邮件与服务器的连接失败。
无法获取邮件传递邮件时出错。
由于安全更新,无法打开服务器连接。
如果使用 Exchange 管理中心查看移动设备详细信息,或者收集设备的同步日志,则会收到以下错误消息:
AccessState: 访问被拒绝
“ 按列设置的访问”将包含如下其他信息:
相同命令太多
有关Office 365管理员可用于在 Exchange 管理中心中识别此问题的步骤,请参阅“更多信息”部分。
原因
当移动设备的行为方式可能对Exchange Online服务性能产生不利影响时,设备在短时间内会进入“拒绝访问”状态。 例如,如果设备在很短的时间内将过多相同的同步命令发送到特定文件夹的服务,则会出现这种情况。Exchange Online已实现 EAS 限制,以管理和维护 Office 365 中Exchange Online环境的最佳性能。 有关在使用 Exchange 管理中心时如何查看移动设备的访问状态以及如何收集 EAS 日志的详细信息,请参阅“更多信息”部分。
解决 方案
若要解决此问题,请在与设备供应商或运营商讨论此解决方法时执行以下步骤:
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同步出现延迟时,请勿在移动设备上重复按 “同步” 按钮。 此外,不要快速切换文件夹并重复按按钮进行同步。
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请至少等待 10 分钟,然后执行其他操作,以便服务会自动删除限制。
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切换到手动同步,查看它是否可用于连接设备并将其与邮箱同步。 这样做有助于防止设备发送过多相同的命令。
如果问题仍然存在,检查本地网络中设备的无线连接。 你可能必须联系设备制造商或运营商以捕获和查看设备日志记录。 如果问题未解决,请联系移动设备制造商报告并调查此问题。 注意 设备上 EAS 协议的实现控制发送到服务的命令的频率。 Microsoft 支持部门无法更改设备上的软件。 设备的任何更新只能通过设备制造商进行。
更多信息
查看移动设备详细信息
有关如何查看移动设备详细信息的详细信息,请参阅 查看用户的移动设备信息。
收集 EAS 日志
有关如何收集 EAS 日志的详细信息,请参阅以下Microsoft知识库文章:
2461792 如何收集 ActiveSync 设备日志以排查移动设备和Exchange Online可以使用记事本等文本编辑器打开日志文件。 在日志文件中,搜索包含以下信息的 503 错误:
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ResponseHeader 与 AccessState 一起: 阻止
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AccessStateReason:SyncCommands 或 AccessStateReason : RecentCommands
请注意,在此错误之前,设备可能会多次发送相同的命令。 例如,设备可能会将 Sync 命令与相同的参数(如 SyncKey 和 CollectionId)一起发送。 如果检查时间戳,可以看到在很短的时间内重复发送的命令,这会导致 503 服务不可用错误。 这表示设备正在以导致Exchange Online服务启用限制保护的方式执行,以防止设备影响服务的性能。
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