症状
在具有 NVIDIA GeForce GTX 1050 视频卡的 Surface Book 2 13 英寸设备上,系统会提示你输入 BitLocker 恢复密钥。
原因
安装 2018 年 8 月 UEFI 更新后,可能会出现此问题。 如果输入了恢复密钥,则设备现在处于旧版绑定 (PCR 0,2,4,11) 配置。 因此,必须应用其他步骤来启用安装可更正此问题的更新。
备注 2018 年 8 月 UEFI 更新不再可用。 但是,任何具有 NVIDIA GeForce GTX 1050 且安装了更新的 2 13 英寸Surface Book设备都可能会遇到此问题,并且可能仍处于此配置中。
解决方法
若要解决此问题,请使用以下方法之一。
自动修复
下载并运行 Surface BitLocker 保护程序检查工具。 该工具将指导你完成修复更新的安装。
注意: Surface BitLocker 保护程序检查工具仅以英语提供,但它将在所有设备上运行。
下面介绍如何使用 Surface BitLocker 保护程序检查工具:
-
在任务栏上的搜索框中,键入 Surface BitLocker 保护程序检查,然后从列表中选择它以打开该工具。
-
根据看到的消息,执行以下操作之一。
|
消息 |
行动 |
|
“此设备的 BitLocker 设置不需要进行任何更改。” |
BitLocker 设置正常,因此无需执行任何其他操作。 按 Enter 退出该工具。 |
|
“请将Surface Book 2 停靠到基地。” |
在 Surface Book 2 设备上,将显示器连接到键盘。 如果已连接,请将其拆离,清理其连接器,然后重新连接。 按 Enter 退出该工具,然后再次执行上述步骤 2 和 3。 |
|
“BitLocker 已暂时挂起。 现在需要重新启动。 此工具将从重新启动后自动恢复。” |
该工具需要更改 BitLocker 设置。 按 Enter 重启设备并应用更改。 设备重启后,该工具将自动恢复。 |
|
“BitLocker 恢复密钥是:<BitLocker 恢复密钥编号> 请在安全的位置记录此项。 现在需要重新启动。 此工具将从重新启动后自动恢复。” |
如果需要,请打印或记下 BitLocker 恢复密钥。 然后按 Enter 重启设备并应用更改。 设备重启后,该工具将自动恢复。 |
|
“此设备上的 BitLocker 设置已成功修复。” |
该工具修复了 BitLocker 设置,因此无需执行任何其他操作。 按 Enter 退出该工具。 |
手动修复 (高级)
重要说明 以下步骤仅适用于高级用户。 如果你不习惯使用Windows PowerShell但需要有关下载或使用修复工具的帮助,请联系 Surface 支持部门。
检查 BitLocker 设置
-
使用管理权限启动 PowerShell 命令提示符。
-
运行以下命令:Manage-bde -protectors -get C:
-
检查 PCR 验证配置文件设置。
-
如果 PCR 验证配置文件设置为 7、11,则设备配置正确,无需执行进一步操作。
-
如果此值设置为 7、11 以外的值,请转到后续步骤。
-
更正 BitLocker 设置
-
在 PowerShell 命令提示符处运行以下命令:Suspend-bitlocker -mountpoint C: -rebootcount 0
-
打开“设备管理器”。
-
找到并展开 固件 分支。
-
如果任何固件显示警告符号,请选择每个固件条目,然后选择 “卸载设备”。 对显示警告符号的任何固件节点执行此操作。
-
重启Surface Book 2 设备。
-
启动具有管理权限的 PowerShell 命令提示符。
-
运行以下命令:Manage-bde -protectors -get C:
-
找到 TPM ID 并将其复制到剪贴板。 请确保包含大括号 ( { } ) 。
-
键入以下命令,并在每个命令后按 Enter:Manage-bde -protectors -delete C: -id "{TPM id}"Manage-bde -protectors -add C: -TPM注意 在第一个命令中,将 <TPM ID> 替换为在步骤 8 中复制的 ID 号。
-
重启Surface Book 2 设备。
按照“检查 BitLocker 设置”步骤确定设置现在是否正确。
如果以前在 设备管理器 中删除了驱动程序,请再次打开设备管理器,验证固件设备类型是否未显示警告符号。 为此,请双击 Surface UEFI 项目,然后打开“ 驱动程序 ”选项卡。 验证已安装的驱动程序是否为 389.2318.768.0 或更高版本。
如果无法将 BitLocker 设置配置为 7、11,或者无法消除设备管理器中的警告符号,请联系 Surface 支持部门。