Microsoft 在一个可下载文件中分发 Microsoft SQL Server 2008 R2 Service Pack 1 (SP1)修补程序。 由于修补程序是累积的,因此每个新版本都包含以前的 SQL Server 2008 R2 Service Pack 1 (SP1)更新版本附带的所有修补程序和所有安全更新。
症状
请考虑以下情况:
-
用户在运行 Windows XP 或 Windows Server 2003 的计算机上安装 Microsoft SQL Server 2012 PowerPivot for Microsoft Excel 2010。 用户不是计算机上管理员组的成员。
-
用户尝试启动 PowerPivot for Excel 加载项。
在这种情况下,会间歇性地显示类似以下的错误消息:
嵌入的 Analysis Services 引擎:无法打开嵌入的 Powerpivot 数据。
原因
出现此问题的原因是嵌入的 PowerPivot 引擎不正确检查 SeIncreaseBasePriorityPrivilege 权限。 默认情况下,普通用户没有 SeIncreaseBasePriorityPrivilege权限。 因此,将生成错误。注意SeIncreaseBasePriorityPrivilege权限允许用户提升进程的计划优先级并增加进程的工作集。 这将加快进程的执行。
解决方案
若要解决此问题,请在安装了 SQL Server 2012 PowerPivot for Excel 2010 的计算机上应用累积更新。
累积更新信息
SQL Server 2012
此问题的修补程序首次在累积更新2中发布。有关如何为 SQL Server 2012 获取此累积更新包的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2703275 SQL Server 2012 累积更新包2注意 由于这些版本是累积的,因此每个新的修复版本都包含以前的 SQL Server 2012 修复版本附带的所有修补程序和所有安全修补程序。 我们建议你考虑应用包含此修补程序的最新修复版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2692828 在 SQL Server 2012 发布后发布的 SQL Server 2012 版本
状态
Microsoft 已确认这是在“适用范围”部分中列出的 Microsoft 产品存在的问题。
解决方法
要解决此问题,请使用下列方法之一。
方法 1
向用户授予 SeIncreaseBasePriorityPrivilege 权限。
方法 2
将用户添加到遇到 "症状" 部分中所述问题的计算机上的管理员组。
参考
有关 PowerPivot for Excel 的详细信息,请转到以下 MSDN 网站:
有关 PowerPivot for Excel 的常规信息有关如何下载 SQL Server 2012 PowerPivot for Excel 2010 的详细信息,请转到以下 MSDN 网站: