KB3018269-安装 SQL Server 2014 SP1 (内部版本12.0.4050.0)时出现错误912或3417

注意如果您有版本12.0。4050.0 安装了 SQL Server 2014 服务 SP1 (KB3018269),则必须先从所有安装实例卸载该更新,然后才能安装此更新。 若要执行此操作,请使用 "控制面板" 中的 " 添加或删除程序 "。 有关详细信息,请参阅 KB 3018269。 请注意,你可能已安装 KB3018269,原因如下:

  • 已将更新应用到 SQL Server 2014 的现有实例。

  • 您使用 KB3018269 "滑包" (例如,SQLServer2014SP1-FullSlipstream-x64-ENU)安装了 SQL Server 2014 SP1 的新实例。

  • 您安装了任何 SQL Server 2014 SP1 速成版程序包。

假设你有一个 SQL Server 实例,其中包含在 Microsoft SQL Server 2014 中启用的 SSISDB 目录。 当您尝试升级到 SQL Server Service Pack 1 (SP1)内部版本号12.0.4050.0 时,收到以下错误消息:

错误:912,严重性:21,状态: 2. 数据库 "master" 的脚本级别升级失败,因为升级步骤 "SSIS_hotfix_install" 遇到错误3602,状态251,严重级别25。 这是一个很严重的错误情况,可能会干扰正常操作,数据库将脱机。 如果在升级 "master" 数据库期间发生错误,它将阻止整个 SQL Server 实例启动。 检查以前的错误日志条目是否存在错误,采取相应的纠正措施并重新启动数据库,以便脚本升级步骤运行完成。

错误:3417,严重性:21,状态:3。无法恢复 master 数据库。 SQL Server 无法运行。 从完整备份还原 master,修复它,或重建它。 有关如何重建 master 数据库的详细信息,请参阅 SQL Server 联机丛书。 SQL Server 关闭已启动

注意 然后,该实例处于无效且不可用的状态。

Microsoft 已经确认这是一个列于“适用范围”部分的 Microsoft 产品问题。

若要解决此问题,请按照下列步骤操作:

  1. 使用 "控制面板" 中的 " 添加或删除程序 " 卸载 SQL SERVER 2014 SP1 (KB3018269)的12.0.4050.0 版本。

  2. 安装 SQL Server 2014 SP1 版本 12.0.4100.1 (版本12.0.4100.1)。

有关此问题的详细信息,请参阅 SQL Server 2014 Service Pack 1 已发布

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

你对翻译质量的满意程度如何?

哪些因素影响了你的体验?

是否还有其他反馈?(可选)

谢谢您的反馈意见!

×