症状
在使用 Microsoft Dynamics CRM 时内部可能会提示用户输入身份验证凭据每 24 小时一次。这可能是 web 客户端和 Microsoft Dynamics CRM Outlook 客户端的用户两个用户。
这只会为所声明的身份验证已启用的部署。
原因
为解决此问题的一个可能的原因是,索赔将 SessionSecurityTokenLifetimeInHours 设置为值为 24 小时。这是默认值。
解决方案
设置 SessionSecurityTokenLifetimeInHours 的声明需要更新到 24 以外。在此特定情况下,它被设置为一周。
1.在已安装 CRM 发现角色动态服务器上,打开 PowerShell 命令窗口。
2.从窗口中运行以下命令。
$Settings = 获取 CrmSetting SettingType ClaimsSettings DwsServerUrl https://CrmDiscoverServer.domain.com -$creds 凭据
$Setting.SessionSecurityTokenLifetimeInHours ="168"
组-CrmSetting-DwsServerUrl https://CrmDiscoverServer.domain.com -凭据 $creds $setting
3.完成后,验证的寿命值现在是否 168 通过运行以下命令。
获得 CrmSetting SettingType ClaimsSettings DwsServerUrl https://CrmDiscoverServer.domain.com -$creds 凭据
4.下一步,在前端服务器上重新启动 IIS。
5.最后,重新启动 Outlook,遇到问题的症状部分中定义的所有用户
注意:
在上面的示例中,URL https://CrmDiscoverServer.domain.com将需要使用与在 Microsoft Dynamics CRM 部署了发现服务器角色的服务器的 URL 进行更新。
用户仍然会遇到身份验证提示输入凭据,但通过执行这些指令,此提示现在会每隔 7 天除非重新启动 Outlook 和/或您的浏览器。重新启动 Outlook/浏览器将自动续订其安全令牌并将允许用户不会看到身份验证提示。