症状
在联机模式下使用 Microsoft Outlook 访问某些电子邮件时,RPC 客户端访问服务意外崩溃或重启。 出现这种情况时,事件日志中将记录以下错误。 注意 有时,即使仍记录事件条目,服务也不会崩溃。将在保存到以下位置的 RCA 日志中记录以下内容:
C:\Program Files\Microsoft\Exchange Server\V15\Logging\RPC 客户端访问2015-04-23T19:05:35.961Z,3,603,/o=<id>/ou=exchange administrative group(fydibohf23spdlt)/cn=recipients/cn=5dd9b1444df54688b0d2367fbc5e47aa-crashmbx,,OUTLOOK.EXE,15.0.4711.1000,Classic,,,,ncacn_http,Client=MSExchangeRPC,,,,fault,00:00:00.2970000,,"Watson: [IndexOutOfRangeException] Index was outside the bounds of the array. at M.E.D.TextConverters.Internal.Format.FormatStore.TextStore.AddText(TextRunType runType, Char[] textBuffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.Format.FormatStore.AddMarkupText(Char[] textBuffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.Html.HtmlFormatConverterWithEncapsulation.OutputEncapsulatedMarkup() at M.E.D.TextConverters.Internal.Html.HtmlFormatConverterWithEncapsulation.Process(HtmlTokenId tokenId) at M.E.D.TextConverters.ConverterStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.RtfCompressed.RtfCompressCommon.ReadMoreData() at M.E.D.TextConverters.Internal.RtfCompressed.RtfCompressConverter.Run() at M.E.D.TextConverters.ConverterStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.S.BodyReadStream.<>c__DisplayClassb.<Read>b__a() at M.E.D.S.ConvertUtils.<>c__DisplayClass1`1.<CallCtsWithReturnValue>b__0() at M.E.D.S.ConvertUtils.CallCts(Trace tracer, String methodName, LocalizedString exceptionString, CtsCall ctsCall) at M.E.D.S.ConvertUtils.CallCtsWithReturnValue[T](Trace tracer, String methodName, LocalizedString exceptionString, CtsCallWithReturnValue`1 ctsCall) at M.E.D.S.BodyReadStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.S.Util.StreamHandler.CopyStreamData(Stream readStream, Stream writeStream, Nullable`1 numBytes, Int32 t",,,.in,
原因
当 TextConverter 执行缓冲区复制操作时, TextConverter类中发生的逻辑错误导致该问题。
解决方案
若要解决此问题,请安装 Exchange Server 2013 的累积更新 14或exchange server 2013的更高累积更新。
解决方法
若要解决此问题,请通过使用 RCA 日志确定导致服务停止的邮箱。 然后,我们建议你让邮箱用户将其 Outlook 设置从联机模式更改为缓存模式。 此外,请确保用户不会直接或通过使用 Outlook 规则将特定电子邮件复制或移动到 .pst 或本地文件夹。 若要确定导致问题的邮件,请一次将每封邮件复制或移动到 .pst 文件。 无法移动的消息是导致问题的消息。 此问题会导致失去连接丢失或导致 RPC 客户端访问服务崩溃。
状态
Microsoft 已经确认这是一个列于“适用范围”部分的 Microsoft 产品问题。