禁止或允许对形状进行更改

应用对象
Visio Professional 2024 Visio Standard 2024 Visio Professional 2021 Visio Standard 2021 Visio Professional 2019 Visio Standard 2019 Visio 专业版 2016 Visio 标准版 2016

防止在 Visio 中对宽度和高度等形状属性进行更改和通过锁定形状避免形状被选中是防止更改绘图的便捷方式。

形状保护要求“ 开发工具 ”选项卡可见。 默认情况下,此选项卡处于隐藏状态。

启用“开发工具”选项卡

  1. 单击“文件”选项卡,然后单击“选项”。
  2. 单击“高级”,然后向下滚动到“常规”部分。
    “以开发人员模式运行”复选框
  3. 选择 “在开发人员模式下运行 ”,然后单击“ 确定”。

禁止或允许对形状属性进行更改

  1. 在绘图中选择一个形状。

  2. 在“开发工具”选项卡上的“形状设计”组中,单击“保护”。

    Visio 2016 中的“开发工具”选项卡上的“形状设计”中的“保护”

  3. 选择您要锁定的形状属性,或清除要取消锁定属性的复选框,然后单击“确定”。

注意

如果可以使用其中一个可用的笔工具) 选择墨迹形状进行编辑 (,则即使在 “保护”对话框中选择了各种形状属性时,也可以在墨迹形状中添加墨迹笔划或从墨迹形状中擦除。 若要防止对墨迹形状进行任何更改,请锁定形状以阻止选择。

从所选内容中锁定或解锁形状

  1. 选择您要保护的一个或多个形状。

  2. 在“开发工具”选项卡上的“形状设计”组中,单击“保护”。 Visio 将打开“保护”对话框。

    注意

    若要了解有关此对话框上所有各种选项的更多信息,请参阅 “保护”对话框。

  3. 选中“防止选取”复选框,然后单击“确定”两次。

    Visio 2016 中的“保护”对话框中的“从所选部分”

  4. 在“开发人员”选项卡上的“显示/隐藏”组中,选中“绘图资源管理器”检查框。

    Visio 2016 中的“开发工具”选项卡上选中的绘图资源管理器

  5. 在“绘图资源管理器”窗口中,右键单击图形的名称,然后单击“保护文档”。

    Visio 2016 的绘图资源管理器中的“保护文档”

  6. 在“保护”下选择“形状”,然后单击“确定”。

    Visio 2016 中的“保护文档”中的所选形状

若要允许再次选择形状,请执行上述步骤,但要清除“形状”复选框,然后单击“确定”。