Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

在 Word 中,您可以建立並執行宏,將常用工作自動化。 宏是一系列命令和指示,您可將這些命令和指示分組為單一命令,以自動完成工作。

若要節省您花在經常執行之工作上的時間,可將步驟組合成巨集。 請先錄製巨集。 然後,您可以按一下 [快速存取工具列] 上的按鈕,或按下按鍵組合來執行該巨集。 視您設定的方式而定。

  1. 按一下 [檢視] > [巨集] > [錄製巨集]

    [錄製巨集] 命令

  2. 輸入巨集的名稱。

    巨集名稱方塊

  3. 若要在您建立的任何新文件中使用巨集,請確定 [將巨集儲存在] 方塊指定 [所有文件 (Normal.dotm)]

    選擇巨集存放位置的方塊

  4. 若要在您按一下按鈕時執行巨集,請按一下 [按鈕]

    按一下即可將巨集指定到按鈕。

  5. 按一下新巨集 (名稱類似 Normal.NewMacros.<您的巨集名稱>),然後按一下 [新增]

    巨集及 [新增] 按鈕

  6. 按一下 [修改]。

    [自訂快速存取工具列] 方塊中的 [修改] 按鈕

  7. 選擇按鈕圖像,輸入您想要的名稱,再按兩次 [確定]

    [修改按鈕] 方塊中的按鈕選項

  8. 現在開始錄製步驟。 針對工作中的每個步驟按一下命令或按下按鍵。 Word 會記錄您的滑鼠點擊和按鍵動作。

    附註: 錄製巨集時,請使用鍵盤來選取文字。 巨集不會錄製使用滑鼠進行的選擇。

  9. 若要停止錄製,按一下 [檢視] > [巨集] > [停止錄製]

    [停止錄製] 命令

您的巨集按鈕即會出現在 [快速存取工具列] 上。

[快速存取工具列] 上的 [巨集] 按鈕

若要執行巨集,請按一下該按鈕。

  1. 按一下 [檢視] > [巨集] > [錄製巨集]

    [錄製巨集] 命令

  2. 輸入巨集的名稱。

    巨集名稱方塊

  3. 若要在您建立的任何新文件中使用巨集,請確定 [將巨集儲存在] 方塊指定 [所有文件 (Normal.dotm)]

    選擇巨集存放位置的方塊

  4. 若要在按下鍵盤快速鍵時執行巨集,請按一下 [鍵盤]

    按一下即可將巨集指定到鍵盤快速鍵

  5. [按新設定的快速鍵] 方塊中輸入按鍵組合。

  6. 檢查該組合是否已經指定給其他動作。 如果是,請嘗試不同的組合。

  7. 若要在您建立的任何新文件中使用鍵盤快速鍵,請確定 [將自訂儲存於] 方塊顯示為 [Normal.dotm]

  8. 按一下 [指定]

  9. 現在開始錄製步驟。 針對工作中的每個步驟按一下命令或按下按鍵。 Word 會記錄您的滑鼠點擊和按鍵動作。

    附註: 錄製巨集時,請使用鍵盤來選取文字。 巨集不會錄製使用滑鼠進行的選擇。

  10. 若要停止錄製,按一下 [檢視] > [巨集] > [停止錄製]

    [停止錄製] 命令

若要執行巨集,請按下鍵盤快速鍵。

要執行巨集,請按一下 [快速存取工具列] 上的按鈕,按鍵盤快速鍵,或者,您也可以從 [巨集] 清單中執行巨集。

  1. 按一下 [檢視] > [巨集] > [檢視巨集]

    [檢視巨集] 命令

  2. [巨集名稱] 底下的清單中,按一下要執行的巨集。

  3. 按一下 [執行]

若要使某文件的巨集在所有新文件中皆可用,請將它新增到 Normal.dotm 範本。

  1. 開啟含有巨集的文件。

  2. 按一下 [檢視] > [巨集] > [檢視巨集]

    [檢視巨集] 命令

  3. 按一下 [組合管理]

    [檢視巨集] 方塊中的 [組合管理] 按鈕

  4. 按一下要新增至 Normal.dotm 範本的巨集,然後按一下 [複製]

  1. 按一下 [檔案] > [選項] > [自訂功能區]

  2. [由此選擇命令] 下,按一下 [巨集]

  3. 按一下所要的巨集。

  4. [自訂功能區] 底下,按一下要新增巨集的索引標籤和自訂群組。

如果沒有自訂群組,請按一下 [新增群組]。 然後按一下 [重新命名] 並為自訂群組輸入名稱。

  1. 按一下 [新增]

  2. 按一下 [重新命名] 可為巨集選擇圖像並輸入所要的名稱。

  3. 按兩次 [確定]

  1. 按一下 [開發人員] 索引標籤上 [程式碼] 群組中的 [巨集]。

  2. [巨集名稱] 方塊中,輸入巨集的名稱。

    附註: 如果您在 Word 中將新宏命名為與內建宏相同的名稱,新的宏指令將會取代內建宏。 若要檢視內建宏清單,請按兩下 [宏] 清單中的[Word 命令]。

  3. 在 [宏在] 列表 ,按下您要儲存宏的範本或檔。

    若要讓宏在所有檔中皆可使用,請務必按下 Normal.dotm

  4. 按兩下 [建立 ] 以開啟 Visual Basic 編輯器。

開啟 Visual Basic 編輯器之後,您可能會想要使用 Visual Basic for Applications 的詳細資訊。 如需詳細資訊,請按下 [說明] 功能表上的 [Microsoft Visual Basic 說明],或按 F1。

您可以錄製一連串的動作,或是在 Visual Basic 編輯器中輸入Visual Basic for Applications 程式代碼,從頭開始撰寫宏。

附註: 若要在 Office Word 2007中使用宏,您必須顯示 [ 開發人員 ] 索引標籤。

  1. 按一下 Microsoft Office 按鈕 Office 按鈕影像,然後按一下 [Word 選項]。

  2. 按一下 [常用]。

  3. 在 [處理 Word 的最佳選項] 底下,選取 [在功能區中顯示開發人員] 索引卷標複選框。

    附註: 功能區是 Microsoft Office Fluent 使用者介面的元件。

  1. 在 [開發人員] 索引標籤上,按一下 [程式碼] 群組中的 [錄製巨集]。

    [開發人員] 索引標籤上的 [程式碼] 群組
  2. [巨集名稱] 方塊中,輸入巨集的名稱。

    附註: 如果您在 Office Word 2007中將新宏命名為與內建宏相同的名稱,新的宏指令將會取代內建宏。 若要檢視內建宏清單,請在 [ 開發人員 ] 索引卷標的 [ 程序代碼 ] 群組中,按兩下 [ 宏]。 在 [宏] 列表中,按兩下 [Word 命令]

  3. 在 [將 宏儲存在 ] 方塊中,按下您要儲存宏的 範本 或檔。

    重要: 若要讓宏在所有檔中皆可使用,請務必按下 Normal.dotm

  4. 請在 [描述] 方塊中輸入巨集的描述文字。

  5. 執行下列其中一個動作:

    • 開始錄製    若要開始錄製宏,而不將其指派給快速存取工具列上的按鈕或快捷鍵,請按兩下 [ 確定]

    • 建立按鈕    若要將宏指派給快速存取工具列上的按鈕,請執行下列動作:

      1. 按兩下 [按鈕]

      2. [自定義快速存取工具列] 底下,選取您要新增宏至快速存取工具列的檔 (或所有文件) 。

        重要: 若要讓宏在所有檔中皆可使用,請務必按下 Normal.dotm

      3. [從對話框選擇命令 ] 底下,按下您要錄製的宏,然後按兩下 [ 新增]

      4. 若要自定義按鈕,請按兩下 [ 修改]

      5. 在 [ 符號] 底下,按下您要用於按鈕的符號。

      6. 在 [ 顯示名稱] 方 塊中,輸入您要顯示的宏名稱。

      7. 按兩次 [確定 ] 以開始錄製宏。

        您選擇的符號會顯示在 [快速存取工具列] 中。 當您指向符號時,會顯示您輸入的名稱。

    • 指定鍵盤快速鍵    若要將宏指派給鍵盤快捷方式,請執行下列動作:

      1. 按一下 [鍵盤]。

      2. 在 [ 命令] 方塊中 ,按兩下您要錄製的宏。

      3. 在 [ 按新的快捷鍵] 方塊 中,輸入您要的按鍵順序,然後按兩下 [ 指派]

      4. 按兩下 [關閉 ] 開始錄製宏。

  6. 執行您要包含在宏中的動作。

    附註: 錄製宏時,您可以使用滑鼠按下命令和選項,但無法選取文字。 您必須使用鍵盤來選取文字。 如需使用鍵盤選取文字的詳細資訊,請參閱 選取文字

  7. 若要停止錄製動作,請按兩下 [程序代碼] 群組中的 [停止錄製]。

變更宏的鍵盤快捷方式

  1. 按一下 Microsoft Office 按鈕 Office 按鈕影像,然後按一下 [Word 選項]。

  2. 按一下 [自訂]。

  3. [鍵盤快捷方式] 旁邊,按兩下 [ 自定義]

  4. 在 [ 類別] 清單中,按兩下 [ 宏]

  5. 在 [ 宏] 清單中 ,按下您要變更的宏。

  6. 在 [ 按新的快速鍵] 方塊 中,輸入您要選擇的按鍵組合。

  7. 核取 [ 目前的按鍵] 方 塊,確定您沒有指派您已經用來執行其他工作的按鍵組合。

  8. 在 [儲存 變更於 ] 列表中,按下符合您要執行宏之位置的選項。

    重要: 若要讓宏在所有檔中皆可使用,請務必按下 Normal.dotm

  9. 按一下 [關閉]。

  1. 按一下 [開發人員] 索引標籤上 [程式碼] 群組中的 [巨集]。

    [開發人員] 索引標籤上的 [程式碼] 群組

  2. 在 [ 宏名稱] 底下的清單中,按下您要執行的宏。

  3. 按一下 [執行]

  1. 按一下 [開發人員] 索引標籤上 [程式碼] 群組中的 [巨集]。

    [開發人員] 索引標籤上的 [程式碼] 群組

  2. [巨集名稱] 方塊中,輸入巨集的名稱。

    附註: 如果您在 Office Word 2007中將新宏命名為與內建宏相同的名稱,新的宏指令將會取代內建宏。 若要檢視內建宏清單,請按兩下 [宏] 清單中的 [Word 命令]

  3. 在 [宏 ] 清單中 ,按下您要儲存宏的 範本 或檔。

    若要讓宏在所有檔中皆可使用,請務必按下 Normal.dotm

  4. 按兩下 [建立 ] 以開啟 Visual Basic 編輯器。

開啟 Visual Basic 編輯器之後,您可能會想要使用 Visual Basic for Applications 的詳細資訊。 如需詳細資訊,請按下 [說明] 功能表上的 [Microsoft Visual Basic 說明],或按 F1。

若要快速處理您經常執行的工作,您可以在桌面版 Word 中將步驟組合成只要按兩下即可執行的宏。 在 Word 網頁版中,您必須手動逐步執行這類工作。

如果您有 Word,請先按兩下 [在 Word 中開啟] 以在 Word 中開啟檔。

[在傳統型應用程式中開啟] 命令的影像

然後依照桌面版 Word 的指示進行。

當您在 Word 中執行宏並儲存檔時,您會在 Word 網頁版中重新開啟檔時看到宏的結果。

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×