Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

狀況

請考慮下列情況:

  • 您可以使用分散式檔案系統複寫 (DFSR) 服務,在 Windows Server 2012 為基礎的網域環境中。

  • 您必須在網域環境中的分散式檔案系統 (DFS) 複寫群組。

  • 您可以使用 DFSR 服務,來複寫 DFS 複寫群組中的檔案。部分檔案的大小很大。例如,檔案的大小是 10 gb。


在這個案例中,無法複製大型的檔案。

注意只有當複寫連線已開啟,然後關閉 [經常時,通常會發生這個問題。這可能被因排定的複寫作業或不可靠的網路連線。DFSR 偵錯記錄檔中沒有指出複寫檔案的部分複本是儲存,並且再卸除的資訊。

此外,DFSR 偵錯記錄檔會記錄下列資訊︰

日期 時間2376 RDCX 882 [警告] (已略過) Rdc::SeedFile::Initialize Abandoning 候選檔案。
uid:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103 gvsn:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104 的檔案名稱︰
ri2k3-dc1.vhd csId:{A739B084-9C47-4514-97DB-D8E4344D6438}
Candidate(uid:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103
gvsn:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104
fileName:104-{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103-{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104-Partial.frx)
+ [Error:9048(0x2358) StageReader::Serialize staging.cpp:529 2376 C 壓縮的資料不正確]
+ [Error:9048(0x2358) Rdc::StagingClosure::Run rdc.cpp:3947 2376 C 壓縮的資料不正確]
+ [Error:9048(0x2358) Rdc::Common::StageFile rdc.cpp:3574 2376 C 壓縮的資料不正確]
+ [Error:9048(0x2358) StreamToIndex rdc.cpp:529 2376 C 壓縮的資料不正確]
+ [Error:9048(0x2358) SignatureGenerator rdc.cpp:279 2376 C 壓縮的資料不正確]
+ [Error:9048(0x2358) XpressUncompressReader::Read xpressstreams.cpp:1379 2376 C 壓縮的資料不正確]
+ [Error:9048(0x2358) XpressUncompressReader::Read xpressstreams.cpp:1323 2376 C 壓縮的資料不正確

原因

DFSR 會考慮複寫的檔案為無效的部分複本,就會發生這個問題。無法複製大型檔案,在一個工作階段,DFSR 會儲存複寫檔案的部分複本,以便複寫程序可以繼續從停止的位置。因為檔案的部分複本會被視為無效的 DFSR,DFSR,就必須重新啟動複寫程序。不過,複寫開啟連接時永遠不會久,複寫程序完成。因此,無法複製大型檔案。

解決方案

若要解決這個問題,請套用此 hotfix。在套用此 hotfix 之後,複寫就會繼續中斷處繼續執行而不必重頭開始的部分的檔案副本。

Hotfix 資訊

使用 Microsoft 支援從支援的 hotfix。不過,此 Hotfix 僅用於修正本文中所述的問題。此 hotfix 只適用於發生本文所述之問題的系統。此 hotfix 可能會接受其他測試。因此,如果此問題的影響不會很嚴重,我們建議您等候含此 hotfix 的下一版軟體更新。

如果 hotfix 可供下載,在此知識庫文件頂端將出現「可用的 Hotfix」區段。如果這個區段沒有出現,請連絡 Microsoft 客戶服務及支援以取得 hotfix。

注意如果發生其他問題,或如果需要進行疑難排解,您可能必須建立個別的服務要求。收取支援費用會套用到其他支援問題和此特定 hotfix 無法解決的問題。如需 Microsoft 客戶服務和支援的電話號碼或建立個別的服務要求的完整清單,請移至下列 Microsoft 網站:

http://support.microsoft.com/contactus/?ws=support注意「 下載 Hotfix 」 表單會顯示 hotfix 可用的語言。如果看不到您的語言,是因為未提供該語言的 Hotfix 。

先決條件

若要套用此 hotfix,您必須安裝的 Windows Server 2012。

重新啟動需求

您不必套用此 hotfix 之後,重新啟動電腦。

Hotfix 取代資訊

此 hotfix 不會取代任何先前發行的 hotfix。

此 hotfix 的英文 (美國) 版會安裝具有下列表格中所列的屬性的檔案。這些檔案的日期和時間均以國際標準時間 (UTC) 列出。本機電腦上這些檔案是以您當地的時間與目前的日光節約時間 (DST) 的時差來顯示日期和時間。此外,當您在檔案上執行特定作業時,日期和時間可能會變更。

Windows 8 和 Windows Server 2012 檔案資訊和注意事項

重要Windows 8 和 Windows Server 2012 hotfix 隨附在相同的套件中。不過,只有 「 視窗 8 」 會列在 Hotfix 要求] 頁面。若要要求 hotfix 套件套用至一或兩個作業系統,選取列在 [Windows 8] 下,在頁面的 hotfix。永遠參考文件的〈套用〉一節以判斷實際套用每個 hotfix 的作業系統。

  • 藉由檢查的檔案版本號碼,如下列表格所示,可以識別套用至特定產品、 里程碑 (RTM、 SPn) 及服務分支 (LDR、 GDR) 的檔案。

    版本

    產品

    里程碑

    服務分支

    6.2.920 0.16 xxx

    Windows 8 和 Windows Server 2012

    RTM

    GDR

    6.2.920 0.20 xxx

    Windows 8 和 Windows Server 2012

    RTM

    LDR

  • 資訊清單檔案 (.manifest) 及菊檔案 (.mum) 所安裝的每個環境都 < 其他檔案="" windows="" 8="" 和="" windows="" server="" 2012="" 資訊=""> 一節中的 [分別列出。MUM 及 MANIFEST 檔案,以及相關的安全性目錄 (.cat) 檔案,對維護更新元件的狀態非常重要。安全性類別目錄檔案 (將不會為其列出屬性) 是使用 Microsoft 數位簽章簽署的。

所有支援 x64 型版本的 Windows Server 2012

檔案名稱

檔案版本

檔案大小

日期

時間

平台

Dfsrprovs.mof

不適用

75,761

25-Jul-2012

20:12

不適用

Dfsrress.dll

6.2.9200.16384

2048

26-Jul-2012

02:33

x64

Dfsrs.exe

6.2.9200.20899

4,724,736

19-Dec-2013

00:24

x64

其他檔案資訊

Windows Server 2012 的其他檔案資訊

所有支援 x64 型版本的 Windows Server 2012 的其他檔案

檔案名稱

Amd64_2beae9088974fa54abf8919396ec92cd_31bf3856ad364e35_6.2.9200.20899_none_f6ff7a3e18a75efe.manifest

檔案版本

不適用

檔案大小

712

日期 (UTC)

19-Dec-2013

時間 (UTC)

23:28

平台

不適用

檔案名稱

Amd64_microsoft-windows-dfsr-core-serveronly_31bf3856ad364e35_6.2.9200.20899_none_f6d92e444aacb376.manifest

檔案版本

不適用

檔案大小

37,695

日期 (UTC)

19-Dec-2013

時間 (UTC)

23:28

平台

不適用


狀態

Microsoft 已確認這是<套用>一節所列出的 Microsoft 產品的問題。

參考

了解有關的術語,Microsoft 會使用來描述軟體更新。

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×