Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

徵狀

請試想下列案例:

  • 您在電腦上安裝完整版的 Microsoft SQL Server 2005。

  • 當您安裝 microsoft Office 記帳專業版或 Microsoft Office Accounting Express 時,請安裝 Microsoft SQL Server Express 2005。

  • 安裝 Microsoft SQL Server Express 2005 之後,請移除完整版本的 Microsoft SQL Server 2005。

在這種情況下,當您啟動 [記帳專業版] 或 [會計速成版] 時,會收到下列錯誤訊息:

Microsoft Office 會計遇到問題,需要關閉。 我們對此造成的不便深表歉意。 若要查看此錯誤報表包含的資料,請按一下這裡。

當您在 [會計專業版] 或 [會計速成版] 中列印報表時,您也會收到此錯誤訊息。 按一下以查看報表資料之後,您會收到類似下列訊息的錯誤訊息:

未註冊的類別(來自 HRESULT 的例外狀況:0x80040154 (REGDB_E_CLASSNOTREG))

當您收到第二個錯誤訊息時,會計專業人員或會計快速停止回應。

原因

發生這個問題的原因是,當您移除完整版本的 Microsoft SQL Server 2005 時,系統會移除 [會計專業人員] 或 [會計 Express] 使用的主要元件。 一些已移除的主要元件是 Microsoft Office 2003 網頁元件。

解決方案

若要解決此問題,請重新安裝 Microsoft Office 2003 網頁元件。 若要執行這項操作,請依照下列步驟執行:

  1. 依序按一下 [開始][控制台][新增或移除程式]。注意如果您使用的是 Windows Vista 作業系統,請按一下 [ 控制台],然後按一下 [ 程式和功能]。

  2. 按一下 [ Microsoft Office 2003 網頁元件],然後按一下 [ 移除]。注意 如果 Microsoft Office 2003 網頁元件 沒有出現在清單中,請移至步驟3。

  3. 取得並安裝 Microsoft Office 2003 網頁元件。 如需如何執行此動作的詳細資訊,請造訪下列 Microsoft 網站:

    http://www.microsoft.com/downloads/details.aspx?familyid=7287252C-402E-4F72-97A5-E0FD290D4B76&displaylang=en

  4. 啟動 [記帳專業人員] 或 [會計速成版]。

如果問題持續發生,請移除 [記帳專業版] 或 [會計速成版]。 然後,重新安裝 [記帳專業版] 或 [會計速成版]。

狀態

Microsoft 已確認本篇文章<適用於>一節所列之 Microsoft 產品確實有上述問題。

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×