Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

摘要

當您嘗試使用 Microsoft Windows Media Player 播放媒體檔案時,收到下列錯誤訊息:

無法播放檔案, 格式不支援。 (錯誤=80040265)

原因

這個問題可能是由下列一或多個原因而造成:

  • 有一或多個 Windows Media Player 檔案遺失或毀損。

  • 您嘗試播放的媒體檔案為 Windows Media Player 不支援的檔案格式。 例如,您嘗試播放 .viv 檔案。 Windows Media Player 不支援 .viv 檔案。

  • 媒體檔案已毀損。

  • 未安裝媒體檔案所使用的轉碼器。

  • 媒體檔案使用 Windows Media Player 不支援的轉碼器。

解決方案

如果要解決這個問題,請依照下列步驟執行: 執行每一個步驟之後,請進行測試,確定問題解決與否。

注意:Windows Media Player 支援最常見的媒體檔案格式。 但並非市面上所有的媒體檔案格式均可支援。 請在步驟 1 中,確定您嘗試播放的檔案為 Windows Media Player 支援的格式。 如果 Windows Media Player 不支援該格式,請勿執行步驟 1 之後的步驟。 請連絡該檔案的經銷商詢問是否有該檔案的檢視器。

注意:由於 Microsoft Windows 有多種版本,因此下列步驟可能依您的電腦有所差異。 如有需要,請參閱您的產品說明文件,以完成這些步驟。

  1. 確認 Windows Media Player 支援您嘗試播放的檔案格式。 Windows Media Player 支援下列檔案格式:

    • Windows Media 格式: .asf、.asx、.avi、.wav、.wax、.wma、.wm、.wmv

    • Moving Pictures Experts Group (MPEG) 格式: .m3u、.mp2v、.mpg、.mpeg、.m1v、.mp2、.mp3、.mpa、.mpe、.mpv2

    • Musical Instrument Digital Interface (MIDI) 格式: .mid、.midi、.rmi

    • UNIX 格式: .au、.snd

    注意:Windows Media Player 無法播放以 Microsoft MPEG4v3 轉碼器所建立的 .avi 檔案。 Microsoft 只支援 .asf 資料流格式的 MPEG4v3 檔案, 而不支援 .avi 檔案類型的檔案。 如果要播放檔案,必須使用支援格式 (如 .wmv 格式) 的原始來源重新編碼檔案。 如果要執行這項操作,可以使用 Windows Media 編碼器。 如需詳細資訊,請造訪下列 Microsoft 網站,然後在 [選取下載項目] 清單中按一下 [Windows Media 編碼器]

    如果您可以取得原始來源,請連絡檔案建立者,要求建立者將檔案轉換成受支援的 Windows Media Player 檔案格式。

  2. 確認您可以播放與先前嘗試播放、而出現錯誤訊息的檔案使用相同副檔名的媒體檔案。

    如需 Windows Media Player 支援檔案格式的說明及範例,請按以下的文章編號,檢視「Microsoft 知識庫」中的文章:

    Windows Media Player 多媒體檔案格式
      如果可以正常播放其他檔案,即表示先前所要播放的檔案可能已經損毀。 如果播放這兩個檔案均會收到錯誤訊息,請執行下一個步驟。

  3. 移除 Windows Media Player,並重新啟動電腦,然後重新安裝 Windows Media Player。

    1. 如果要移除 Windows Media Player,請依照下列步驟執行:

      1. 依序按一下 [開始][控制台][新增或移除程式]

      2. [目前安裝的程式] 清單中,按一下 [Microsoft Windows Media Player],然後按一下 [變更/移除]

      3. 提示您是否確定要移除時,請按一下
        [是]

        注意 您無法使用這個方法移除內建版本的 Windows Media Player。 如需有關如何移除 Windows Media Player 9 系列的詳細資訊,請造訪下列 Microsoft 網站:

    2. 重新啟動電腦。

    3. 如果要下載 Windows Media Player 的最新版本,請造訪下列 Microsoft 網站:

  4. 重新安裝最新版的 Microsoft DirectX。
    如需有關疑難排解及安裝 DirectX 的詳細資訊,請按以下的文章編號,檢視「Microsoft 知識庫」中的文章:

    如何下載並安裝 DirectX

    如何使用 DirectX 診斷工具判斷 DirectX 的版本

  5. 確認您使用的是您嘗試播放的媒體檔案所適用的轉碼器。
    如需有關檢查、安裝及疑難排解音訊轉碼器的詳細資訊,請按以下的文章編號,檢視「Microsoft 知識庫」中的文章:

    如何在 Windows 中安裝和移除轉碼器和 MCI 裝置

    疑難排解 Windows 95/98 中的音訊和影片轉碼器

    Media Player 無法播放使用 Indeo 4.x 轉碼器的 .avi 檔案

    無法下載適當的解壓縮程式

  6. 啟動 [登錄編輯程式],然後確認下列登錄子機碼及關聯值是否存在。 若要啟動登錄編輯程式,請依序按一下 [開始][執行],輸入
    regedit,然後按一下 [確定]

    重要 此章節、方法或工作包含有關如何修改登錄的步驟。 然而,不當修改登錄可能會發生嚴重的問題。 因此,請務必謹慎地依照這些步驟執行。 為加強保護,請先備份登錄再進行修改。 這樣一來,如果發生問題,您就可以還原登錄。 如需有關如何備份和還原登錄的詳細資訊,請按以下的文章編號,檢視「Microsoft 知識庫」中的文章:

    如何在 Windows 中備份及還原登錄
    登錄子機碼:

    HKEY_CLASSES_ROOT\CLSID\{da4e3da0-d07d-11d0-bd50-00a0c911ce86}\Instance\{083863F1-70DE-11d0-BD40-00A0C911CE86} 相關項目及其值:

    名稱

    資料

    類型

    CLSID

    {083863F1-70DE-11d0-BD40-00A0C911CE86}

    字串值

    FriendlyName

    DirectShow Filters

    字串值

    Merit

    00600000

    DWORD 值

    如果這個子機碼存在,且關聯值亦都正確,請結束 [登錄編輯程式]。

    如果此機碼不存在,請加以建立。 若要執行這項操作,請依照下列步驟執行:

    1. 找出並按下列子機碼:

      HKEY_CLASSES_ROOT\CLSID\{da4e3da0-d07d-11d0-bd50-00a0c911ce86}\Instance

    2. [編輯] 功能表中,指向 [新增],然後按一下 [機碼]

    3. 輸入 {083863F1-70DE-11d0-BD40-00A0C911CE86},然後按下 ENTER。

    4. [編輯] 功能表中,指向 [新增],然後按一下 [字串值]

    5. 輸入 CLSID,然後按下 ENTER。

    6. [編輯] 功能表上,按一下  [修改]

    7. 輸入  {083863F1-70DE-11d0-BD40-00A0C911CE86},然後按一下  [確定]

    8. [編輯] 功能表中,指向 [新增],然後按一下 [字串值]

    9. 輸入 FriendlyName,然後按下 ENTER。

    10. [編輯] 功能表上,按一下  [修改]

    11. 輸入 DirectShow Filters,再按一下 [確定]

    12. [編輯] 功能表中,指向 [新增],然後按一下 [DWORD 值]

    13. 輸入 Merit,然後按下 ENTER。

    14. [編輯] 功能表上,按一下  [修改]

    15. 輸入 600000,再按一下 [確定]

    16. 結束登錄編輯程式。

參考

如需有關播放 Windows Media Player 檔案時可能收到之其他錯誤訊息的詳細資訊,請按以下的文章編號,檢視「Microsoft 知識庫」中的文章:

Windows Media Player 檔案格式無效的錯誤訊息

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×