Applies ToWindows 8.1 Enterprise Windows 8.1 Windows 8.1 Pro Windows RT 8.1 Windows Server 2012 R2 Datacenter Windows Server 2012 R2 Essentials Windows Server 2012 R2 Foundation Windows Server 2012 R2 Standard Windows 7 Service Pack 1 Windows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate Windows Server 2008 R2 Service Pack 1 Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Datacenter Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition

狀況

假設您有正在執行 Windows RT 8.1 」、 「 Windows 8.1 」、 「 Windows Server 2012 R2 」、 「 視窗 7 Service Pack 1 (SP1) 或 「 Windows Server 2008 R2 SP1 的電腦。電腦已安裝與使用內嵌的 DisplayPort (eDP) 的 Intel 鯊灣平台 GPU 模型。在此情況下,您會遇到下列問題之一︰

  • 在桌面上,方法,您可以插入的外部顯示器裝置,例如監視器,出,並再插上相同或其他監視器時,它會顯示黑色畫面。

  • 膝上型電腦,在您闔上膝上型電腦,然後再開啟它,它會顯示黑色畫面。

原因

系統不會傳送DxgkDdiCommitVidPn呼叫,顯示裝置已拔除或膝上型電腦螢幕關閉時,就會發生這個問題。

解決方案

如果要解決這個問題,在 Windows 8.1 和 Windows Server 2012 R2,安裝更新 2919355。若要解決這個問題,在 Windows 7 和 Windows Server 2008 R2,安裝本文所述的 hotfix。

Windows 8.1 和 Windows Server 2012 R2 的更新資訊

如需有關如何取得更新 2919355,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件︰

Windows RT 8.1、 Windows 8.1 和 Windows Server 2012 R2 更新年 4 月,2014

Hotfix 資訊Windows 7 和 Windows Server 2008 R2

支援的 hotfix 可從 Microsoft 取得。不過,此 Hotfix 僅用於修正本文中所述的問題。此 Hotfix 只適用於發生此特定問題的系統上。如果 Hotfix 可供下載,在此知識庫文件頂端將出現<有可用的 Hotfix 供您下載>區段。如果這個區段不會出現,將要求提交給 Microsoft 客戶服務及支援取得 Hotfix。注意如果發生其他問題,或如果需要進行疑難排解,您可能必須建立個別的服務要求。收取支援費用會套用到其他支援問題和此特定 hotfix 無法解決的問題。如 Microsoft 客戶服務及支援的電話號碼或建立個別的服務要求的完整清單,請造訪下列 Microsoft 網站︰

注意「 可下載 Hotfix 」表單會顯示 hotfix 可用的語言。如果看不到您的語言,是因為未提供該語言的 Hotfix 。

先決條件

若要套用此 hotfix,您必須執行 Windows 7 SP1 或 Windows Server 2008 R2 SP1。如需有關如何取得 Windows 7 或 Windows Server 2008 R2 service pack 的詳細資訊,請按一下下面的文件編號,即可檢視「Microsoft 知識庫」中的文件︰

Service Pack 1 Windows 7 和 Windows Server 2008 R2 的資訊。

登錄資訊

若要使用此套件中的 hotfix,您不需對登錄進行任何變更。

重新啟動需求

套用此 hotfix 後,您必須重新啟動電腦。

Hotfix 取代資訊

此 hotfix 不會取代先前發行的 hotfix。

此 hotfix 的全域版本安裝檔案具有下列表格中所列的屬性。這些檔案的日期和時間均以國際標準時間 (UTC) 列出。本機電腦上這些檔案是以您當地的時間與目前的日光節約時間 (DST) 的時差來顯示日期和時間。此外,當您在檔案上執行特定作業時,日期和時間可能會變更。

Windows 7 和 Windows Server 2008 R2 檔案資訊和注意事項重要Windows 7 hotfix 及 Windows Server 2008 R2 hotfix 隨附在相同的套件中。不過,在 [Hotfix 要求] 頁面上的 Hotfix 會在這兩個作業系統下列出。若要要求套用至一或兩個作業系統的 Hotfix 套件,請選取此頁面上列在 Windows 7/Windows Server 2008 R2 之下的 Hotfix。永遠參考文件的〈套用〉一節以判斷實際套用每個 hotfix 的作業系統。

  • 可以識別套用至特定產品、 里程碑 (RTM、 SPn) 及服務分支 (LDR、 GDR) 的檔案,藉由檢查的檔案版本號碼,如下列表格所示︰

  • GDR 服務分支只包含能解決普遍及嚴重問題之廣泛發行的修正程式。LDR 服務分支包含廣為發佈和其他的修正程式。

  • 資訊清單檔案 (.manifest) 及菊檔案 (.mum) 所安裝的每個環境都 < 其他檔案和="" windows="" server="" 2008="" r2="" 的="" windows="" 7="" 資訊=""> 一節中的 [分別列出。MUM 及資訊清單檔案,以及相關的安全性類別目錄 (.cat) 檔案皆對維護更新元件的狀態來說相當重要。安全性類別目錄檔案 (將不會為其列出屬性) 是使用 Microsoft 數位簽章簽署的。

狀態

Microsoft 已確認這是<套用>一節所列出的 Microsoft 產品的問題。

更多的資訊

如需有關軟體更新術語的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:

的描述用來描述 Microsoft 軟體更新標準術語。

適用於 Windows 7 和 Windows Server 2008 R2 的其他檔案資訊

適用於所有支援的 Windows 7 x86 版本的其他檔案

本文將所述之產品製造協力廠商均與 Microsoft 無關。Microsoft 不對這些產品之其他相關效能或可靠性作出任何擔保或默示。

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。