如有關 Microsoft Outlook Express 和 Microsoft Outlook 電子郵件用戶端之間的差異,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:
257824 OL2000: Outlook 與 Outlook 之間的差異表示重要: 本文包含修改登錄的相關資訊。您可以修改登錄之前,請務必將它備份起來,並了解如何在發生問題時還原登錄。如需有關如何備份、 還原和編輯登錄的資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:
Microsoft Windows 登錄256986說明
狀況
當您啟動 Outlook Express 時,您可能會收到下列錯誤訊息:
無法啟動身分登入。有些元件已遺失或未正確設定。
-以及-
無法啟動 outlook Express。它可能未正確安裝。請確定您的磁碟未滿,或您不是記憶體不足。請連絡 Microsoft 支援部門,取得進一步的協助 (0x80040154)
-以及-
因為無法啟動 outlook Express MSOE。無法初始化 DLL。可能未正確安裝 outlook Express。
原因
錯誤訊息可能被因損毀或不正確的 Msident.dll 檔案或 Msidntld.dll 檔案的版本所建立的。
解決方案
警告︰不當使用「登錄編輯程式」可能會導致嚴重的問題,甚至必須重新安裝作業系統。Microsoft 不保證您不當使用登錄編輯程式所產生的問題都可以解決。請自行承擔使用登錄編輯器的風險。
Outlook Express 安裝程式即將在
如果要解決這個錯誤訊息,節省電腦上的,請遵循下列步驟:
-
按兩下 [我的電腦],然後再按兩下 [控制台]。
-
在 [控制台]中,按兩下 [新增/移除程式。
-
按一下 [ Windows 安裝程式] 索引標籤。
-
按一下以清除Outlook Express中,,然後按一下[確定]。
-
關閉 [新增/移除程式],然後再關閉 [控制台]。
-
按一下 [開始],指向 [執行],然後鍵入regedit。
-
瀏覽,然後再刪除下列機碼:
HKEY_LOCAL_MACHINE\Software\Microsoft\Activesetup
-以及-
HKEY_LOCAL_MACHINE\Software\Microsoft\Active 安裝程式
-
關閉登錄編輯程式。
-
下載並安裝 Internet Explorer 5.5 從網際網路。
在 Windows 98 或 98 上的 outlook Express
這種行為可能會發生其中一種在下列情況:
-
Outlook Express 安裝程序未正確完成。
-
HKEY_CURRENT_USER 子樹狀目錄中的識別身份登錄機碼不存在。
-
下列子機碼中沒有 Outlook Express 的登錄機碼:
HKEY_LOCAL_MACHINE\Software\Microsoft
-以及-
HKEY_CURRENT_USER\Software\Microsoft
若要檢查登錄,按一下 [開始],再按一下 [執行、 中開啟] 方塊中輸入regedit ,然後按一下[確定]。
注意: 不會變更任何登錄設定。如果您變更登錄設定時,您的電腦可能無法啟動。 如果您並沒有識別金鑰,但在登錄中有 Outlook Express 的機碼,藉由展開 Msident.dll 檔案,並 Msidntld.dll 檔案,從 Ie_extra.cab 檔案,或是利用 Microsoft Windows 系統檔案檢查程式 (SFC) 中,您可以修正問題Microsoft Windows 98 第二版與 Microsoft Internet Explorer 5.0 版。如果您有 Internet Explorer 5.01 您必須解壓縮這些檔案從 Ie_extra.cab 檔案版本。如何使用系統檔案檢查員 」 解壓縮檔案
請確定您有 Windows 98 第二個版本的光碟片,在您的光碟機,或是您有我們的電腦上使用這些檔案。若要使用 SFC,解壓縮 Msident.dll 檔案,並 Msidntld.dll 檔案:
-
按一下 [開始],按一下 [執行、 在 [開啟] 方塊中鍵入sfc.exe ,然後按一下[確定]。
-
在 [選擇一個選項,然後按一下 [開始] 方塊中,按一下 [從安裝磁碟展開檔案,型別
msident.dll,然後按一下 [開始。 -
在 [還原來源] 方塊中;輸入您的光碟機的路徑。例如,如果您的光碟機是 D 磁碟機,請輸入d:\win98。
-
在 [檔案儲存位置] 方塊中,輸入
c:\windows\system,然後按一下[確定]。 -
按一下 [從安裝磁碟展開檔案,輸入msidntld.dll,然後按一下 [開始]。
-
在 [還原來源] 方塊中,輸入您的光碟機的路徑。例如,如果我們的光碟機是 D 磁碟機上,輸入
d:\win98. -
在 [檔案儲存位置] 方塊中,輸入
c:\windows\system,然後按一下[確定]。
還原檔案之後,您必須在 Msident.dll 和 Msidntld.dll 檔案上執行 Regsvr32.exe。若要這麼做,按一下 [開始]、 按一下 [執行]、 輸入regsvr32 Msident.dll 開啟] 方塊中,然後按一下[確定]。Msidntld.dll 檔案,請重複此程序。如果您沒有註冊的 Msident.dll 和 Msidntld.dll 檔案是否正確,您仍然收到錯誤訊息。
如何以手動方式解壓縮檔案
若要以手動方式解壓縮的 Msident.dll 和 Msidntld.dll 檔,您需要 Ie_extra.cab 檔案上其中一個可用硬碟機或 Internet Explorer CD-ROM 上。如果您是從網際網路下載 Internet Explorer,此檔案是位於 Windows 更新的安裝程式檔案資料夾。展開這個檔案到 Windows\System 資料夾。
如果要在找出 Ie_extra.cab 檔案之後,重新啟動電腦,在 MS-DOS 模式。執行這項操作,按一下 [開始]、 按一下 [關機,再按 [重新啟動在 MS-DOS 模式下,,然後按一下 [確定]。然後從 Ie_extra.cab 中解壓縮檔案。 如需其他有關解壓縮公用程式的詳細資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:129605如何解壓縮壓縮的 Windows 上的原始檔案 如果您沒有正確的; 註冊 Msident.dll,Msidntld.dll 檔案您仍然收到錯誤訊息。檔案解壓縮之後,您必須執行 Regsvr32.exe Msident.dll,和 Msidntld.dll 檔案。若要這麼做,按一下 [開始]、 按一下 [執行]、 輸入regsvr32 Msident.dll 開啟] 方塊中,然後按一下[確定]。Msidntld.dll 檔案,請重複此程序。如果您沒有註冊的 Msident.dll 和 Msidntld.dll 檔案是否正確,您仍然收到錯誤訊息。
沒有 Outlook 明示的登錄機碼
如果您在登錄中沒有 Outlook Express 的登錄機碼,重新命名 Msident.dll 檔案,並 Msidntld.dll 檔案,然後解除安裝並重新安裝 Outlook Express。
如需有關如何變更的檔案名稱的詳細資訊,請按一下 [開始],按一下 [說明],鍵入 [搜尋] 索引標籤中的 [變更檔案或資料夾的名稱,然後按一下該清單中的主題。