Lync Server 2010 移動流覽-CsLegacyUser 會在舊版使用者遷移之前刪除舊版使用者原則時失敗

徵狀

當您將舊版 Office 通訊伺服器的啟用中的使用者遷移至 Lync Server 2010 池中時,Lync Server 2010 CsLegacyUser PowerShell Cmdlet 會失敗,並提供下列其中一個或所有錯誤:

CsLegacyUser :不會遷移「撥號計畫」類型的所有原則。 執行匯入-CsLegacyConfiguration Cmdlet 來遷移所有原則。 如需不需遷移之原則的詳細資訊,請參閱「CN = {83933C77-5884-4BF4-B8AC-123A39254142} \0ADEL:07aabf08-6701-4a36-a9a9-a778010d85fc、CN = 已刪除的物件、CN = CONFIGURATION、DC = CONTOSO、dc = com」。 在第一行:1個字元: 18 + CsLegacyUser <<<<  身分識別 "jeff@contoso.com"-目標 "pool01.contoso.com" + CategoryInfo: InvalidOperation:(CN = 李明 Anders .。。contoso,DC = com: OCSADUser) [CsLegacyUser],MoveUserException + FullyQualifiedErrorId: MoveLegacyUserError,,

CsLegacyUser :不會遷移「會議」類型的所有原則。 執行匯入-CsLegacyConfiguration Cmdlet 來遷移所有原則。 如需無法遷移之原則的詳細資料,請參閱 "CN = {1815ED7B-A539-4117-9283-E8DD27CD393E} \0ADEL: 678f6d55-1f9c-4825-ba9f-05ce2aa46cb3,CN = 已刪除的物件,Cn = CONFIGURATION,DC = CONTOSO,dc = com」。 在第一行:1個字元: 18 + CsLegacyUser <<<<  身分識別 "jeff@contoso.com"-目標 "pool01" + CategoryInfo: InvalidOperation:(CN = 李明 Anders .。。contoso,DC = com: OCSADUser) [CsLegacyUser],MoveUserException + FullyQualifiedErrorId: MoveLegacyUserError,,

CsLegacyUser :不會遷移「Voice」類型的所有原則。 執行匯入-CsLegacyConfiguration Cmdlet 來遷移所有原則。 如需不需遷移之原則的詳細資訊,請參閱「CN = {8DD5A104-9069-49B9-AB68-A09FB92ECF9C} \0ADEL:5e14b3b5-cc32-4e65-a72e-592b9cfa1972、CN = 已刪除的物件、CN = CONFIGURATION、DC = CONTOSO、dc = com」。 在第一行:1個字元: 18 + CsLegacyUser <<<<  身分識別 "jeff@contoso.com"-目標 "pool01.contoso.com" + CategoryInfo: InvalidOperation:(CN = 李明 a = ers .。。contoso,DC = com: OCSADUser) [CsLegacyUser],MoveUserExceptio + FullyQualifiedErrorId: MoveLegacyUserError,,

原因

將舊版 Office 通訊伺服器設定遷移至 Lync Server 2010 池時,會使用下列三個 Lync Server 2010 PowerShell Cmdlet:

  • Merge-CsLegacyTopology

  • Import-CsLegacyConfiguration

  • Move-CsLegacyUser

本文的 [症狀] 區段所列的 Lync Server 2010 PowerShell Cmdlet 錯誤將會在以下所述的案例中發生:

  • 從 Office 通訊伺服器目錄林全域及語音屬性刪除 [語音]、[撥號] 或 [會議] 的 Office 通訊伺服器使用者原則

  • 使用匯入-CsLegacyConfiguration Lync Server 2010 PowerShell Cmdlet 之後

Lync Server 2010 CsLegacyUser PoweShell Cmdlet 會將舊版 Office 通訊伺服器池中(來源)的語音、撥號計畫及會議的使用者原則資訊與已使用匯入-CsLegacyConfiguration Lync server 2010 PowerShell Cmdlet遷移至 Lync Server 2010 池中(目標)的語音、撥號方案和會議進行比較。 如果沒有相符的原則資訊,舊版使用者移動將會失敗,並出現本文 [症狀] 區段所述的錯誤。

解決方案

若要修正此問題,請安裝下列累加更新:

2514981 Lync Server 2010 (核心元件:2011年11月)累計更新的描述

因應措施

下列兩種方法可讓您成功完成 Lync Server 2010 移動-CsLegacyUser PoweShell Cmdlet:

方法 1

  1. 語音、撥號方案和會議的 Office 通訊伺服器使用者原則,必須在 Office 通訊伺服器池中重新建立,以符合您使用 Import-CsLegacyConfiguration Lync Server 2010 PowerShell Cmdlet 而遷移至 Lync Server 2010 池中的匯入的專案。

  2. 針對語音、撥號計畫及會議重新建立的 Office 通訊伺服器使用者原則,必須重新指派給舊版池中已啟用 Office 通訊伺服器的使用者

    如需執行上述步驟1和2的詳細資料,請參閱下列 Office 通訊伺服器部署資訊:

    Office 通訊伺服器 2007 R2 Enterprise Voice 部署/Redir/fx102821959.aspx 指南 HTTP://technet.microsoft.com/en-us/library/dd441382 (.13) .aspx

    Office 通訊伺服器2007檔:企業語音規劃和部署指南HTTP://www.microsoft.com/download/en/details.aspx?FamilyID=24e72dac-2b26-4f43-bba2-60488f2aca8d&9508 = en

  3. Lync Server 2010 PowerShell Cmdlet Import-CsLegacyConfiguration 遷移步驟將必須再次執行

  4. Lync Server 2010 PowerShell Cmdlet CsLegacyUser 現在可以用來將舊版 Office 通訊伺服器使用者遷移至 Lync Server 2010 池

方法 2

  1. 使用 Lync Server 2010 PowerShell Cmdlet 移動-CsLegacyUser,如下所示:

CsLegacyUser –身分識別 "Jeff Smith" –目標 "pool01.contoso.com"  -ExcludeVoicePolicy  -ExcludeDialPlan-ExcludeConferencingPolicy

當舊版 Office 通訊伺服器使用者成功地遷移至 Lync Server 2010 時,請使用下列資訊,將 Lync Server 2010 語音、撥號計畫及會議原則新增到 Lync 2010 使用者:

修改預設會議使用者體驗

http://technet.microsoft.com/en-us/library/gg429706.aspx

 

允許使用者使用企業語音

http://technet.microsoft.com/en-us/library/gg413011.aspx

其他相關資訊

Lync Server 管理命令介面HTTP://technet.microsoft.com/en-us/library/gg398474.aspx

Move-CsLegacyUser

http://technet.microsoft.com/en-us/library/gg413025.aspx

Import-CsLegacyConfiguration

http://technet.microsoft.com/en-us/library/gg412923.aspx

Merge-CsLegacyTopology

http://technet.microsoft.com/en-us/library/gg425870.aspx

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×