徵狀
使用 Microsoft Dynamics CRM 時先可能會提示使用者提供驗證憑證一次每隔 24 小時。這可能會發生兩個使用者的 web 用戶端,以及 Microsoft Dynamics CRM Outlook 用戶端的使用者。
這才會針對已啟用的宣告驗證的部署。
原因
這個問題的一個可能的原因是,宣告設定 SessionSecurityTokenLifetimeInHours 設定為 24 小時的值。這是預設值。
解決方案
設定 SessionSecurityTokenLifetimeInHours 的宣告必須更新,以 24 以外的項目。在這個特定的執行個體,它被設定為一週。
1.在 [動態伺服器上已安裝的 CRM 探索角色,請開啟 [PowerShell 命令視窗]。
2.從視窗中執行下列命令。$Settings = get CrmSetting SettingType ClaimsSettings DwsServerUrl https://CrmDiscoverServer.domain.com -$creds,發生認證 $Setting.SessionSecurityTokenLifetimeInHours = '168' 設定 CrmSetting-DwsServerUrl https://CrmDiscoverServer.domain.com -認證 $creds $setting
3.完成時,請確認,存留時間值現在是 168 藉由執行下列命令。
取得 CrmSetting SettingType ClaimsSettings DwsServerUrl https://CrmDiscoverServer.domain.com -$creds,發生認證
4.接下來,在主選單伺服器上重新啟動 IIS。
5.最後,重新啟動 Outlook,任何使用者遇到的徵狀 」 一節所述的問題附註:
在上述範例中,URL https://CrmDiscoverServer.domain.com必須以更新探索的伺服器角色,在 Microsoft Dynamics CRM 部署伺服器的 URL。
使用者仍會遇到驗證要求認證的提示,但藉由執行這些指示,這個問題會立即發生每 7 天除非重新啟動 Outlook,及/或您的瀏覽器。重新啟動 Outlook/瀏覽器就會自動更新其安全性語彙基元,並可讓使用者看不到驗證提示。