UEFI 啟用的電腦可能會 「 擱置 」 在黑色的畫面,在啟動程序中的 Windows 7 或 Windows 2008 R2

狀況

請考慮下列情況:

  • 您的電腦需執行 Windows 7 或 Windows Server 2008 R2。

  • 您啟用這台電腦上的整合可延伸韌體介面 (UEFI) 模式。

  • 然後,下列事件會發生在啟動過程︰

    • 如果要在按下 F8 以開啟 [進階開機選項] 功能表,然後按下 esc 鍵取消。

    • 您從 Windows 安裝 DVD 啟動電腦,然後按一下 [修復您的電腦] 選項,以啟動 [Windows 修復環境 (WinRE)。

    • 當載入 Winload.efi 或 Winresume.efi,以及 Windows 修復環境 (WinRE) 就會啟動,就會發生可復原的錯誤。

在案例中,啟動程序可能會停止回應 (停止回應) 在黑色的畫面。

注意這個問題可能比較容易發生時您必須在電腦上安裝 hotfix 980598。

原因

其中一種下列的應用程式不會清除所有分頁表項目可用的頁面,就會發生這個問題︰

  • Windows 作業系統載入器 (Winload.efi) 應用程式

  • Windows 繼續載入器 (Winresume.efi) 應用程式

當 Bootmgfw.efi 應用程式會嘗試清除這些分頁表項目時,此應用程式會存取無效的記憶體位址,並造成存取違規例外狀況。

注意Bootmgfw.efi 的是 Windows 開機管理員應用程式。

解決方案

Hotfix 資訊

支援的 hotfix 可從 Microsoft 取得。不過,此 Hotfix 僅用於修正本文中所述的問題。此 Hotfix 只適用於發生此特定問題的系統上。

如果 hotfix 可供下載,在此知識庫文件頂端將出現「可用的 Hotfix」區段。如果這個區段不會出現,將要求提交給 Microsoft 客戶服務及支援取得 Hotfix。

注意如果發生其他問題,或如果需要進行疑難排解,您可能必須建立個別的服務要求。收取支援費用會套用到其他支援問題和此特定 hotfix 無法解決的問題。如 Microsoft 客戶服務及支援的電話號碼或建立個別的服務要求的完整清單,請造訪下列 Microsoft 網站︰

注意「 下載 Hotfix 」 表單會顯示 hotfix 可用的語言。如果看不到您的語言,是因為未提供該語言的 Hotfix 。

先決條件

若要套用此 hotfix,您必須執行 Windows 7 或 Windows Server 2008 R2 在電腦上。

登錄資訊

若要使用此套件中的 hotfix,您不需對登錄進行任何變更。

重新啟動需求

您不必套用此 hotfix 之後,重新啟動電腦。

Hotfix 取代資訊

此 hotfix 不會取代先前發行的 hotfix。

檔案資訊

此 hotfix 的全域版本安裝檔案具有下列表格中所列的屬性。這些檔案的日期和時間均以國際標準時間 (UTC) 列出。本機電腦上這些檔案是以您當地的時間與目前的日光節約時間 (DST) 的時差來顯示日期和時間。此外,當您在檔案上執行特定作業時,日期和時間可能會變更。

Windows 7 和 Windows Server 2008 R2 檔案資訊附註


重要Windows 7 hotfix 及 Windows Server 2008 R2 hotfix 隨附在相同的套件中。不過,在 [Hotfix 要求] 頁面上的 Hotfix 會在這兩個作業系統下列出。若要要求套用至一或兩個作業系統的 Hotfix 套件,請選取此頁面上列在 Windows 7/Windows Server 2008 R2 之下的 Hotfix。永遠參考文件的〈套用〉一節以判斷實際套用每個 hotfix 的作業系統。

  • 為每個環境所安裝的 MANIFEST 檔案 (.manifest) 及 MUM 檔案 (.mum) 都分別列在「Windows Server 2008 R2 和 Windows 7 的其他檔案資訊」一節。菊及資訊清單檔案,以及相關的安全性類別目錄 (.cat) 檔案中,是非常重要的事維護更新元件的狀態。安全性類別目錄檔案 (將不會為其列出屬性) 是使用 Microsoft 數位簽章簽署的。

適用於所有支援的 Windows 7 x86 版本

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×