Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

狀況

USB 裝置連接到相同的集線器會很慢或完全沒有回應。

原因

已附加至相同的集線器的多個裝置會進入選擇性暫停,但其中集線器上的裝置可以接收喚醒要求。 如果發生這種情況的暫停要求完成之前,裝置就變得不穩定。

因應措施

請嘗試這些方法來解決這個問題。

方法 1 停用及啟用 USB 根集線器

您可以使用 [裝置管理員來停用和重新啟用 [USB 根。這可讓從無法回應的狀況中復原的 USB 連接埠的控制站。



若要停用並重新啟用 [USB 根,請依照下列步驟執行:

  1. 按一下 [開始],然後按一下 [執行]。

  2. 在 [開啟] 方塊中輸入devmgmt.msc,,然後按一下[確定]。會開啟 [裝置管理員。

  3. 展開 [通用序列匯流排控制器]。

    注意您可能必須向下捲動以尋找這個項目清單。

  4. 以滑鼠右鍵按一下受影響的 USB 根集線器,,,然後按一下 [解除安裝,將它移除。

  5. 重新啟動電腦。在電腦啟動之後,Windows 將自動掃描硬體變更,並重新安裝您解除安裝的所有 USB 根集線器。

電腦重新啟動之後,請檢查是否已解決的問題。如果這個方法解決了問題,您便已完成。如果這個方法無法解決問題,請前往方法 2。

方法 2 重新啟動電腦

請嘗試重新啟動電腦。 重新啟動電腦後,請檢查是否已解決的問題。

如果重新啟動電腦,解決問題,您便已完成。如果這個方法無法解決問題,請進行方法 3。

方法 3 停用選擇性擱置 」 功能

如果前述兩種方法對您沒有用,您可以停用選擇性擱置 」 功能。不過,請注意,停用選擇性擱置 」 功能時,所有 USB 主機控制器驅動程式 (並因此所有的 USB 連接埠和連接的 USB 裝置) 系統中會受到影響。因此,您的電腦無法暫停任何 USB 裝置連接到它,而且在 USB 裝置可以繼續使用而連接到電腦的電源。此外,允許電腦關閉這個裝置以節省電源] 核取方塊不會出現在 [USB 根集線器的電源管理] 索引標籤。



您可以藉由編輯登錄,以停用 USB 選擇性暫停功能。因為 「 選擇性擱置 」 功能中的競爭狀況,USB 裝置可能會沒有回應的。「 選擇性擱置 」 功能會暫停有效率地維護,進而將 USB 裝置關閉電腦的電池電力的 USB 裝置。不過,有時候這項功能可能無法正確地喚醒 USB 裝置。因此,USB 裝置沒有回應,當您嘗試使用它。



您可能要停用伺服器的產品,既然電源管理不重要或不需要這項功能。



重要這個章節、 方法或工作包含修改登錄的步驟。不過,如果您不當修改登錄,可能會發生嚴重的問題。因此,請務必小心執行這些步驟。為加強保護,請在修改前備份登錄。然後,您可以在發生問題時還原登錄。如需有關如何備份和還原登錄的詳細資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:

322756如何備份及還原 Windows 中的登錄若要停用選擇性擱置 」 功能,請依照下列步驟執行:

  1. 按一下 [開始],然後按一下 [執行]。

  2. 輸入regedit,然後按一下[確定]。登錄編輯器隨即開啟。

  3. 找到並按一下下列登錄子機碼: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USB

  4. 如果DisableSelectiveSuspend登錄項目存在,請將它連按兩下。如果不存在,請建立項目。若要建立的項目,請依照下列步驟執行:

    1. 在 [編輯] 功能表中,指向 [新增],然後按一下DWORD。

    2. 輸入DisableSelectiveSuspend,然後再按 ENTER 鍵。

    3. 按一下 [編輯] 功能表的 [修改]。

  5. 在 [數值資料] 欄位中,輸入1 ,若要停用 「 選擇性擱置 」 功能,然後按一下[確定]。

  6. 結束登錄編輯程式。

狀態

Microsoft 已確認這是在 Windows XP SP2 和 SP3 上 USB 子系統中的問題。

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×