連結的資料類型常見問題集和祕訣

套用到
Microsoft 365 Excel Mac 版 Microsoft 365 Excel Excel 2024 Mac 版 Excel 2024 Excel 2021 Mac 版 Excel 2021

您可以對 連結的資料類型執行許多動作。 無論您是要參考公式中的連線資料類型,或只是瞭解某些限制,請查看下列內容,以瞭解有關如何充分利用 Excel 中的資料類型的詳細資訊。

常見問題集

如何存取連結的資料類型? 有什麼需求?

注意

連結的資料類型僅適用 (標準 Microsoft 365 帳戶) 全球多租用戶用戶端。

若要存取連結至外部資料來源的資料類型,例如 Bing,您必須符合下列需求。 若要查看目前可用的資料類型,請參閱 Excel 中提供哪些連結的資料類型? 

股票和地理位置資料類型

  • 擁有有效的 Microsoft 365 訂閱 或免費的 Microsoft 帳戶。

  • 將英文、法文、德文、義大利文、西班牙文或葡萄牙文編輯語言新增至 Office 語言喜好設定。 最終可能會新增其他語言。

  • 使用最新的 Excel 應用程式或 Excel 網頁版。

    注意

    如果您沒有 Microsoft 365 訂閱,則只有在使用 Microsoft 帳戶登入 Excel 網頁版時,才能使用這些資料類型。 

存取連結的資料類型時發生錯誤

如果您已開啟含有資料類型的活頁簿,或嘗試變更或重新整理資料類型,而您收到無法存取這些資料類型的錯誤訊息,請嘗試下列步驟:

  • 請確定您是使用與您 Microsoft 365 訂閱相關聯的帳戶登入 Excel。
  • 移至 [ 檔案>帳戶> ],並確定 Excel 有最新的更新。 如果您使用的是 Excel 網頁版,請移至 [ 檔案>資訊]。 對於 macOS,請在功能表列上選取 [說明>檢查匯報],然後安裝任何可用的更新。
  • 檢查以確定您符合取得資料類型的需求。
  • 如果您仍然遇到問題,請嘗試在 Excel 網頁版中開啟該活頁簿。

注意

您可能原本在只支援檢視連結資料的 Excel 版本中開啟了具有資料類型的活頁簿。 例如,活頁簿包含 [股票] 資料類型,因此您仍然可以檢視卡片或存取欄位。 不過,您將無法重新整理或變更資料類型。 若要使用資料類型,請確定您是使用與您的訂閱相關聯的帳戶登入 Excel 網頁版。

有哪些類型的連結資料類型?

有數種可用的資料類型。 若要查看類型及其位於的功能區按鈕,請參閱 Excel 中提供哪些連結資料類型? 

連結的資料類型會從線上來源(例如 Bing)提取可靠的資料。 如果要查看特定資料類型的類型或來源,可以選取儲存格中的資料類型圖示以開啟卡片,然後捲動到底部以尋找有關資料提供者和資料類型的資訊。

如何為資料類型提供意見反應

我們會持續努力改善 Excel 資料類型。 如果找不到結果、資料不正確或遺失,或無法完成任務... 請告訴我們! 我們會使用您的寶貴意見反應來改善體驗和功能。

我們需要哪些意見反應?

  • 資料品質 (錯誤、不適當、不完整等等)
  • 資料覆蓋率 (遺漏資料)
  • 您的體驗 (使用資料類型和資料)
  • 建議與想法

關於股票、地理位置的資料品質

  1. 一旦您轉換成資料類型,請在儲存格中選取 [資料類型] 圖示以開啟卡片。
  2. 下滑至卡片底部,然後選取旗幟圖示。
  3. 如果您使用的是電腦版 Excel) ,請填寫簡短的問卷 (並提交。 您說明的越明確,我們就能更輕鬆地瞭解問題並加以修正。

選取卡片底部的旗幟圖示。

如需有關資料涵蓋範圍的意見反應

  1. 轉換為某種資料類型後,您可能會在儲存格中看到藍色問號。 這表示我們無法找到或比對結果。 如果 [資料選取器] 尚未開啟,請選取此圖示。
  2. 在 [資料選取器] 窗格中,選取 [ 提供意見反應]。
  3. 填寫簡短問卷並提交。 您說明的越明確,我們就能更輕鬆地瞭解問題並加以修正。

如需一般資料類型意見反應或建議

您也可以直接從 Excel 應用程式傳送關於您使用資料類型的整體體驗的一般意見反應。

  1. 移至 [說明 ] 索引標籤 >的 [意見反應]。 如需詳細資訊,請參閱如何?提供有關 Microsoft Office 的意見反應。
  2. 告訴我們您喜歡或不喜歡的內容,或有建議的相關資訊。 如需詳細資訊,請提交表單。

可以。 取消連結儲存格的方式可讓您移除與參照資料類型的公式連線。 如果您使用的是電腦版 Excel,請選取具有連結資料類型的儲存格,然後在 Mac 上按 Ctrl+C 或 Cmd+C 以複製它。 在 Mac 上按 Ctrl+ALT+V 或 Cmd+Control+V ,然後選擇 [值]。 這會將資料類型貼到新儲存格,而且您不會失去與資料提供者的連線。

如果我將活頁簿傳送給同事或朋友,對方是否可以使用這種新的資料類型?

可以,但必須 符合需求 ,才能使用特定資料類型。 如果您將活頁簿傳送給不符合需求的人員,他們仍然可以看到資料類型的資料,但是無法變更或重新整理資料。

此功能是否可以在其他的 Excel 版本中使用?

目前,只有 Microsoft 365 Excel 和 Excel 網頁版支援連結的資料類型。 如果您使用 不 支援的 Excel 版本開啟這些新的資料類型, #VALUE! 將會顯示於這些儲存格中。 #NAME 呢?會出現在取代任何參照這些資料類型的公式的位置。

填滿控點是否適用於資料類型?

是。 大部分的 Excel 功能都可與資料類型搭配使用,而我們也持續努力改善整合。 當列或欄具有相同的資料類型,而且您要使用相同的欄位填入儲存格時,[填滿控點] 可正常運作。 如果該欄位沒有資料或遺失,您會收到 #FIELD 錯誤。

您也可以在資料類型清單的最後一個儲存格中輸入要轉換的文字,Excel 會自動嘗試比對您的文字以進行轉換。

是否有任何已知的其他限制?

連結資料類型的傳統 Excel 功能可能無法正常運作。 例如,如果您根據資料類型的資訊建立樞紐分析表,就只能使用明確新增至工作表的資訊。 此外,在樞紐分析表、Power Query 或甚至一些圖表中使用這些資料類型時,可能無法如預期般運作。 

這些資料類型提供哪些語言版本?

某些資料類型目前僅提供特定語言版本。 若要存取和使用它們,您可以將編輯語言新增至 Office 語言喜好設定。

  • 股票和地理位置資料類型:僅限英文、西班牙文、法文、德文、義大利文和葡萄牙文。 我們正在努力在未來新增更多語言。

祕訣和訣竅

快速輕鬆的鍵盤快速鍵

開啟卡片:

若為 Windows 按 Ctrl+Shift+F5 ,若為 Mac 按 Cmd+Shift+F5 。

如何重新整理資料

連結的資料類型連線至線上資料來源。 將文字轉匯成連結資料類型之後,活頁簿中會建立外部資料連線。 這樣一來,如果資料在線上變更,您可以在 Excel 重新整理資料以更新資料。

若要重新整理資料,請以滑鼠右鍵按一下具有連結資料類型的儲存格,然後按一下 [資料類型>重新整理]。 這會重新整理您選取的儲存格,以及含有相同資料類型的任何其他儲存格。

如果要重新整理所有連結的資料類型和活頁簿中的所有資料連線 (包括查詢、其他資料連線和樞紐分析表) ,請按一下 [全部>重新整理資料]。

從資料類型卡插入影像

使用資料類型卡,您可以獲取比一般值更多的資訊。 某些資料類型卡片,例如 [地理] 資料類型的卡片,包含您可以插入至活頁簿中的影像。 這些影像包含在儲存格內,就像任何文字或數字一樣。

  1. 選取儲存格並移至 [資料 ] 索引標籤 >的 [資料類型 ] 群組,然後選取您想要的資料類型,以將文字轉換成資料類型。
  2. 轉換完畢後,儲存格的值就會出現一個圖示。 選取以查看卡片。
  3. 在卡片中,將游標停留在影像上,您會看到 [插入資料新增欄] 按鈕 圖示。 選取此圖示,將影像插入到活頁簿中。
  4. 該影像會縮放以配合儲存格大小。 若要調整其大小,只要調整列或欄以增加儲存格的大小即可。

要將資料類型轉換回文字以移除。

如果您不想讓儲存格成為連結的資料類型,只要以滑鼠右鍵按一下儲存格,然後按一下 [資料類型>轉換成文字] 即可。 資料類型會隨即移除、不再有線上連線,而且儲存格中的值已轉換成文字。

重要

如果您將資料類型轉換成文字,任何已從該資料類型擷取值的資料行或公式都會顯示該 #FIELD! 錯誤。

撰寫參照資料類型的公式

資料類型以及您從中插入的資料可用於公式和計算,就像其他資料一樣。  您也可以撰寫參照連結資料類型中之值的公式,即使您的資料不在資料表中也是一樣。 如需詳細資訊,請參閱 如何撰寫參照資料類型的公式。

排序及篩選

[篩選] 功能表、[顯示值] 功能表、所列連結資料類型的欄位

您可以使用欄標題上的篩選按鈕,隨時排序和篩選 Excel 中的資料 (按一下 [資料>篩選器] 來開啟篩選按鈕。)

但如果您使用的是電腦版 Excel,這裡有一個具有資料類型的儲存格提示: 按一下具有圖示之儲存格上方的篩選按鈕。 接著,決定您想要的排序或篩選方式。 如果要使用顯示名稱來執行此操作,請保持選取 [選取欄位] 底下的 [顯示值]。 如果要使用連結資料類型中的另一個欄位來執行排序或篩選,請在 [選取欄位] 底下選取該欄位。

在此範例中,我們選取的欄位是 [區域]。 Excel 接著使用這個作為下方篩選核取方塊的基礎,並顯示資料表中國家/地區的人口。

同時,也請記得:Excel 會依據您在 [選取欄位] 底下所選的欄位,來變更 [數字篩選] 功能表。

深入了解連結的資料類型

Excel 資料類型:股票和地理位置

將 Excel 連線至 Power BI 語意模型

建立資料類型 (Power Query)