症狀
當嘗試透過 Outlook 資料夾窗格Microsoft Microsoft Dynamics 365 Outlook 外掛程式 (Outlook 用戶端) 來渲染網頁時,檢視窗格仍是空白,且顯示「正在等待從 CRM 伺服器檢索頁面......」的訊息。展示。 這個面板從未載入對應的網頁。
原因
Dynamics 365 for Outlook 外掛依賴自訂的漫遊首頁來在 Outlook 中渲染網頁。 2017 年 10 月的 Microsoft Outlook 安全更新會停用 Outlook 中的漫遊首頁,以解決應用程式的重大漏洞,因此意外導致外掛程式失敗。
關於此問題發生的原因,請參閱 Outlook 的以下文章:
版本管理資訊
所有版本的 Microsoft Dynamics 365 for Microsoft Outlook 外掛程式都受到此問題影響。 這包括 Microsoft Dynamics CRM 2016 for Microsoft Office Outlook、Microsoft Dynamics CRM 2015 for Microsoft Office Outlook 以及 Microsoft Dynamics CRM 2013 for Microsoft Office Outlook。
這也影響了該外掛所連接的所有 Dynamics 365/CRM 組織版本。
Outlook 安全性更新版本資訊如下:
Microsoft Outlook 2010 (KB4011089) 32 位元版的安全更新
64 位元版Microsoft Outlook 2010 (KB4011089) 安全更新
32 位元版Microsoft Outlook 2010 (KB4011196) 安全更新
64 位元版Microsoft Outlook 2010 (KB4011196) 安全更新
32 位元版Microsoft Outlook 2013 (KB4011178) 安全更新
64 位元版Microsoft Outlook 2013 (KB4011178) 安全更新
Microsoft Outlook 2016 (KB4011162) 32 位元版的安全更新
Microsoft Outlook 2016 (KB4011162) 64 位元版的安全更新
未來任何累積的 Outlook 更新都會包含這些安全匯報,並會導致此問題發生,例如以下更新:
32 位元版Microsoft Outlook 2013 (KB4011252) 更新
64 位元版Microsoft Outlook 2013 (KB4011252) 更新
Microsoft Outlook 2016 (KB4011240) 32 位元版更新
Microsoft Outlook 2016 (KB4011240) 64 位元版更新
解決方式
對於 Office Outlook 的點擊執行安裝,這個問題已在 2018 年 3 月初發布的月度頻道中解決。 請確保您擁有最新的 Office Outlook 更新:
如何安裝 Microsoft Outlook 最新的適用更新
對於 MSI 安裝的 Office Outlook,這個問題在 2018 年 8 月 14 日針對 Microsoft Office Outlook 2010、2013 和 2016 的安全更新中得到解決:
Outlook 2010 安全更新:2018 年 8 月 14 日 KB4032222
Outlook 2013 安全更新:2018 年 8 月 14 日 KB4032240
Outlook 2016 安全更新:2018 年 8 月 14 日 KB4032235
安裝上面那個與你 MSI 版本相符的 Office Outlook 更新,頁面就能正確顯示。
更多資訊
此問題的症狀與 2018 年 8 月 Office Insider 更新後的點擊執行 Office 安裝類似。 關於此議題的更多資訊,請參閱以下網站:
Microsoft Dynamics 365 for Outlook 安裝 2018 年 8 月的 Office Insider 更新後無法渲染網頁
關於本次安全更新的更多資訊,請參閱以下連結: