套用 6 月更新 KB4291497 或 KB4291495 之後,出現 "0x80092004" 錯誤,並且 2018 年 7 月 .NET 安全性和品質彙總套件更新 KB4340557 或 KB4340558 無法安裝

適用於: .NET Framework 4.7.1Microsoft .NET Framework 4.7Microsoft .NET Framework 4.6.2

本文也適用於 .NET Framework 4.7.2。

摘要


本文說明在執行於 .NET Framework 4.7.2、4.7.1、4.7、4.6.2、4.6.1 或 4.6 上的系統安裝 2018 年 6 月 .NET Framework 品質彙總套件預覽更新 KB4291497KB4291495 之後,當使用者嘗試在 Windows 8.1、Windows Server 2012 R2 或 Windows Server 2012 上安裝 2018 年 7 月安全性和品質彙總套件更新 KB4340557KB4340558 時,可能會遇到 "0x80092004" 錯誤。

徵狀


請試想下列案例:

  • 您在 Windows 8.1、Windows Server 2012 或 Windows Server 2012 R2 上使用 .NET Framework 4.6 或更新版本。
  • 您先前已安裝 2018 年 6 月品質預覽更新 KB4291497KB4291495
  • 您嘗試安裝 2018 年 7 月安全性和品質彙總套件更新 KB4340557KB4340558

在這個案例中,更新無法安裝,並且您收到 "0x80092004" 安裝錯誤訊息。

注意:若要驗證您已安裝哪些更新,請選取 [開始] 按鈕,然後選取 [設定] > [變更電腦設定] > [更新與復原] > [Windows Update] > [檢視您的更新記錄]

解決方案


Microsoft 已經重新發行 2018 年 7 月 .NET Framework 安全性和品質彙總套件更新 KB 4340558 和 KB 4340557,以更正安裝問題。 您可以透過 Windows Update 掃描這些更新, 也可以直接從下列知識庫文章下載並安裝這些更新:

適用於 Windows 8.1、RT 8.1 以及 Server 2012 R2 之 NET Framework 3.5 SP1、4.5.2、4.6、4.6.1、4.6.2、4.7 和 4.7.1 的安全性和品質彙總套件更新 (KB 4340558)

適用於 Windows Server 2012 之 .NET Framework 3.5 SP1、4.5.2、4.6、4.6.1、4.6.2、4.7 和 4.7.1 的安全性和品質彙總套件更新 (KB 4340557)

狀態


這個問題已經獲得解決。 如需詳細資訊,請參閱<解決方案>一節。