選擇最能描述典型 Outlook 搜尋問題的案例:
傳統 Outlook 搜尋不會傳回任何結果
當您使用 Outlook 搜尋沒有得到任何結果時,請按照提供的順序執行以下步驟:
執行 Windows 搜尋疑難排解員
-
在 Windows 11 中: 選取 [開始] 按鈕,選取 [設定>] [隱私權] & [安全性],然後在 [Windows 權限] 下尋找並選取 [搜尋 Windows]。 向下捲動並選取 索引子疑難排解員。
-
在 Windows 10 中: 選取 [開始] 按鈕,選取 [設定>更新] & [安全性],然後選取 [疑難排解]。 尋找並選取 [搜尋和索引],然後選取 [ 執行疑難排解員]。
確認傳統 Outlook 中的索引編制已完成
啟動傳統 Outlook,然後選取 [搜尋 方塊]。
在功能區中,選取 [搜尋工具>] 功能表中的 [索引狀態]。
當 [索引狀態 ] 對話方塊出現時,您應該會看到下列內容:
如果傳統版 Outlook 尚未完成編製索引,請記下剩餘的項目要編製索引,等候五分鐘,然後再次檢查。 如果項目數量未減少,繼續進行下一個步驟。
檢查資料檔已選取
- 啟動傳統 Outlook,然後選取 [搜尋 方塊]。
- 在功能區中,從 [搜尋] 功能表中選取 [搜尋工具>][要搜尋的位置]。
- 確認已選取所有已列出的資料檔/存放區。
確認 Windows Search 服務已啟用並執行中
- 選取 Windows [開始] 功能表,然後選取 [搜尋 ] 方塊。
- 輸入 services.msc ,然後按下 Enter。
- 在 [ 名稱 ] 欄底下,尋找並按兩下 [Windows Search]。
- 如果尚未啟用啟動類型,請將啟動 類型 設定為 [ 自動 (延遲啟動) ]。
- 如果 服務狀態 未顯示 [執行中],請選取其下方的 [開始 ] 按鈕以啟動服務。
在索引中包含傳統 Outlook 資料
- 結束傳統版 Outlook。
- 在 Windows 控制台,開啟 [索引選項]。
- 在 [編製索引] 對話方塊中,確認 Microsoft Outlook 已列在 [包含位置] 欄中。
- 如果未列出 Microsoft Outlook ,請選取 [修改],然後選取以啟用 Microsoft Outlook 旁邊的核取方塊。
- 選取 [確定],然後選取 [關閉]。
請遵循下列步驟,確認索引選項已正確設定:
- 結束傳統版 Outlook。
- 在 Windows 控制台,開啟 [索引選項]。
- 在 [索引選項] 對話方塊中,選取 [進階]。
- 選取 [檔案類型] 索引標籤。
- 向下捲動,直到您在 [副檔名] 欄中找到 [msg],然後選取此項目。
- 確認 [索引檔案屬性和內容] 選項已啟用。
- 選取 [確定],然後選取 [關閉]。
注意
請確認 [篩選器說明] 欄顯示 Office Outlook MSG IFilter。 如果沒有,表示 Windows Search 服務無法正常運作,或是 Microsoft Outlook 無法正確安裝篩選器。 在任一種情況下,您應該連絡 Microsoft 支援服務,取得有關此問題的協助。
重建傳統版 Outlook 的搜尋目錄
- 結束傳統版 Outlook。
- 在 Windows 控制台,開啟 [索引選項]。
- 在 [索引選項] 對話方塊中,選取 [進階]。
- 在 [進階選項] 對話方塊,選取 [重建]。
- 選取 [確定],然後選取 [關閉]。
如果索引編製未完成,請連絡 Microsoft 支援服務以要求有關 Windows 桌面搜尋的協助。
檢查傳統版 Outlook 的新設定檔中的搜尋功能是否可運作
請依照下列步驟,建立新的設定檔並測試搜尋:
- 在傳統 Outlook 中,選取 [檔案>帳戶設定>] [管理設定檔]。 或者,您可以結束 Outlook,並在 Windows 控制台中開啟 郵件 。
- 在 [郵件設定 - Outlook] 對話方塊,選取 [顯示設定檔],然後在 [一般] 索引標籤中選取 [新增]。
- 在 [設定檔名稱] 方塊,輸入新的設定檔名稱,然後選取 [確定]。
- 如果出現提示,請提供帳戶資訊,例如電子郵件地址和密碼,然後選取 [下一步]。
- 選取 [完成]。 您會發現新增的新設定檔名稱列在 [郵件] 對話方塊的 [一般] 索引標籤中。
- 在 [啟動 Microsoft Outlook 時,使用這個設定檔] 下方,選擇 [提示使用的設定檔],然後選取 [確定]。
- 重新啟動 Outlook。
- 在 [選擇設定檔] 對話方塊的下拉式清單中,選擇您所建立的新設定檔名稱,然後選取 [確定]。
- 選取 [搜尋 ] 方塊並嘗試搜尋。
如果搜尋正常運作,則可能是舊設定檔有問題。 您可以將這個設定檔設定為新的預設設定檔,並將資訊從舊設定檔移轉至新設定檔。
使用篩選來縮小搜尋範圍並顯示較舊的電子郵件訊息
搜尋較舊的結果時,您可以使用篩選來縮小搜尋準則。 如果傳統版 Outlook 找到太多結果,可能不會顯示較舊的項目。 如需如何使用篩選的詳細資訊,請移至 瞭解 在 Outlook 中縮小搜尋準則。
從控制台修復 Office
存取修復工具的步驟依作業系統而異。
Windows 10 或 11
以滑鼠右鍵按一下 [開始] 按鈕
,在 Windows 11 中選取 [已安裝的應用程式],或在 Windows 10 中選取快顯功能表上的 [應用程式與功能]。
選取您要修復的 Microsoft Office 產品,然後選取 [修改]。 如果您沒有看到任何選項,請選取右側的三個點。
注意
這將會修復整個 Office 套件,即使您只想修復某個應用程式 (例如 Word 或 Excel)。 如果您已安裝獨立版本的 App,則可以依名稱搜尋該應用程式。
視您的 Office 是隨選即用或 MSI 型安裝而定,您會看到下列選項以繼續進行修復。 請依照適用您安裝類型的步驟進行。
隨選即用
在 [您要 如何修復您的 Office 程式] 視窗中,選取 [ 線上修復>修復] 以確保一切都修復完畢。 (您也可以使用較快的 [快速修復] 選項,但它只能偵測然後取代損毀的檔案)。
MSI 型
在 [變更您的安裝] 中,選取 [修復],然後按一下 [繼續]。
依照畫面上的指示完成修復。
解除安裝並重新安裝 Office
使用解除安裝疑難排解員從 Windows 電腦解除安裝 Microsoft 365、Office 2021、Office 2019 或 Office 2016。
選取下方的按鈕,以啟動解除安裝疑難排解員。
如果您收到彈出視窗,指出 此網站正在嘗試開啟 [取得協助],請按一下 [開啟]。
依序完成其餘的畫面上的提示,並在出現提示時重新啟動您的電腦。
針對您要安裝或解除安裝的 Office 版本選取步驟。
Microsoft 365 | Office 2024 | Office 2021Office | 2019 | Office 2016
重要
- 解除安裝疑難排解員目前無法解除安裝 Office 2024。
- 在安裝您要解除安裝的 Microsoft 365 或 Office 產品同一台 Windows 電腦上執行疑難排解員。
- 您必須使用 Windows 10 或更新版本,才能執行疑難排解員。
秘訣
如果 Microsoft 365 解除安裝疑難排解員未能從電腦完全移除 Microsoft 365 或 Office,您可以嘗試 手動解除安裝 Office。
傳統 Outlook 搜尋傳回不完整的結果,或找不到較舊的電子郵件
當您使用 Outlook 搜尋取得不完整的結果時,請依照提供的順序執行下列步驟:
包含 [刪除的郵件] 資料夾
如果遺失的搜尋結果位於 [刪除的郵件] 資料夾中,您可以將此資料夾新增至搜尋結果中:
- 啟動傳統 Outlook。
- 選取 [ 檔案>選項],然後選取 [搜尋]。
- 選取 [在所有項目中搜尋時,包括每個資料檔中刪除的郵件] 資料夾中的郵件核取方塊,然後選取 [確定]。
- 重新啟動 Outlook。
增加同步處理滑桿以下載過去的電子郵件
您可以在電子郵件帳戶的離線設定中增加時間,以便將更多或所有電子郵件快取到本機以編製索引。 方法如下:
- 啟動傳統 Outlook。
- 選取 [檔案>帳戶設定>] [帳戶設定]。
- 在 Email 索引標籤上,選取您的電子郵件帳戶,然後選取 變更。
- 將 過去的下載電子郵件 : 滑桿拖曳到所需的時間量,或拖曳至最右邊的 [全部]。
- 選取 [下一步 ],然後選取 [完成]。 關閉視窗並重新啟動 Outlook。
選取 [目前資料夾] 作為搜尋範圍,僅針對 封存 信箱) 中不完整的搜尋結果 (
當您在傳統 Outlook 中使用 [所有信箱] 或 [所有 Outlook 項目] 範圍進行搜尋時,會針對封存信箱傳回有限或未傳回任何結果。 您只能搜尋資料夾本身,以搜尋移至自動展開封存信箱的項目。 在資料夾清單中選取封存資料夾,以選取 [目前資料夾 ] 選項做為搜尋範圍。 如果自動展開儲存區域中的資料夾包含子資料夾,您必須分別搜尋每個子資料夾。 如需詳細資訊,請移至 Microsoft 365 中無限制封存的概觀。
共用信箱:搜尋結果的問題
如果您沒有從共用信箱搜尋中得到預期的結果,或收到錯誤,請遵循下列其中一個步驟:
如果您使用 [所有信箱] 範圍,則不會傳回任何結果
若要搜尋共用信箱,請選取該信箱並使用 目前資料夾 範圍。 這是設計限制,不會隨著未來的更新而改變。 移至 瞭解搜尋範圍 部落格 ,以深入瞭解何時支援哪些範圍的詳細資料。
若要解決此問題,您可以將共用信箱新增為設定檔中的次要 Exchange 帳戶。 首先,您需要檢查共用郵箱是否已在設定檔中列為帳戶。 如果是這樣,您將不得不將其刪除。 若要這麼做,請按照下列步驟進行:
- 從 [檔案 ] 功能表中,選取 [ 帳戶設定],然後再次選擇 [帳戶設定 ]。
- 按兩下 Exchange 帳戶。
- 選擇 [其他設定],然後選取 [ 進階 ] 索引標籤。
- 在 [開啟這些其他信箱 ] 區段中,選擇共用信箱,然後選取 [ 移除]。
依照下列步驟,將共用信箱新增為設定檔的次要帳戶:
- 從 [檔案 ] 功能表中,選取 [新增帳戶]。
- 在此對話方塊中,輸入信箱的完整名稱,例如 support@company.com。
- 當系統提示您輸入密碼時,請選擇 [以另一個帳戶登入 ,並使用具有共用信箱權限的 Exchange 帳戶認證] 選項。