當您發布與 Microsoft Dynamics NAV 2009 服務包 1 中工作相關的工作日誌、採購訂單或購買發票時,會出現錯誤訊息:「您沒有權限修改價值輸入表中的紀錄」

套用到
Dynamics NAV 2009 Service Pack 1

快速發表的文章直接提供來自 Microsoft 支援組織內部的資訊。 本書所含資訊是針對新興或獨特主題所創建,或旨在補充其他知識庫資訊。

本文適用於 Microsoft Dynamics NAV 2009,適用於所有國家及所有語言地區。

症狀

當您發布與 Microsoft Dynamics NAV 2009 服務包 1 中工作相關的工作日誌、採購訂單或採購發票時,您會收到以下錯誤訊息:

注意

您沒有權限修改值輸入表中的紀錄。

原因

此問題發生於「工作 Jnl.-Post Line」 (1012) 缺少「值輸入」資料表的權限。

解決方式

Hotfix 資訊

Microsoft 現在已經支援熱修補程式。 然而,這僅是為了修正本文所描述的問題。 只應用在遇到這個特定問題的系統上。 此熱修補可能會進行額外測試。 因此,如果您未受到此問題嚴重影響,我們建議您等待下一個 Microsoft Dynamics NAV 2009 服務包或包含此熱修補的 Microsoft Dynamics NAV 版本。

注意:在特殊情況下,若 Microsoft Dynamics 及相關產品的技術支援專業人員判斷特定更新能解決您的問題,通常因支援電話而產生的費用可能會被取消。 一般來說,如果有所描述之特定更新無法解決的其他支援問題,才會收取支援費用。

            
          

安裝資訊

Microsoft 僅提供圖例的程式設計範例,不含明示或暗示的擔保。 這包括 (但不限於) 適用于特定目的之可操作性或適用性的暗示擔保。 本文假設您熟悉正在示範的程式設計語言,以及用來建立和進行程式偵錯工具的工具。 Microsoft 技術支援工程師可以協助說明特定程序的功能,但不會修改這些範例以提供附加功能或建構程序來滿足您的特定需求。

注意:安裝此熱修補程式前,請確認所有 Microsoft Navision 用戶端使用者都已登出系統。 這包括Microsoft Navision 應用服務 (NAS) 用戶端使用者。 當你實施這個熱修補時,應該只有你一個登入的客戶端使用者。

要實作這個熱修補,你必須擁有開發者授權。

我們建議在 Windows 登入視窗或資料庫登入視窗中,將使用者帳號分配「SUPER」角色 ID。 若使用者帳號無法被指派「SUPER」角色 ID,您必須驗證該帳號擁有以下權限:

  • 你要更改的物件的修改權限。
  • 系統物件 ID 5210 的執行權限,以及系統物件 ID 9015 的執行權限。

                
注意:除非你必須進行資料修復,否則你不必擁有資料儲存的權利。

法規變更

注意:在將修正程式套用到生產電腦之前,務必在受控環境中測試修正。
為了解決此問題,在「工作 Jnl.-Post Line」碼單元 (1012) 的權限屬性中,新增包含讀取權限的表格 5802,內容如下:

物件識別碼 物件名稱 閱讀許可 插入許可 修改權限 刪除權限
5802 價值進入

          

先決條件

您必須安裝 Microsoft Dynamics NAV 2009 Service Pack 1 才能套用此熱修補。

移除資訊

你無法移除這個熱修正。

狀態

Microsoft 已確認這是「適用對象」一節中列出的 Microsoft 產品中的問題。

MICROSOFT及/或其供應商對本網站所發布文件及相關圖像中所載資訊的適用性、可靠性或準確性 (「資料」) 不作任何保證或保證。

資料可能包含技術性不準確或印刷錯誤,且可隨時修訂,恕不另行通知。 在適用法律允許的最大範圍內,MICROSOFT 及/或其供應商否認並排除所有明示、默示或法定的陳述、保證及條件,包括但不限於所有權、非侵權、令人滿意的狀態或品質、適銷性及特定用途的適用性。