症狀
安裝 Microsoft Exchange Server 2016 累積更新 8 (CU8) 之後,如果雲端信箱未啟用封存功能,則混合式環境中從 Microsoft Office 365 使用者到內部部署信箱的空閒/忙碌查詢會失敗。
原因
發生此問題的原因是已知問題會影響 Exchange Server 2016 CU8 中的 OAuth 連線能力。
因應措施
若要解決此問題,請為每個雲端信箱建立個人封存信箱。
解決方式
若要修正此問題,請安裝 Exchange Server 2016 的累積更新 9 或 Exchange Server 2016 的較新累積更新。
更多資訊
若要確認您是否遇到此問題,請使用 Test-OAuthConnectivity Cmdlet 。
例如,連線到 Office 365 的遠端 PowerShell,然後執行
Test-OAuthConnectivity -Service EWS -TargetUri https://< 內部部署 EWS URL>/ews/Exchange.asmx -Mailbox <雲端信箱>
如果您的案例相符,此 Cmdlet 會產生下列回應:
Exchange 回應詳細資料:
HTTP 回應訊息:
例外狀況:
System.Net.WebException:遠端伺服器傳回錯誤: (500) 內部伺服器錯誤。
位於 System.Net.HttpWebRequest.GetResponse ()
位於 Microsoft.Exchange.Monitoring.TestOAuthConnectivityHelper.SendExchangeOAuthRequest (ADUser user, String orgDomain, Uri targetUri, String& diagnosticMessage, Boolean appOnly, Boolean useCachedToken, Boolean reloadConfig)
狀態
Microsoft 已確認這是「適用對象」一節中列出的 Microsoft 產品中的問題。
參考資料
了解 Microsoft 用來說明軟體更新的術語。