症狀
假設你在 2014 SQL Server Microsoft 透過多個活躍結果集 (MARS) 連線建立叢集欄位儲存索引。 當你設定 maxdop 值大於 1 時,建立或重建叢集欄位儲存索引就會失敗。 此外,您收到的錯誤 35377 類似以下內容:
注意
錯誤編號:35377
錯誤嚴重度:EX_USER
ErrorOwner: <OwnerName>
rrorFormat:當 MARS 開啟時,不允許存取叢集欄位儲存索引。
錯誤原因:MARS 連線上叢集欄位儲存索引的無效存取。
錯誤更正措施:連線不應啟用 MARS。
ErrorFirstProduct:SQL14
注意:當你將 maxdop 設為 1 時,這個問題就不會發生。
解決方式
這兩個問題最初在隨後的 SQL Server 累積更新中被修正。
2014 SQL Server 累積更新 1 /en-us/help/2931693
關於 SQL Server 的累積更新
每次新的 SQL Server 累積更新都包含了之前累積更新中包含的所有熱修補與安全修補。 請查看 SQL Server 的最新累積更新:
狀態
Microsoft 已確認這是「適用對象」一節中列出的 Microsoft 產品中的問題。