狀況

在 Microsoft Exchange Server 2016年環境中,您解除安裝Windows PowerShell 2.0 版,並改為安裝較新版的 PowerShell 之後,Exchange 管理命令介面無法開啟成功,而您會收到下列錯誤訊息:

新 PSSession: [伺服器名稱] 處理資料,從遠端伺服器失敗的伺服器名稱
下列的錯誤訊息: [ClientAccessServer =伺服器名稱,BackEndServer =伺服器名稱,RequestId =RequestId,時間戳記 =日期時間]
[AuthZRequestId=AuthZRequestId][FailureCategory=AuthZ-SetupVersionInformationCorruptException]
無法判斷安裝的檔案版本的登錄機碼
' HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine'。如需詳細資訊,請參閱
about_Remote_Troubleshooting [說明] 主題。
Char 的線條: 1:1
+ 新-PSSession-ConnectionURI"$connectionUri"-ConfigurationName Micr...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo: OpenError: (System.Manageme...RemoteRunspace:RemoteRunspace) [新-PSSession],PSRemotin
gTransportException
+ 第 IncorrectProtocolVersion FullyQualifiedErrorId: PSSessionOpenFailed

此外,也會記錄下列事件記錄檔項目:

記錄檔名稱︰應用程式
來源: MSExchange RBAC
日期時間的日期:
事件識別碼: 258
工作類別: RBAC
層級: 錯誤
關鍵字: 傳統
使用者: n/A
電腦:電腦名稱
描述:
(處理程序 PID w3wp.exe)"RemotePS 公用 API Func GetApplicationPrivateData,8820 會擲回的例外狀況 Microsoft.Exchange.Diagnostics.SetupVersionInformationCorruptException: 無法判斷安裝的檔案版本的登錄機碼 ' HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine'。

原因

PowerShell 最新版本的登錄路徑已變更,就會發生這個問題。

因應措施

您可以新增HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine登錄機碼上一步] 之後您解除安裝 Windows PowerShell 2.0。最快的方式是擷取登錄 Microsoft TechNet 圖庫中的檔案: https://gallery.technet.microsoft.com/Exchange-2016-CU1-7c843cb0

解決方案

如果要修正這個問題,請安裝累積更新 9 Exchange Server 2016年或更新的累積更新的 Exchange Server 2016年

狀態

Microsoft 已確認這是<套用>一節所列出的 Microsoft 產品的問題。

參考

深入了解 Microsoft 用來描述軟體更新的術語

需要更多協助?

擴展您的技能
探索訓練
優先取得新功能
加入 Microsoft 測試人員

這項資訊有幫助嗎?

您對翻譯品質的滿意度為何?
以下何者是您會在意的事項?

感謝您的意見反應!

×