使用 Microsoft 登入
登入或建立帳戶。
您好:
選取其他帳戶。
您有多個帳戶
選擇您要用來登入的帳戶。

徵兆

請考慮下列案例:

  • 您使用 System Center Configuration Manager 2007 部署功能套件 (OSD) 任務順序來部署 WINDOWS OS Windows管理介面 (WIM) 檔案。

  • 檔案大於 4 GB。

  • 您可以使用多重案例方法來部署 OS WIM 檔案。

在此案例中,下載 WIM 檔案之後,任務順序和部署會立即失敗。

注意:相同的Windows作業系統 WIM 檔案會使用 unicast 正確部署。 此外,如果您使用多重廣播方法來部署小於 4 GB 的作業系統 WIM 檔案Windows,則不會發生此問題。

原因

此問題是由 System Center Configuration Manager 2007 Service Pack 1 (SP1) R2 的已知問題所造成。 在此問題中,當 WIM 檔案大小大於 4 GB 時,雜湊計算無法正確執行。

解決方案

Service Pack 資訊

若要解決此問題,請從此 Microsoft 網站取得 Microsoft System Center Configuration Manager 2007 的最新 Service Pack:HTTP://www.microsoft.com/download/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
如需此 Service Pack 中已解決的問題清單,請按一下 Microsoft Knowledgebase 中的下列文章編號:

971348 System Center Configuration Manager 2007 Service Pack 2 中包含的 hotfix 和更新清單

Hotfix 資訊

Microsoft 提供支援的 Hotfix。 不過,此 Hotfix 僅是為了修正本文所述的問題。 僅將此 Hotfix 套用至發生本文所述問題的系統。 這個 Hotfix 可能會收到額外的測試。 因此,如果您未受到此問題嚴重影響,建議您等待下一次包含此 Hotfix 的軟體更新。

如果 hotfix 可供下載,則此知識庫文章頂端有「Hotfix 下載可用」一節。 如果沒有出現此區段,請連絡 Microsoft 客戶服務及支援以取得 Hotfix。

注意 如果發生其他問題或需要進行任何疑難排解,您可能需要建立個別的服務要求。 一般支援費用將適用于其他不符合此特定 Hotfix 資格的支援問題。 如需 Microsoft 客戶服務和支援電話號碼的完整清單,或是建立個別的服務要求,請流覽下列 Microsoft 網站:

HTTP://support.microsoft.com/contactus/?ws=support注意:[Hotfix 下載可用] 表單會顯示可供使用 Hotfix 的語言。 如果您沒有看到您的語言,這是因為該語言無法使用 hotfix。

先決條件

若要套用此 Hotfix,您必須安裝 System Center Configuration Manager 2007 Service Pack 1。

重新啟動需求

套用此 Hotfix 之後,您不需要重新開機電腦。

Hotfix 取代資訊

這個 hotfix 並不會取代任何其他 hotfix。

檔案資訊

此 hotfix 的英文版本具有 (或更新版本的檔案屬性) 列于下表中。 這些檔案的日期和時間會以協調的通用時間列 (UTC) 。 當您檢視檔案資訊時,它會轉換為當地時間。 若要尋找 UTC 和當地時間之間的差異,請使用 主控台 中 [日期及時間] 工具中的 [時區] 索引標籤。

檔案名稱

檔案版本

檔案大小

日期

Time

Platform

Mcs.msi

不適用

7,138,304

01-Dec-2008

1,501

不適用

Smswdstp.dll

4.0.6221.1176

119,128

01-Dec-2008

1,501

x86

Smswdstp.dll

4.0.6221.1176

286,040

01-Dec-2008

1,501

x64


因應措施

若要解決此問題,請使用 Unicast 方法來部署或使用小於 4 GB 的 OS WIM 檔案。

狀態

Microsoft 已確認<適用於>一節中所列的 Microsoft 產品確實有上述問題。

其他相關資訊

安裝 Microsoft 知識庫 (KB) 文章971413所述的 Hotfix 之後,多廣播作業系統部署可能無法再運作。 這包括Windows小於 4GB 的作業系統 WIM 檔案。

安裝 KB 文章971413所述的 Hotfix 之後,就會啟動網站重設。 網站重設會重新安裝所有網站元件。 不過,如果下列條件為 True,則多投影片會話會失敗:

  • 網站重設程式完成之後,就會立即啟動多重廣播會話。

  • 網站重設程式尚未完成。

  • 並非所有元件都已完成重新安裝程式,特別是與多重投影片相關聯的元件。

解決這個問題最簡單的方法就是先等候一段時間,再執行任何多廣播作業系統部署。 不過,如果多重投影片部署仍然無法運作,請依照下列所述的方法進行:

方法 1

  1. 在作業系統影像的屬性中,停用然後重新啟用 [ 允許此套件透過多重預報傳輸 (WinPE 僅) 選項。

  2. 停用並重新啟用 多投影片發佈點屬性中的 Multicast 選項, (DP) 。

  3. 重新安裝 WDS。

注意 如果大於 4 GB 的檔案上的多廣播部署仍然無法運作,請遵循下一個方法。

方法 2

  1. 在 System Center Configuration Manager 2007 主機的 [作業系統映射] 底下,以滑鼠右鍵按一下正在多重廣播的作業系統映射,然後按一下 [內容]

  2. 按一下 [通訊設定表。

  3. 清除[允許透過多重廣播傳輸此套件 (僅限 WinPE) 選項,然後按一下 [套用
    ]。

  4. 取 [允許透過多重廣播傳輸此套件 (僅限 WinPE) 選項,然後按一下 [
    確定]

  5. 針對已設定為多重投影片的每個作業系統映射,重複步驟 1 到步驟 4。

注意 如果大於 4 GB 的檔案上的多廣播部署仍然無法運作,請遵循下一個方法。

方法 3

  1. 在 System Center Configuration Manager 2007 主機的[作業系統映射] 底下,以滑鼠右鍵按一下正在多重廣播的作業系統映射,然後按一下 [內容]

  2. 按一下 [通訊設定表。

  3. 清除 [ 允許使用多重投影片傳輸此套件 (WinPE 僅) 選項,然後按一下 [ 確定]

  4. 針對已設定多重投影片的每個作業系統映射,重複此方法的步驟 1 到步驟 3。

  5. 停用 DP 角色屬性中的多廣播 DP。 若要這麼做,請按一下 [ 多廣播] 索引 標籤,清除 [啟用多廣播 ] 選項,然後按一下 [ 確定]

  6. 監控 MCSSetup.log 檔案和 MCSMSI.log 檔案。 等到檔案成功卸載為止。

  7. 重新安裝 DP 角色屬性中的多重廣播。 若要這麼做,請按一下 [ 多重廣播] 索引 標籤,核 取 [啟用多廣播],然後按一下 [ 確定]

  8. 監控 MCSSetup.log 檔案和 MCSMSI.log 檔案。 等待檔案順利安裝。

  9. 在 System Center Configuration Manager 2007 主機的[作業系統映射] 底下,以滑鼠右鍵按一下正在多重廣播的作業系統映射,然後按一下 [內容]

  10. 按一下 [通訊設定表。

  11. 取 [允許透過多重廣播傳輸此套件 (僅限 WinPE) 選項,然後按一下 [
    確定]

  12. 針對每個已設為多重廣播的作業系統映射,重複此方法的步驟 9 到步驟 11。

注意 如果大於 4 GB 的檔案上的多廣播部署仍然無法運作,請遵循下一個方法。

方法 4

  1. 請遵循步驟 1 到步驟 6 的方法 3。

  2. 如果伺服器不是 PXE 服務點,請移至此方法的步驟 5。

  3. 如果伺服器也是 PXE 服務點,請從 PXEBOOTIMAGES$ DP 刪除開機影像,然後卸載 ConfigMgr PXE 服務點角色。

  4. 監控 PXESetup.log 檔案,並確定 PXE 服務點已正確卸載。

  5. 卸載 WDS。

  6. 如果出現提示,請重新開機伺服器。

  7. 重新安裝 WDS,以確保您同時選取部署伺服器和傳輸伺服器。

  8. 如果伺服器不是 PXE 服務點,請移至此方法的步驟 12。

  9. 如果伺服器也是 PXE 服務點,請重新安裝 ConfigMgr PXE 服務點角色。

  10. 監控 PXESetup.log 檔案,並確認 PXE 服務點已正確安裝。 如果記錄檔提示您重新開機伺服器,請重新開機伺服器。

  11. 將開機影像新增至 PXEBOOTIMAGES$ DP。

  12. 請依照步驟 7 執行方法 3 的步驟 13。


如需詳細資訊,請按一下下列文章編號以檢視 Microsoft 知識庫中的文章:

824684 用來描述 Microsoft 軟體更新的標準術語描述

需要更多協助嗎?

想要其他選項嗎?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

這項資訊有幫助嗎?

您對語言品質的滿意度如何?
以下何者是您會在意的事項?
按下 [提交] 後,您的意見反應將用來改善 Microsoft 產品與服務。 您的 IT 管理員將能夠收集這些資料。 隱私權聲明。

感謝您的意見反應!

×