使用 Microsoft 登入
登入或建立帳戶。
您好:
選取其他帳戶。
您有多個帳戶
選擇您要用來登入的帳戶。

徵兆

在軟體更新點 (SUP) 與 Windows Software Update Services 同步處理 (WSUS) 完成後,先前成功部署的軟體更新在 Microsoft System Center Configuration Manager 2007 的系統管理員主控台中顯示為無效。 具體來說,當您在系統管理員主控台的部署管理 節點中檢視更新時, (紅色箭號) 的無效軟體更新圖示會與更新一起出現。 此外,這些更新不再列在部署套件節點下方。

原因

此問題可能會因為 2012 年 10 月對 Microsoft Update 服務所做的變更而發生。 這些增強功能包含會影響所有 WSUS 伺服器的中繼資料更新。 這些變更會導致某些更新標示為內容變更,即使更新二進位檔案並未變更。 對於某些系統管理員來說,當 WSUS 在 10 月與 Microsoft Update 伺服器同步處理時,可能會自動套用中繼資料變更。 其他系統管理員會透過將更新2734608套用至 WSUS 伺服器來收到變更。

解決方案

若要解決此問題,請將這個 Hotfix 套件安裝在主要和次要System Center Configuration Manager 2007 SP2 網站伺服器上。

套用此 Hotfix 之後,只包含中繼資料變更而非檔案內容的更新不會造成更新顯示為無效。

此 Hotfix 不會更新先前標示為不正確更新狀態。 不過,您可以從系統管理員主控台的軟體更新 節點使用 [下載軟體] 精靈重新下載這些更新。

若要識別顯示無效軟體更新圖示的更新,您可以建立新的搜尋資料夾。 若要這麼做,請在建立搜尋資料夾時使用下列物件屬性:

  • Deployed=Yes

  • Downloaded=No

此外,您必須選取 [在此功能底下搜尋所有資料夾] 核取方塊。

執行查詢之後,請確認只傳回不正確軟體更新。 您可以選取更新,然後直接從結果視窗下載更新。 如果已知更新,您可以將更新放入原始部署套件。 或者,您可以將更新放入新的部署套件。 使用中的部署會自動更新,以辨識更新的修訂下載狀態。

如需如何設定軟體更新搜尋資料夾的詳細資訊,請移至下列 Microsoft TechNet 網站:

如何設定軟體更新的搜尋資料夾

Hotfix 資訊

Microsoft 提供支援的 Hotfix。 不過,此 Hotfix 僅是為了修正本文所述的問題。 僅將此 Hotfix 套用至發生本文所述問題的系統。 這個 Hotfix 可能會收到額外的測試。 因此,如果您未受到此問題嚴重影響,建議您等待下一次包含此 Hotfix 的軟體更新。

如果 hotfix 可供下載,則此知識庫文章頂端有「Hotfix 下載可用」一節。 如果沒有出現此區段,請連絡 Microsoft 客戶服務及支援以取得 Hotfix。

注意 如果發生其他問題或需要進行任何疑難排解,您可能需要建立個別的服務要求。 一般支援費用將適用于其他不符合此特定 Hotfix 資格的支援問題。 如需 Microsoft 客戶服務及支援電話號碼的完整清單,或是建立個別的服務要求,請流覽下列 Microsoft 網站:

HTTP://support.microsoft.com/contactus/?ws=support注意:[Hotfix 下載可用] 表單會顯示可供使用 Hotfix 的語言。 如果您沒有看到您的語言,這是因為該語言無法使用 hotfix。

先決條件

若要安裝此 Hotfix,您必須執行 System Center Configuration Manager 2007 Service Pack 2 (SP2) 。

登錄資訊

若要安裝此 Hotfix,您不需要對登錄進行任何變更。

重新啟動需求

安裝此 Hotfix 之後,您不需要重新開機電腦。

Hotfix 取代資訊

此 hotfix 不會取代先前發行的 hotfix。

檔案資訊

此 Hotfix 的全域版本會安裝下表中所列屬性的檔案。 這些檔案的日期與時間是以 Coordinated Universal Time (UTC) 表示。 本機電腦上這些檔案的日期與時間,是以您當地的時間和目前的日光節約時間 (DST) 的時差來顯示。 此外,當您對檔案執行特定作業時,其日期與時間可能會改變。

檔案名稱

檔案版本

檔案大小

日期

Time

Platform

Updmgr.dll

4.0.6487.2220

156,232

01-Feb-2010

1,855

x86

其他相關資訊

For more information about this issue, go to the "Issue 2 - Additional Improvements" section of the following blog post on the Microsoft TechNet website:

支援提示:Configuration Manager用戶端部署套件可能無法部署,因為必須重新下載更新如需更新2734608的詳細資訊,請按一下下列文章編號以檢視 Microsoft 知識庫中的文章:

2734608 Windows Server Update Services 3.0 Service Pack 2 的更新 (KB2734608) 如需軟體更新同步處理的詳細資訊,請前往下列 Microsoft TechNet 網站:

軟體更新同步處理的一般資訊如需軟體更新中繼資料的詳細資訊,請前往下列 Microsoft TechNet 網站:

軟體更新中繼資料的一般資訊如需軟體更新圖示字詞的詳細資訊,請前往下列 Microsoft TechNet 網站:

軟體更新圖示字詞的一般資訊

需要更多協助嗎?

想要其他選項嗎?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

這項資訊有幫助嗎?

您對語言品質的滿意度如何?
以下何者是您會在意的事項?
按下 [提交] 後,您的意見反應將用來改善 Microsoft 產品與服務。 您的 IT 管理員將能夠收集這些資料。 隱私權聲明。

感謝您的意見反應!

×