使用 Microsoft 登入
登入或建立帳戶。
您好:
選取其他帳戶。
您有多個帳戶
選擇您要用來登入的帳戶。

狀況

請考慮下列情況:

  • 您正在執行 Windows Server 2008 R2 的電腦上安裝遠端桌面工作階段主機角色服務。

  • 您要刪除電腦上的預設遠端桌面通訊協定 (RDP) 接聽程式 (Rdp-tcp)。

  • 您的電腦上建立一些新的自訂的 RDP 接聽程式。

  • 您嘗試將 LogonTimeout 設定為特定的接聽程式。

在這個案例中,您不能設定特定的接聽程式的 [LogonTimeout] 設定。LogonTimeout 登錄項目位於硬式編碼的預設 RDP 接聽項的位置,它會套用到電腦上的所有 RDP 接聽程式。

原因

因為沒有 LogonTimeout 登錄項目的移除預設的接聽程式時儲存的位置,就會發生這個問題。

注意LogonTimeout 登錄項目是預設 RDP 接聽項的登錄項目的子機碼。

解決方案

若要解決這個問題,請在受影響的 Windows Server 2008 R2 型電腦上安裝此 hotfix。

注意事項

  • 套用此 hotfix 之後,Winlogon.exe 程序首先會嘗試找出位於下列位置之下的"LogonTimeout"的登錄子機碼︰

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

  • 如果這種情形失敗,Winlogon.exe 程序就會嘗試尋找"LogonTimeout"的登錄子機碼位於下列位置之下︰

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations

  • 當這兩個位置其中一種方法中,有"LogonTimeout"的登錄子機碼時,將讀取它的值,Winlogon.exe 程序,並將其再將值套用至所有 RDP 的連線。


Hotfix 資訊

支援的 hotfix 可從 Microsoft 取得。不過,此 Hotfix 僅用於修正本文中所述的問題。此 hotfix 只適用於發生本文所述之問題的系統。此 hotfix 可能會接受其他測試。因此,如果此問題的影響不會很嚴重,我們建議您等候含此 hotfix 的下一版軟體更新。

如果 hotfix 可供下載,在此知識庫文件頂端將出現「可用的 Hotfix」區段。如果這個區段沒有出現,請連絡 Microsoft 客戶服務及支援以取得 hotfix。

注意如果發生其他問題,或如果需要進行疑難排解,您可能必須建立個別的服務要求。收取支援費用會套用到其他支援問題和此特定 hotfix 無法解決的問題。如 Microsoft 客戶服務及支援的電話號碼或建立個別的服務要求的完整清單,請造訪下列 Microsoft 網站︰

http://support.microsoft.com/contactus/?ws=support注意「 下載 Hotfix 」 表單會顯示 hotfix 可用的語言。如果看不到您的語言,是因為未提供該語言的 Hotfix 。

先決條件

若要套用此 hotfix,您執行的必須是下列其中一種作業系統︰

  • Windows Server 2008 R2

  • Windows Server 2008 R2 Service Pack 1 (SP1)

此外,您必須安裝遠端桌面工作階段主機角色服務。

如需有關如何取得 Windows Server 2008 R2 service pack 的詳細資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件︰

Service Pack 1 Windows 7 和 Windows Server 2008 R2 的976932資訊

登錄資訊

若要使用此套件中的 hotfix,您不需對登錄進行任何變更。

重新啟動需求

套用此 hotfix 後,您必須重新啟動電腦。

Hotfix 取代資訊

此 hotfix 不會取代先前發行的 hotfix。

檔案資訊

此 hotfix 的全域版本安裝檔案具有下列表格中所列的屬性。這些檔案的日期和時間均以國際標準時間 (UTC) 列出。本機電腦上這些檔案是以您當地的時間與目前的日光節約時間 (DST) 的時差來顯示日期和時間。此外,當您在檔案上執行特定作業時,日期和時間可能會變更。

Windows Server 2008 R2 檔案資訊備忘稿

重要Windows 7 hotfix 及 Windows Server 2008 R2 hotfix 隨附在相同的套件中。不過,在 [Hotfix 要求] 頁面上的 Hotfix 會在這兩個作業系統下列出。若要要求套用至一或兩個作業系統的 Hotfix 套件,請選取此頁面上列在 Windows 7/Windows Server 2008 R2 之下的 Hotfix。永遠參考文件的〈套用〉一節以判斷實際套用每個 hotfix 的作業系統。

  • 藉由檢查的檔案版本號碼,如下列表格所示,可以識別套用至特定產品、 SR_Level (RTM、 SPn) 及服務分支 (LDR、 GDR) 的檔案。

    版本

    產品

    SR_Level

    服務分支

    6.1.760
    0.
    21xxx

    Windows Server 2008 R2

    RTM

    LDR

    6.1.760
    1.
    21xxx

    Windows Server 2008 R2

    SP1

    LDR

  • 資訊清單檔案 (.manifest) 及菊檔案 (.mum) 所安裝的每個環境都 < 其他檔案的="" windows="" server="" 2008="" r2="" 資訊=""> 一節中的 [分別列出。MUM 及 MANIFEST 檔案,以及相關的安全性目錄 (.cat) 檔案,對維護更新元件的狀態非常重要。安全性類別目錄檔案 (將不會為其列出屬性) 是使用 Microsoft 數位簽章簽署的。

所有支援 x64 型版本的 Windows Server 2008 R2

檔案名稱

檔案版本

檔案大小

日期

時間

平台

Winlogon.exe

6.1.7600.21055

390,656

16-Sep-2011

05:12

x64

Winlogon.exe

6.1.7601.21820

391,168

16-Sep-2011

06:29

x64

狀態

Microsoft 已確認這是<套用>一節所列出的 Microsoft 產品的問題。

更多的資訊

如需有關軟體更新術語的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:

用來描述 Microsoft 軟體更新標準術語的編號 824684描述

LogonTimeout 登錄項目位於下列位置︰

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\LogonTimeout

其他檔案資訊

Windows Server 2008 R2 的其他檔案資訊

所有支援 x64 型版本的 Windows Server 2008 R2 的其他檔案

檔案名稱

Amd64_20788ab2b117dd0a5b896e098e889ca7_31bf3856ad364e35_6.1.7601.21820_none_ec912e19bd510bc4.manifest

檔案版本

不適用

檔案大小

700

日期 (UTC)

16-Sep-2011

時間 (UTC)

17:36

平台

不適用

檔案名稱

Amd64_9029c1c2d979c25df5b55f932f4656c0_31bf3856ad364e35_6.1.7600.21055_none_c9c272be06ffa565.manifest

檔案版本

不適用

檔案大小

700

日期 (UTC)

16-Sep-2011

時間 (UTC)

17:36

平台

不適用

檔案名稱

Amd64_microsoft-windows-winlogon_31bf3856ad364e35_6.1.7600.21055_none_cc61e0ed07a7f398.manifest

檔案版本

不適用

檔案大小

16,223

日期 (UTC)

16-Sep-2011

時間 (UTC)

07:59

平台

不適用

檔案名稱

Amd64_microsoft-windows-winlogon_31bf3856ad364e35_6.1.7601.21820_none_ce63d60904ba56e3.manifest

檔案版本

不適用

檔案大小

16,223

日期 (UTC)

16-Sep-2011

時間 (UTC)

07:33

平台

不適用

檔案名稱

Update.mum

檔案版本

不適用

檔案大小

3,215

日期 (UTC)

16-Sep-2011

時間 (UTC)

17:36

平台

不適用

需要更多協助嗎?

想要其他選項嗎?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

這項資訊有幫助嗎?

您對語言品質的滿意度如何?
以下何者是您會在意的事項?
按下 [提交] 後,您的意見反應將用來改善 Microsoft 產品與服務。 您的 IT 管理員將能夠收集這些資料。 隱私權聲明。

感謝您的意見反應!

×