Article ID: 932729 - Last Review: December 3, 2007 - Revision: 1.4

FIX: Error message when you try to access a Web site that is hosted on IIS 6.0: Access Denied

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SYMPTOMS

When you try to access a Web site that is hosted on Microsoft Internet Information Services (IIS) 6.0, you receive an error message that resembles the following:
Access Denied
This issue occurs if the following conditions are true:
  • You use a Web browser other than Windows Internet Explorer to access the Web site.
  • The Web site uses only Digest authentication to authenticate clients.
  • The Web browser sends a request that includes a query string.

CAUSE

This issue occurs because IIS 6.0 does not include the query string when IIS 6.0 uses Digest authentication to authenticate clients.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft Windows Server 2003 Service Pack 1, Itanium architecture
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File nameFile versionFile sizeDateTimePlatform
Iisutil.dll6.0.3790.2885436,73621-Feb-200708:08IA-64
W3core.dll6.0.3790.28851,060,35221-Feb-200708:08IA-64
Wiisutil.dll6.0.3790.2885167,93621-Feb-200708:08x86
Ww3core.dll6.0.3790.2885349,18421-Feb-200708:08x86
Microsoft Windows Server 2003 Service Pack 1, x86
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Iisutil.dll6.0.3790.2885167,93621-Feb-200708:24
W3core.dll6.0.3790.2885349,18421-Feb-200708:24

MORE INFORMATION

This issue does not occur in IIS 7.0.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Internet Information Services 6.0
Keywords: 
kbautohotfix kbhotfixserver kbfix kbbug kbqfe kbpubtypekc KB932729
 

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