Event ID 52 When You Start Terminal Services

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Article ID: 258021 - View products that this article applies to.
This article was previously published under Q258021
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SYMPTOMS

Clients cannot connect to a Windows 2000-based server that is running Terminal Services, even after you reset the client license registry key as described in following Microsoft Knowledge Base article:
248430 How to Transfer Terminal Services CAL from One Computer to Another
The client computer may receive the following error messages if you try to establish a Terminal Services connection:
Terminal Services Client Disconnected

The client could not connect to the Terminal server. The server may be too busy. Please try connecting later.
-or-
Terminal Services Client Disconnected

The Terminal server has ended the connection.
The following event ID message may be logged in the System event log on the server:
Event ID: 52
Description: Object Name not found.
Source: TermService
Data:
=====
0000: 52 00 44 00 50 00 2d 00   R.D.P.-.
0008: 54 00 63 00 70 00 00 00   T.c.p...
0010: 00 00 00 00 00 00 00 00   ........
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0028: 00 00 00 00 00 00 00 00   ........
0030: 00 00 00 00 00 00 00 00   ........
0038: 00 00 00 00 00 00 00 00   ........
0040: 00 00                     ..
					

CAUSE

This problem may occur if the RDP-tcp listener was not initialized or if the Terminal device driver is not started. You may have to verify that the license key is correct.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To resolve this problem, first determine the cause of the problem by using the following list, and then follow the applicable steps:
  • The RDP-tcp connection may have to be reset. To reset the RDP-tcp connection in the Terminal Services Configuration management console, right-click the connection, and then click Disable. Confirm the changes when you are prompted to do so. Repeat the process, and then click Enable.
  • The RDP-tcp connection may be corrupted. Re-create the RDP-tcp connection in the Terminal Services Configuration management console. To re-create the connection, delete the connection, and then re-create it.
  • An evaluation license may have been used to configure Terminal Services Licensing. Verify that a retail license has been issued and correctly installed.
  • The Network Adapter tab in RDP-tcp properties may be set to Maximum Connections: 0. This causes the "The Terminal server has ended the connection" error message.
  • The Terminal device driver files may be corrupted or missing. Verify the existence of the Termdd.sys and Rdpwd.sys files in the %SystemRoot%\Sytem32\Drivers folder. Verify that the Rdpdd.dll and Rdpwsx.dll files are located in the %SystemRoot%\Sytem32 folder.
  • The TermDD service may be disabled. Open the registry and locate the following key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermDD
    Check the data setting for the Start value, which should be 2. If the value is set to 4, the driver has been disabled. Set the value to 2, and then restart the server computer.
After you complete these steps, the client license registry may still have to be reset. For additional information about how to reset the client license registry, click the article number below to view the article in the Microsoft Knowledge Base:
248430 How to Transfer Terminal Services CAL from One Computer to Another
You may have to verify the license key by using the Microsoft Registration Authority and Clearinghouse. See the "More Information" section in this article for information about how to contact the Microsoft Registration Authority and Clearinghouse.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:
237811 How to Activate a Terminal Services License Server and Install CALs Over the Internet
244749 Licenses Required When Using Terminal Services Client Software
258045 Terminal Services Licensing Does Not Accept a Valid License Key Pack
For more information about Terminal Services, see Chapter 16, "Deploying Terminal Services," in the "Deployment Planning Guide" on the following Microsoft Web site:
http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/default.mspx?mfr=true
To validate a Terminal Services License Key in the United States, call 1-888-571-2048 to contact the Microsoft Registration Authority and Clearinghouse.

To contact the Registration Authority and Clearinghouse outside the United States, follow these steps:
  1. Start the Terminal Services Licensing tool.
  2. Right-click your license server, and then click Properties.
  3. Click Connection Method, and then click Set To Telephone.
  4. Click the appropriate country, and then click OK.
  5. On the Action menu, click Install Licenses, and then click Next.
  6. Call the appropriate Customer Service Center by using the telephone number that is displayed.
  7. Click Cancel to quit the Terminal Services Licensing tool.

Properties

Article ID: 258021 - Last Review: February 28, 2007 - Revision: 4.5
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbprb kbtermserv KB258021

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