Article ID: 287524 - Last Review: October 27, 2006 - Revision: 3.6

"Stop 0x0000001E" Error Message When You Mount a Volume

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This article was previously published under Q287524

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SYMPTOMS

When you mount a volume under high-stress conditions, your computer may stop responding (hang) and you may receive an error message that is similar to:
STOP: 0x0000001E (0xC0000005, 0x801725bc, 0x0000001, 0x0000030)
KMODE_EXCEPTION_NOT_HANDLED
Note that the values in the error message may vary.

The fault address (the value in the sample error message is 0x801725bc) is in the operating system kernel (Ntoskrnl.exe).

CAUSE

This error occurs because a volume parameter block (VPB) is modified without being protected by a global spinlock when you mount a volume.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   15-Jun-2001  16:43  5.0.2195.3749  1,685,632  Ntkrnlmp.exe
   15-Jun-2001  16:44  5.0.2195.3749  1,685,312  Ntkrnlpa.exe
   15-Jun-2001  16:45  5.0.2195.3749  1,706,048  Ntkrpamp.exe
   15-Jun-2001  16:42  5.0.2195.3749  1,663,424  Ntoskrnl.exe
				

NOTE: After you apply this hotfix, your installation of Windows 2000 is updated to version 5.0.2195 Service Pack 2, RC 3.2 Build 2195. Even though the version is slightly different, Windows 2000 Service Pack 2 is still installed on your computer. The change in the version helps support professionals identify that an updated version of the Service Pack 2 kernel is installed on your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was corrected in Microsoft Windows XP.

MORE INFORMATION

From the Microsoft Windows 2000 Device Driver Kit (DDK):
A VPB is a structure, defined by the I/O Manager, that maps a file system's volume device object to the device or partition upon which the volume is mounted. The file system's device object is actually used to represent the volume (VPB) mounted on the actual device (physical device object). Device objects for physical disks, tapes, CD-ROMs, and RAM disks have associated VPBs.

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwin2000presp3fix KB287524
 

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