You receive an "Error 25506" error message when you run the Setup program for Office XP or for Publisher 2002

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Article ID: 322092 - View products that this article applies to.
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SYMPTOMS

If you try to run Setup for Office XP or Publisher 2002, you may receive an error message similar to the following
Error 25506. Microsoft program requires updated system files not detected on your computer. You must install the Microsoft Office 2002 System Files Update prior to installing program. C:\Windows\System\Riched20.dll is version 5.30.22.2300 when we require version 5.30.23.1200.
where program is the program that you are trying to install.

CAUSE

This problem may occur if the Riched20.dll file is damaged, if the Riched20.dll file is the wrong version, or if the Riched20.dll file is missing from your computer.

RESOLUTION

To resolve this problem, follow these steps:
  1. Rename the Riched20.dll file. To do this, follow the steps for your version of Microsoft Windows. This file may be hidden. For instructions about how to unhide files, see your operating system documentation. If you do not find the file, go to step 2.
    • Microsoft Windows 98 or Microsoft Windows NT 4.0:

      1. Quit all Windows programs.
      2. Click Start, point to Find, and then click Files or Folders.
      3. In the Named box, type Riched20.dll.
      4. In the Look in box, select your local hard disk.
      5. Click Find Now to search for the file.
      6. For each occurrence of the Riched20.dll file that appears in the Find program, right-click the file. Click Rename on the shortcut menu. Give the file a new name, such as Riched20.old, and then press ENTER.
      -or-
    • Microsoft Windows Millennium Edition (Me) or Microsoft Windows 2000:

      1. Quit all Windows programs.
      2. Click Start, point to Search, and then click For Files or Folders.
      3. In the Search for files or folders named box, type Riched20.dll.
      4. In the Look in box, select your local hard disk.
      5. Click Search Now to search for the file.
      6. For each occurrence of the Riched20.dll file that appears in the Search Results dialog box, right-click the file. Click Rename on the shortcut menu. Give the file a new name, such as Riched20.old, and then press ENTER.
      7. On the File menu, click Close to quit the Search program.
      -or-
    • Microsoft Windows XP:
      1. Quit all Windows programs.
      2. Click Start and then click Search.
      3. Under What do you want to search for, click All files and folders.
      4. In the All or part of the file name box, type Riched20.dll.
      5. In the Look in box, select your local hard disk.
      6. Click Search to search for the file.
      7. For each occurrence of the Riched20.dll file that appears in the Search Results dialog box, right-click the file. Click Rename on the shortcut menu. Give the file a new name, such as Riched20.old, and then press ENTER.
      8. On the File menu, click Close to quit the Search Results program.
  2. Insert your Microsoft program CD-ROM into your CD-ROM drive or DVD-ROM drive.
  3. In Windows Explorer (right-click Start and then click Explore), go to the root of your CD-ROM.
  4. If you are using Windows 98 or Windows Me, double-click Instmsi.exe. If you are using Windows NT 4.0, Windows 2000, or Windows XP, double-click Instmsiw.exe.
  5. Click OK to the message that advises you that the Windows Installer installed successfully.
Run Setup for your Microsoft program again.

REFERENCES

For additional information about similar issues, click the article numbers below to view the articles in the Microsoft Knowledge Base:
290234 OFFXP: Internal Error 2894 During Office Installation
308357 OFF: Setup Error 2889 Caused by Nimda Virus Infection
For additional information about 25506 errors, click the article numbers below to view the articles in the Microsoft Knowledge Base:
301064 OFFXP: "Error 25506"; Asycfilt.dll File Is the Wrong Version When You Run Office Setup
304629 OFFXP: Error 25506 on ODBCBCP.DLL, SQLSRV32.DLL, ODDBSE32.DLL, ODBCJI32.DLL, MSORCL32.DLL
312365 Works Suite 2002: Error 25506 or Error 1311

Properties

Article ID: 322092 - Last Review: February 27, 2014 - Revision: 2.4
APPLIES TO
  • Microsoft Publisher 2002 Standard Edition
  • Microsoft Office XP Professional Edition
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office XP Standard Edition for Students and Teachers
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Keywords: 
kbnosurvey kbarchive kbtshoot kbsetup kbprb KB322092

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