"Application Failed to Start Because Netdtect.dll Was Not Found" Error Message When You Install Windows XP SP1

Article ID: 328033
This article was previously published under Q328033
Expand all | Collapse all

SYMPTOMS

When you try to install Windows XP Service Pack 1 (SP1), you may receive the following error message during the "Inspecting your current configuration" phase of the "Updating Your System" portion of Setup:
Update.exe - Unable to Locate Component
This application has failed to start because netdtect.dll was not found. Re-installing the application may fix this problem.

CAUSE

This behavior may occur if there is a third-party driver on your computer that is trying to link to Netdtect.dll. Netdtect.dll is no longer included with Windows. For example, this problem has been confirmed to occur if the following conditions are true:
  • The computer uses a CNet Pro200WL Fast Ethernet network adapter from CNet Technology, Inc.

    -and-
  • You update the driver for the network adapter, Dm9inst.dll, from the Windows Update Web site.

    -and-
  • The file that is downloaded and installed on your computer is of the following version and datestamp:
    File name: Dm9inst.dll
    File version: 1.38.01.1203
    Datestamp: 12/4/2001

RESOLUTION

The error message described in the "Symptoms" section of this article causes no damage and can be safely ignored. It does not indicate a program or device issue, nor do you have to reinstall a program. To continue the installation of Windows XP SP1, click OK on the error message. When you do this, Setup may appear to stop responding for a period of 5 to 10 minutes, but then proceeds as expected to install Windows XP SP1.

MORE INFORMATION

For more information about CNET Technology, Inc., visit the following CNet Web site:
http://www.cnet.com.tw
For more information about Windows Update, visit the following Microsoft Web site:
http://update.microsoft.com
For additional information about how to obtain Windows XP SP1, click the article number below to view the article in the Microsoft Knowledge Base:
322389 How to Obtain the Latest Windows XP Service Pack
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Properties

Article ID: 328033 - Last Review: February 3, 2011 - Revision: 1.3
Keywords: 
kbbug kberrmsg KB328033

Give Feedback