Slow system performance or your computer stops responding when you use Windows Management Instrumentation in Windows XP

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Article ID: 838884 - View products that this article applies to.
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SYMPTOMS

When you use Windows Management Instrumentation (WMI), you may experience slow system performance, and your computer may eventually stop responding (hang).

When you view the contents of the Processes tab in Windows Task manager, high memory usage is indicated for the Svchost.exe process, and this memory-usage value continues to increase.

CAUSE

This issue occurs because of a memory leak in Windows Management Instrumentation.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP

   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   01-Apr-2004  02:53  5.1.2600.1337     161,280  Repdrvfs.dll     
   01-Apr-2004  02:53  5.1.2600.1331     215,552  Wbemcomn.dll     
   01-Apr-2004  02:53  5.1.2600.1331     479,744  Wbemcore.dll     
   01-Apr-2004  02:53  5.1.2600.1331     259,072  Wbemess.dll      
   01-Apr-2004  02:53  5.1.2600.1501     410,112  Wmiprvsd.dll     
   01-Apr-2004  02:53  5.1.2600.1337     104,960  Wmisvc.dll       

Windows XP 64-Bit Edition

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   01-Apr-2004  02:46  5.1.2600.1337     608,256  Repdrvfs.dll     IA-64
   01-Apr-2004  02:46  5.1.2600.1331     672,256  Wbemcomn.dll     IA-64
   01-Apr-2004  02:46  5.1.2600.1331   2,076,160  Wbemcore.dll     IA-64
   01-Apr-2004  02:46  5.1.2600.1331   1,095,680  Wbemess.dll      IA-64
   01-Apr-2004  02:46  5.1.2600.1501   1,547,264  Wmiprvsd.dll     IA-64
   01-Apr-2004  02:46  5.1.2600.1337     336,896  Wmisvc.dll       IA-64
   01-Apr-2004  02:53  5.1.2600.1331     215,552  Wwbemcomn.dll    x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates


For help with system performance issues in Windows Vista, visit the following Microsoft web page:
Problems with overall system speed and system performance

Properties

Article ID: 838884 - Last Review: May 14, 2007 - Revision: 2.8
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2003
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB838884

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