Article ID: 958443 - Last Review: October 10, 2008 - Revision: 1.1

You experience issues in Outlook 2007 or in Outlook 2003 when you try to configure free/busy information or when you try to delegate information

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SYMPTOMS

In Microsoft Office Outlook 2003 or in Microsoft Office Outlook 2007, you experience one of the following issues when you try to configure free/busy information or when you try to delegate information:
  • When you accept a meeting request or when you add a delegate to your mailbox, you receive the following error message:
    Unable to save free/busy information
  • When you use the outlook.exe /cleanfreebusy command-line switch to start Outlook, you receive the following error message:
    Unable to clean your local free/busy information.
  • When you try to add a delegate, you receive one of the following error messages:
    The Delegates settings were not saved correctly. Unable to activate free/busy information.
    The Delegates settings were not saved correctly. Unable to activate send-on-behalf-of list. You do not have sufficient permission to perform this operation on this object.
  • When you try to open a shared calendar item, you receive the following error message:
    Can't open this item. Unable to open the free/busy information
    Additionally, the following event is logged in the Application log on the Outlook client computer:

    Event Type: Warning
    Event Source: Outlook
    Event Category: None
    Event ID: 25
    Date: date
    Time: time
    User: N/A
    Computer: Computer_name
    Description:
    Unable to save free/busy information. Unable to open the free/busy information.

  • When a delegate tries to create an item in the shared calendar or in the manager calendar, the delegate receives the following error message:
    Unable to open free/busy information

CAUSE

These issues occur because a mailbox property does not correctly reference a hidden message in the mailbox. The hidden message contains information that is related to any of the following features:
  • free/busy publishing
  • delegate
  • direct booking

RESOLUTION

To resolve this issue, force the regeneration of hidden free/busy information in the mailbox.

Notes
  • After you follow the steps in this section, you may have to reconfigure settings that are related to the following features:
    • Free/busy publishing
    • Delegates
    • Direct booking
  • The steps in this section must be applied on the mailbox of the user who owns the Calendar folder. This is the mailbox on which you try to create the calendar items, use the /cleanfreebusy switch, or configure the delegate settings.
To force the regeneration of hidden free/busy information in the mailbox, follow these steps:
  1. Exit Outlook.
  2. Make sure that there is an online mode profile for the mailbox.

    Note If there is no online mode profile, use the Mail item in Control Panel to create an online mode profile for the mailbox.
  3. Download the Microsoft Exchange Server Messaging API (MAPI) Editor tool (MfcMapi.exe). To do this, visit the following Microsoft Web site:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=55fdffd7-1878-4637-9808-1e21abb3ae37&DisplayLang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=55fdffd7-1878-4637-9808-1e21abb3ae37&DisplayLang=en)
  4. Start the MfcMapi.exe program that you downloaded, and then click OK.
  5. On the Session menu, click Logon and Display Store Table.
  6. In the Profile Name list, select the online mode profile for the mailbox, and then click OK.
  7. Double-click the Mailbox - username store.
  8. In the navigation pane, click Root Container.
  9. In the details pane, right-click PR_FREEBUSY_ENTRYIDS, click Delete Property, and then click OK.
  10. In the navigation pane, expand Root Container, expand Top of Information Store, and then click Inbox.
  11. In the details pane, right-click PR_FREEBUSY_ENTRYIDS, click Delete Property, and then click OK.
  12. In the Information Store: Inbox dialog box, click Exit on the File menu.
  13. Exit the Microsoft Exchange Server MAPI Editor.
  14. Click Start, click Run, type outlook.exe /cleanfreebusy, and then press ENTER.

Additional steps

If you have any custom settings that are related to the free/busy publishing feature, the delegates feature, or the direct booking feature, follow the appropriate steps:

For the free/busy publishing feature

  1. Start Outlook.
  2. On the Tools menu, click Options.
  3. Click the Preferences tab, and then click Calendar Options in the Calendar area.
  4. Click Free/Busy Options in the Advanced options area.
  5. In the Options area, change the Publish month(s) of Calendar free/busy information on the server setting value to a value that differs from the current setting.

    Note If you do not change the Publish month(s) of Calendar free/busy information on the server setting value, Outlook does not update the hidden free/busy information.
  6. Click OK three times.
  7. On the File menu, click Exit.

For the delegates feature

  1. Start Outlook.
  2. On the Tools menu, click Options, and then click the Delegates tab.
  3. Select the delegate that you want to reconfigure, and then click Permissions.
  4. Click to select the check boxes that you want in the Delegate Permissions dialog box.
  5. Repeat step 3 and step 4 for all delegates.
  6. Click OK two times.
  7. On the File menu, click Exit.

For the direct booking feature

  1. Start Outlook.
  2. On the Tools menu, click Options.
  3. Click the Preferences tab, and then click Calendar Options in the Calendar area.
  4. In the Advanced options area, click Resource Scheduling, and then click to select the check boxes that you want in the Resource Scheduling dialog box.
  5. Click OK three times.
  6. On the File menu, click Exit.

APPLIES TO
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2003
Keywords: 
kbexpertiseinter kbtshoot KB958443
 

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