Applies ToBizTalk Server Branch 2010 BizTalk Server Developer 2010 BizTalk Server Enterprise 2010 BizTalk Server Standard 2010 BizTalk Server 2009 Branch BizTalk Server 2009 Developer BizTalk Server 2009 Enterprise BizTalk Server 2009 Standard

Symptoms

Consider the following scenario:

  • You create a BizTalk application in Microsoft BizTalk 2006 R2, in Microsoft BizTalk 2009, or in Microsoft BizTalk 2010. The application uses BizTalk orchestrations to implement ordered message delivery.

  • You use the BizTalk Administration console to restart the BizTalk host instances that host the BizTalk application while the ordered message delivery instances are active.

In this scenario, the orchestration instance that publishes the ordered message delivery instances may crash. Additionally, you receive an error message that resembles the following:

Uncaught exception (see the 'inner exception' below) has suspended an instance of service '<service name and GUID>'.The service instance will remain suspended until administratively resumed or terminated. If resumed the instance will continue from its last persisted state and may re-throw the same unexpected exception.InstanceId: service instanceShape name: shape nameShapeId: shape IDException thrown from: segment 2, progress 4Inner exception: The handle is invalid. (Exception from HRESULT: 0x80070006 (E_HANDLE))Exception type: COMExceptionSource: Microsoft.XLANGs.BizTalk.EngineTarget Site: Void Commit()The following is a stack trace that identifies the location where the exception occured at Microsoft.BizTalk.XLANGs.BTXEngine.BTXXlangStore.Commit() at Microsoft.XLANGs.Core.Service.Persist(Boolean dehydrate, Context ctx, Boolean idleRequired, Boolean finalPersist, Boolean bypassCommit

Note In this error message, the word "occured" is a misspelling for the word "occurred."

Cause

This issue occurs because of a race condition when the XLANG engine shuts down orchestration instances and when the XLANG engine processes message instances.

Resolution

BizTalk Server 2006 R2

Cumulative update information

The hotfix that resolves this issue is included in cumulative update package 4 for BizTalk Server 2006 R2 SP1. For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:2682056Cumulative update package 4 for BizTalk Server 2006 R2 SP1

BizTalk Server 2009

The fix for BizTalk Server 2009 is currently not available.

BizTalk Server 2010

Cumulative update information

The fix for this issue was first released in Cumulative update package 1 for BizTalk Server 2010. For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2497789 Cumulative update package 1 for BizTalk Server 2010

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about ordered message delivery, visit the following MSDN website:

General information about ordered message deliveryFor more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk Server hotfixes

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