Symptoms
Assume that you send an external email message that has valid recipients and invalid recipients (for example, recipients that have empty email addresses) in a Microsoft Exchange Server 2010 environment. One of the recipients is a mail-enabled public folder. In this situation, the email message is not delivered to the mail-enabled public folder, and you do not receive a non-delivery report (NDR) message.
Cause
This issue occurs because the Exchange Server 2010 server stops the message delivery process only for mail-enabled public folders and not for mailbox users when the Exchange serverĀ checks the recipient list and encounters an error.
Resolution
To resolve this issue, install the following update rollup:
2661854 Description of Update Rollup 2 for Exchange Server 2010 Service Pack 2 After you apply this update, email messages now are still not delivered to public folder recipients. However, a NDR message is generated.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.