Symptoms
Consider the following scenario:
-
You develop an application by using Microsoft Unified Communications Managed API 3.0 (UCMA 3.0) in Microsoft Lync Server 2010.
-
The application uses the RemotePresenceView class or the LocalEndpoint.PresenceServices property to retrieve contact cards.
-
The application tries to retrieve the contact card of a user. The department information of the user is configured in Active Directory.
In this scenario, the department field on the contact card is empty.
Cause
This issue occurs because the department field is not included in the XML-formatted result that is returned to the UCMA 3.0-based application.
Resolution
To resolve this issue, install the following cumulative update:
2670326 Description of the cumulative update for Lync 2010: February 2012
More Information
For more information about the RemotePresenceView class, visit the following Microsoft website:
General information about the RemotePresenceView classFor more information about the LocalEndpoint.PresenceServices property, visit the following Microsoft website:
General information about the LocalEndpoint.PresenceServices property