Applies ToExchange Server 2010 Enterprise Exchange Server 2010 Standard

Symptoms

Consider the following scenario:

  • You install Microsoft Exchange Server 2010 Service Pack 1 (SP1) in hosting mode by using the /hosting switch.

  • You create two tenant organizations (organization 1 and organization 2) in the Exchange Server 2010 SP1 environment.

  • Organization 1 contains a mail-enabled user (user A).

  • You create an external contact in organization 2 for user A.

  • You run the Start-ManagedFolderAssistant cmdlet so that the Managed Folder Assistant will process user A’s mailbox in organization 1.

In this scenario, the Managed Folder Assistant does not process the mailbox. Additionally, the following event is logged in the Application log:

Log Name: ApplicationSource: MSExchangeMailboxAssistantsDate: Date & TimeEvent ID: 10021sTask Category: Managed Folder AssistantLevel: ErrorKeywords: ClassicUser: N/AComputer: ComputerDescription:The MRM Assistant will skip processing mailbox mailbox. Exception details: 'Microsoft.Exchange.Assistants.SkipException: Couldn't get user information for mailbox mailbox from the Active Directory.at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcUserInformation..ctor(MailboxSession session)at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcUserTagInformation..ctor(MailboxSession session, Dictionary`2 allAdTags)at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcUserTagInformation..ctor(MailboxSession session)at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.SysCleanupSubAssistant.BuildMailboxData(MailboxSession mailboxSession)at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.SysCleanupSubAssistant.Invoke(MailboxSession mailboxSession, MailboxDataForTags& mailboxDataForTags)at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ELCAssistant.<>c__DisplayClass6.<InvokeInternal>b__0()at Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(TryDelegate tryDelegate, FilterDelegate filterDelegate, CatchDelegate catchDelegate)'.

Cause

This issue occurs because the Managed Folder Assistant uses a global scope incorrectly and does not use a unique identifier to open the mailbox. Therefore, two objects that have the same Simple Mail Transfer Protocol (SMTP) address are returned, and the Managed Folder Assistant does not process the mailbox.

Resolution

To resolve this issue, install the following update rollup:

2685289 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the Start-ManagedFolderAssistant cmdlet, go to the following Microsoft website:

General information about the Start-ManagedFolderAssistant cmdletFor more information about multi-tenant Exchange deployments, go to the following Microsoft website:

General information about multi-tenant Exchange deploymentsFor more information about how to create a tenant organization, go to the following Microsoft website:

Create a tenant organization

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.