Symptoms
Assume that you repeatedly load and unload a registry hive on a computer that is running Windows 8 or Windows Server 2012. In this situation, invalid Transactional Registry (TxR) log files are generated every time that you load the registry hive.
Cause
This issue occurs because the new globally unique identifiers (GUIDs) are never saved to disk.
Resolution
Update information
How to obtain this update
Windows Update
This update is available from Windows Update.
Microsoft Download Center
The following files are available for download from the Microsoft Download Center:
Operating system |
Update |
---|---|
All supported x86-based versions of Windows 8 |
|
All supported x64-based versions of Windows 8 |
|
All supported x64-based versions of Windows Server 2012 |
For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
Prerequisites
To apply this update, you must be running Windows 8 or Windows Server 2012.
Registry information
To apply this update, you do not have to make any changes to the registry.
Restart requirement
You must restart the computer after you apply this update.
Update replacement information
This update does not replace a previously released update.
The global version of this update installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 8 and Windows Server 2012 file information notes
-
The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
Version
Product
Milestone
Service branch
6.2.920 0.16xxx
Windows RT, Windows 8 and Windows Server 2012
RTM
GDR
6.2.920 0.20xxx
Windows RT, Windows 8 and Windows Server 2012
RTM
LDR
-
GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
For all supported x86-based versions of Windows 8
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Ntoskrnl.exe |
6.2.9200.16518 |
5,554,408 |
02-Feb-2013 |
09:53 |
Not applicable |
Ntoskrnl.exe |
6.2.9200.20623 |
5,547,752 |
02-Feb-2013 |
07:50 |
Not applicable |
For all supported x64-based versions of Windows 8 and of Windows Server 2012
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Ntoskrnl.exe |
6.2.9200.16518 |
6,965,992 |
02-Feb-2013 |
10:54 |
x64 |
Ntoskrnl.exe |
6.2.9200.20623 |
6,965,480 |
02-Feb-2013 |
08:59 |
x64 |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates