現象
Microsoft BizTalk Server 2010 または 2013 がインストールされているサーバーに ..NET Framework 4.5.x がインストールされているとします。 その後、BizTalk ホスト インスタンスがクラッシュし、イベント ログに次のようなエラー コード80131544が表示されます。
注
ログ名: アプリケーション
ソース: .NET ランタイム
日付:
イベント ID: 1023
タスク カテゴリ: なし
レベル:エラー
キーワード:クラシック
ユーザー: N/A
コンピューター: <ServerName>
説明:
アプリケーション: BTSNTSvc64.exe
フレームワーク バージョン: v4.0.30319
説明: このプロセスは、IP 000007FDED170BC1 (000007FDECE00000) の .NET ランタイムの内部エラーが原因で終了し、終了コードは 80131544 でした。
ログ名: アプリケーション
ソース: アプリケーション エラー
日付:
イベント ID: 1000
タスクのカテゴリ: (100)
レベル:エラー
キーワード:クラシック
ユーザー: N/A
コンピューター: <ServerName>
説明:
障害が発生しているアプリケーション名:BTSNTSvc64.exe、バージョン:3.10.229.0、タイム スタンプ:0x50fe567a
障害が発生しているモジュール名:clr.dll、バージョン:4.0.30319.19106、タイム スタンプ:0x51a512d4
例外コード: 0x80131544
障害オフセット: 0x0000000000370bc1
障害が発生しているプロセス ID:0xca8
障害が発生しているアプリケーションの開始時刻: 0x01ceb6394f1dd32a
障害が発生しているアプリケーション パス: <ディスク名>:\Program Files (x86)\Microsoft BizTalk Server 2013\BTSNTSvc64.exe
障害が発生しているモジュール パス: <ディスク名>:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
レポート ID: <ReportId>
パッケージのフルネームの障害:
パッケージ関連のアプリケーション ID の障害:
ログ名: システム
ソース: サービス コントロール マネージャー
日付:
イベント ID: 7031
タスク カテゴリ: なし
レベル:エラー
キーワード:クラシック
ユーザー: N/A
コンピューター: <ServerName>
説明:
BizTalk サービス BizTalk グループ: BTSOrchHost サービスが予期せず終了しました。 それは 2 回発生しました。 次の修正アクションは 60000 ミリ秒以内に実行されます。 サービスを再起動します。
原因
この問題は、BizTalk Server 環境に .NET Framework 4.5 をインストールし、BizTalk Server 2010 の累積的な更新プログラム 7 (CU7) より前には正式にサポートされていないために発生します。 BizTalk Server 2010 Cumulative Update 6 (CU6) 以前を実行する場合は、.NET Framework 4.0 を使用する必要があります。
解決策
累積的な更新プログラムの情報
この問題は、BizTalk Server の次の累積的な更新プログラムで最初に修正されました。
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
回避策
この問題を回避するには、次の手順を実行して XLANG AppDomain Shutdown をオフにします。
BizTalk Server フォルダーに移動します。 既定では、C:\Program Files (x86)\Microsoft BizTalk Server 2013 です。
新しい名前を使用して BTSNTSvc64.exe.config ファイルのコピーを保存します。
注: 32 ビット ホストの場合は、BTSNTSvc.exe.config ファイルのコピーを保存してください。 エラー メッセージをチェックして、クラッシュが BTSNTSvc.exe か BTSNTSvc64.exe かを確認できます。
メモ帳で元のファイルを開き、[ <configuration> ノードを見つけます。 次に、そのすぐ下に、以下を追加します。
<configSections>
<section name="XLangs" type="Microsoft.XLANGs.BizTalk.CrossProcess.XmlSerializationConfigurationSectionHandler, Microsoft.XLANGs.BizTalk.CrossProcess" />
</configSections>[ </runtime> ] ノードに移動し、以下を追加します。
<xlangs>
<構成>
<AppDomains AssembliesPerDomain="50">
<DefaultSpec SecondsIdleBeforeShutdown="-1" SecondsEmptyBeforeShutdown="-1"/>
</AppDomains>
</Configuration>
</xlangs>ホストをリサイクルします。
追加情報
CU7 以降、BizTalk Server 2010 ではランタイムに .NET Framework 4.0 と 4.5.x の両方がサポートされます。 CU7 は、.NET Framework 4.5.x のインストール前またはインストール後にインストールできます。