ソース: Microsoft サポート
迅速な公開
迅速な公開に関する記事は、MICROSOFT サポート組織内から直接情報を提供します。 ここに含まれる情報は、新しいトピックや固有のトピックに応じて作成される、または他のナレッジ ベース情報を補完することを目的とします。
現象
Microsoft Dynamics GP または Microsoft Business Solutions – Great Plains 8.0 で Personal Data Keeper (PDK) にログオンすると、次のエラー メッセージが表示されます。
アプリケーションが正しく初期化できなかった (0xc0000022)
この動作は、管理者ではないユーザー アカウントを使用してコンピューターにログオンした後に発生します。
原因
この問題は、Personal Data Keeper フォルダーに対する適切なアクセス許可を持ってない場合に発生します。
解決策
アクセス許可を Personal Data Keeper フォルダーに変更します。 これを行うには、次の手順に従います。
-
管理者としてコンピューターにログオンします。
-
Personal Data Keeper フォルダーを探します。 既定では、Personal Data Keeper フォルダーは次のいずれかの場所にあります。
-
Microsoft Dynamics GP
C:\Program Files\Microsoft Dynamics\Personal Data Keeper -
Microsoft Business Solutions – Great Plains 8.0
C:\Program Files\Microsoft Business Solutions \Personal Data Keeper
-
-
Personal Data Keeper フォルダーを右クリックし 、[プロパティ] を クリックします。
-
[セキュリティ] をクリックします。
-
[グループまたは ユーザー名] 領域で 、適切なユーザーをクリックし、[詳細設定] を クリックします。
-
[すべての子オブジェクトの アクセス許可エントリ を、ここに示されている子オブジェクトに適用するエントリに置き換える] チェック ボックスをオンにし 、[OK]をクリックします。
-
続行するように求めるメッセージが表示されたら 、[OK] をクリックします。
-
[Personal Data Keeper のプロパティ] ウィンドウで [OK] をクリックします。
-
管理者としてコンピューターからログオフします。
-
手順 5. のユーザー アカウントを使用してコンピューターにログオンします。
DISCLAIMER
MICROSOFT および/またはサプライヤーは、ドキュメントに含まれる情報の適合性、信頼性、正確性、および本 Web サイトに公開されている関連グラフィックス ("素材") に関する一切の表明または保証を一切行いません。
資料には技術的な誤りや誤字が含まれる場合があります。また、予告なくいつでも改訂される場合があります。 適用される法律によって許容される最大限の範囲において、MICROSOFT および/またはサプライヤーは、明示、黙示、または法的条件を問わず、明示、黙示、または法的条件、タイトルの表現、保証、条件、非侵害、満足のいく条件または品質、商品性と特定の目的への適性を含むすべての表現、保証、条件を、マテリアルに関して放棄し、除外します。