現象
再起動した場合、または Windows Server 2003 ベースのコンピューターをシャット ダウンするとシャット ダウン処理中に次の Stop エラー メッセージのいずれかを受信します。
0x000000CE (パラメーター 1、パラメーター 30x00000000、0x00000000) を停止します。
DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS
Stop 0x00000050 (パラメーター 1、パラメーター 30x00000000、0x00000000)
PAGE_FAULT_IN_NONPAGED_AREA
注:
-
これらの Stop エラー メッセージ内のパラメーターは、コンピューターの構成によって異なる場合があります。
-
この問題はランダムに発生します。
原因
システムをシャット ダウンする場合ExQueueWorkItem関数によって、Mrxsmb.sys ドライバーに関連する作業項目がキューに挿入されます。ただし、 ExQueueWorkItem関数は、指定された作業項目に関連付けられているデバイス オブジェクトが使用可能な作業項目が処理される前にあることを確認するためのメカニズムは提供されません。したがって、Mrxsmb.sys ドライバーは、キューに登録された作業項目が終了する前にアンロードは、システムは stop エラーをトリガーします。
解決策
修正プログラムの情報
サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この修正プログラムは、この資料に記載された問題があったシステムのみに対して適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。
修正プログラムをダウンロードできる場合は、このサポート技術情報の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。
注: さらなる問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストの作成が必要な場合があります。この修正プログラムの対象外の追加の質問および問題については、通常のサポート料金が適用されます。マイクロソフト カスタマー サービス サポートの電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support注: [修正プログラムのダウンロード] フォームには、修正プログラムが提供されている言語が表示されます。お使いの言語が表示されない場合は、その言語の修正プログラムが利用できないためです。
必要条件
この修正プログラムを適用するには Windows Server 2003 Service Pack 1 または Windows Server 2003 Service Pack 2 がインストールされている必要があります。
詳細については、次の文書番号をクリックして、マイクロソフト サポート技術情報の資料をご参照ください。
889100 Windows Server 2003 の最新の service pack の入手方法
再起動の必要性
この修正プログラムの適用後、コンピューターを再起動する必要があります。
修正プログラムの置き換えに関する情報
この修正プログラムによって他の修正プログラムが置き換わることはありません。
ファイル情報
修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
Windows Server 2003 Service Pack 1、x86 ベースのバージョン
ファイル名 |
ファイル バージョン |
ファイル サイズ |
日付 |
時刻 |
プラットフォーム |
---|---|---|---|---|---|
Mrxsmb.sys |
5.2.3790.3276 |
438,784 |
07-Jan-2009 |
11:39 |
x86 |
Windows Server 2003 Service Pack 2、x86 ベースのバージョン
ファイル名 |
ファイル バージョン |
ファイル サイズ |
日付 |
時刻 |
プラットフォーム |
---|---|---|---|---|---|
Mrxsmb.sys |
5.2.3790.4441 |
438,784 |
07-Jan-2009 |
11:44 |
x86 |
Windows Server 2003 Service Pack 1、Itanium ベースのバージョン
ファイル名 |
ファイル バージョン |
ファイル サイズ |
日付 |
時刻 |
プラットフォーム |
---|---|---|---|---|---|
Mrxsmb.sys |
5.2.3790.3276 |
1,172,992 |
07-Jan-2009 |
00:41 |
IA-64 |
Windows Server 2003 Service Pack 2、Itanium ベースのバージョン
ファイル名 |
ファイル バージョン |
ファイル サイズ |
日付 |
時刻 |
プラットフォーム |
---|---|---|---|---|---|
Mrxsmb.sys |
5.2.3790.4441 |
1,173,504 |
07-Jan-2009 |
00:47 |
IA-64 |
Windows Server 2003 Service Pack 1、x64 ベースのバージョン
ファイル名 |
ファイル バージョン |
ファイル サイズ |
日付 |
時刻 |
プラットフォーム |
---|---|---|---|---|---|
Mrxsmb.sys |
5.2.3790.3276 |
786,944 |
07-Jan-2009 |
00:41 |
x64 |
Windows Server 2003 Service Pack 2、x64 ベースのバージョン
ファイル名 |
ファイル バージョン |
ファイル サイズ |
日付 |
時刻 |
プラットフォーム |
---|---|---|---|---|---|
Mrxsmb.sys |
5.2.3790.4441 |
787,456 |
07-Jan-2009 |
00:49 |
x64 |
Service Pack 1 に、Windows XP Professional x64 Edition
ファイル名 |
ファイル バージョン |
ファイル サイズ |
日付 |
時刻 |
プラットフォーム |
---|---|---|---|---|---|
Mrxsmb.sys |
5.2.3790.3276 |
786,944 |
07-Jan-2009 |
00:41 |
x64 |
Service Pack 2 に、Windows XP Professional x64 Edition
ファイル名 |
ファイル バージョン |
ファイル サイズ |
日付 |
時刻 |
プラットフォーム |
---|---|---|---|---|---|
Mrxsmb.sys |
5.2.3790.4441 |
787,456 |
07-Jan-2009 |
00:49 |
x64 |
状況
マイクロソフトは、この問題を「対象製品」セクションに記載されているマイクロソフト製品の問題として認識しています。
詳細
ExInitializeWorkItemとExQueueWorkItem関数は、指定された作業項目は、デバイス オブジェクトやデバイス スタックに関連付けられている場合にのみ使用できます。他のすべての場合、ドライバーは、 IoAllocateWorkItem、 IoFreeWorkItem、およびIoQueueWorkItemのルーチンを使用してください。これらのルーチンは、作業項目が処理されるまで、指定された作業項目に関連付けられているデバイス オブジェクトは使用を保証します。
詳細については、次の Microsoft Developer Network Web サイトを参照してください。
http://msdn.microsoft.com/en-us/library/ms791491.aspxソフトウェア更新プログラムの用語の詳細については、次の文書番号をクリックして、マイクロソフト サポート技術情報の資料を参照してください。
824684マイクロソフトのソフトウェア更新プログラムを記述するために使用される一般的な用語説明
X64 ベース バージョンの Microsoft Windows のテクニカル サポート
ハードウェアが既にインストールされている、Microsoft Windows x64 エディションに付属している場合、ハードウェアの製造元は、テクニカル サポート、および Windows x64 エディションのサポートを提供します。この例では、ハードウェアの製造元は、Windows x64 エディションがハードウェアに搭載されているために、サポートを提供します。ハードウェアの製造元が、独自のコンポーネントを使用して Windows x64 エディションのインストールをカスタマイズしている可能性があります。独自のコンポーネントは、固有のデバイス ドライバーを含めることがあります。 またはハードウェアのパフォーマンスを最大化するためのオプションの設定を含めることがあります。Windows x64 エディションのテクニカル ヘルプが必要な場合、マイクロソフトは妥当な範囲のサポートを提供します。ただし、製造元に直接連絡する必要があります。製造元は、製造元がハードウェアにインストールするソフトウェアをサポートするために最も適しています。など、Windows Server 2003 の x64 エディションの Windows x64 エディションを別々 に購入した場合は、テクニカル サポートはマイクロソフトに問い合わせてください。
Windows XP Professional x64 Edition の製品については、次のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/windowsxp/64bit/default.mspxX64 ベース バージョンの Windows Server 2003 の製品については、次のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx