"STOP 0x0000007F" エラーの一般的な原因

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文書番号: 137539 - 対象製品
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目次

現象

Windows の実行中に次のエラー メッセージが表示されることがあります。
STOP 0x0000007F (UNEXPECTED_KERNEL_MODE_TRAP)

原因

このエラー メッセージは、以下のいずれかの場合に表示されることがあります。
  • コンピューターでハードウェアまたはソフトウェアの問題が発生している (最も一般的な原因はハードウェアの問題です)。
  • コンピューターのプロセッサを、想定クロック速度を超えた値で実行しようとしている (たとえば、150 MHz のプロセッサを 187 MHz で実行するように設定している)。
上記の STOP エラーは、カーネル モードでトラップが発生し、そのトラップがカーネルで許容されないか、または常に致命的であることを意味しますSTOP 0x7F が発生する最も一般的な原因は以下のとおりです。
  • メモリ (RAM) の破損など、低レベルのハードウェア障害
  • メモリ モジュールの不一致
  • マザーボードの動作異常
原因を推定するには、STOP 画面の最初の行に表示されているパラメーターを調べます。
**STOP 0x0000007F (0x000000XX, 0x00000000, 0x00000000, 0x00000000)
UNEXPECTED_KERNEL_MODE_TRAP
最も重要なのは、最初のパラメーター (0x0000000X) です。このパラメーターには複数の値になる場合があります。トラップの原因は、このパラメーターの値によって異なります。STOP 0x7F の原因となるすべてのトラップは x86 プラットフォームだけで発生するため、Intel x86 マイクロプロセッサのリファレンス マニュアルに記載されています。中でも最も一般的なものは次のとおりです。
値              意味
   ----------   --------------------
0x00000000   0 除算エラー
0x00000004   オーバーフロー
0x00000005   境界チェックの失敗
0x00000006   無効なオペコード
0x00000008   二重フォールト

0 除算エラー

0 除算エラーは、DIV 命令が実行された場合にその除数がゼロ (0) であるときに発生します。メモリの破損 (またはその他のハードウェアの問題) やソフトウェアの障害が原因であることがあります。

オーバーフロー

オーバーフロー命令は、オーバーフロー (OF) フラグが設定されている場合にプロセッサが割り込みハンドラーの呼び出しを実行したときに発生します。

境界チェックの失敗

この失敗は、プロセッサが BOUND 命令の実行中に、指定された範囲を超えるオペランドを見つけたときに生成されます。BOUND 命令は、符号付き配列のインデックスを特定の範囲内に収めるために使用されます。

無効なオペコード

このエラーは、プロセッサが無効な命令を実行しようとしたときに生成されます。通常、命令ポインターが破損し、誤った場所を指している場合に発生します。この原因として最もよくあるのが、ハードウェアのメモリの破損です。

二重フォールト

ある例外に対するハンドラーを呼び出そうとしているときに別の例外が発生すると、二重フォールトが発生します。通常、2 つの例外は順番に処理されますが、順番に処理できない例外が発生することがあります。この場合、プロセッサから二重フォールトが送信されます。主な原因は、ハードウェアとカーネルのスタック オーバーフローの 2 つです。ハードウェアの問題は、通常、CPU、RAM、またはバスに関連するものです。カーネルのスタック オーバーフローは、カーネル モードのドライバーの不良による場合がほとんどです。

解決方法

この問題を解決するには、次のうち適切な方法を実行します。
  • ソフトウェアまたはハードウェアが特定のトラップの原因になっている可能性がある場合、原因を特定するにはデバッグが必要です。ハードウェアに問題があると思われる場合は、次の手順に従ってハードウェアのトラブルシューティングを実行します。
    1. コンピューターの製造元から提供される診断ソフトウェアを実行してコンピューター内の RAM をテストします。不良と報告された RAM を交換します。さらに、コンピューター内のすべての RAM の速度が同じであることを確認します。
    2. コントローラー、カード、または他の周辺機器を取り外したり交換したりしてみます。
    3. コンピューターで異なるマザーボードを試します。
  • 想定されているクロック速度を超えてプロセッサを実行している場合、想定されているクロック速度に戻します。
  • 更新されたハードウェア ドライバーと BIOS のいずれか、または両方がハードウェアの製造元にあるかどうかを確認します。
プロセッサのフォールトの詳細については、Intel プロセッサのリファレンス マニュアルを参照してください。
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。

プロパティ

文書番号: 137539 - 最終更新日: 2013年3月6日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
キーワード:?
kberrmsg KB137539
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