Causas gerais das mensagens de erro "STOP 0x0000007F"

Traduções deste artigo Traduções deste artigo
ID do artigo: 137539 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

A seguinte mensagem de erro pode ser exibida enquanto você executa o Windows:
STOP 0x0000007F (UNEXPECTED_KERNEL_MODE_TRAP)

Causa

Essa mensagem de erro pode ocorrer se qualquer uma das seguintes condições for verdadeira:
  • O computador tem problemas de hardware ou de software (falha de hardware é a causa mais comum).
  • Você tenta aumentar a velocidade do processador do computador (por exemplo, define um processador de 150 MhZ para executar a 187 MhZ).
O erro STOP mencionado acima significa que ocorreu uma interceptação no modo de kernel e essa interceptação é uma que o kernel não tem permissão para ter ou é sempre fatal. As causas mais comuns de um erro STOP 0x7F são:
  • Corrupção de nível inferior do hardware, como corrupção da memória (RAM)
  • Módulos da memória incompatíveis
  • Uma placa-mãe com defeito
Para determinar uma causa aproximada, examine os parâmetros na parte superior da tela do erro STOP:
**STOP 0x0000007F (0x000000XX, 0x00000000, 0x00000000, 0x00000000)
UNEXPECTED_KERNEL_MODE_TRAP
O parâmetro mais importante é o primeiro (0x0000000X) que pode ter diversos valores diferentes. A causa dessa interceptação pode variar, dependendo do valor desse parâmetro. Todas as interceptações que causam um erro STOP 0x7F podem ser encontradas em qualquer manual de referência do microprocessador Intel x86 uma vez que elas são específicas às plataformas x86. A seguir estão algumas das mais comuns:
   Valores         Significado
   ----------   --------------------
   0x00000000   Erro Divisão por zero
   0x00000004   Estouro de capacidade
   0x00000005   Falha de verificação de limites
   0x00000006   Opcode inválido
   0x00000008   Falha dupla

Erro Divisão por zero

Uma divisão por zero é causada quando uma instrução DIV é executada e o divisor é 0. A corrupção da memória (ou outros problemas de hardware) ou falhas de software podem causar isso.

Estouro de capacidade

A instrução do estouro de capacidade ocorre quando o processador executa uma chamada para um manipulador de interrupção quando o sinalizador do estouro de capacidade (OF) é definido.

Falha de verificação de limites

Essa falha é gerada quando o processador, enquanto executa uma instrução BOUND, descobre que o operando excede os limites especificados. Uma instrução BOUND é usada para garantir que um índice de matriz assinado está dentro de um determinado intervalo.

Opcode inválido

Essa falha é gerada quando o processador executa uma instrução inválida. Isso é causado geralmente quando o ponteiro da instrução tornou-se corrompido e está apontando para o local errado. A causa mais comum disso é a corrupção da memória do hardware.

Falha dupla

Uma falha dupla ocorre quando ocorre uma exceção ao chamar o manipulador para uma exceção anterior. Normalmente, as duas exceções podem ser manipuladas em série. No entanto, existem diversas exceções que não podem ser manipuladas em série e nessa situação o processador sinaliza uma falha dupla. As duas causas principais para isso são o hardware e estouros de pilha de kernel. Problemas de hardware estão normalmente relacionados à CPU, à RAM ou ao barramento. Estouros de pilha de kernel são quase sempre causados por drivers no modo kernel com falhas.

Resolução

Para resolver esse problema, use o método apropriado:
  • Se o software ou o hardware puder causar uma interceptação específica, será necessário uma depuração para determinar qual é a causa. Se suspeitar de um problema de hardware, execute as seguintes etapas para solução de problemas de hardware:
    1. Teste a RAM no computador executando o software de diagnóstico fornecido pelo fabricante do computador. Substitua qualquer RAM reportada como inválida. Além disso, verifique se toda a RAM no computador tem a mesma velocidade.
    2. Remova ou troque controladores, placas ou outros periféricos.
    3. Teste uma placa-mãe diferente no computador.
  • Se estiver aumentando a velocidade do seu processador, volte para a velocidade na qual ele foi desenvolvido para executar.
  • Verifique com o fornecedor do hardware a existência de drivers de hardware atualizados ou atualizações do BIOS, ou ambos.
Para obter informações adicionais sobre falhas de processador, consulte um manual de referência do processador Intel.

Propriedades

ID do artigo: 137539 - Última revisão: sexta-feira, 17 de fevereiro de 2006 - Revisão: 4.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palavras-chave: 
kberrmsg KB137539

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com