Tarkan vastaavuuden löytäminen PHAKU- tai VHAKU-funktion avulla

Artikkeleiden käännökset Artikkeleiden käännökset
Artikkelin tunnus: 181213 - Näytä tuotteet, joita tämä artikkeli koskee.
Laajenna kaikki | Kutista kaikki

Tällä sivulla

Yhteenveto

PHAKU- ja VHAKU-funktiot sisältävät argumentin nimeltä hakualue, jonka avulla voit löytää tarkan vastaavuuden hakuarvollesi ilman hakutaulukon lajittelemista.

Huomautus Hakutaulukkoa ei tarvitse lajitella, jos käytät hakualue-argumenttia oikein.

Enemmän tietoa

Näiden funktioiden syntaksin määritys on seuraava.

PHAKU-funktio

   =PHAKU(hakuarvo,taulukkomatriisi,sarakkeen_numero,hakualue)
				
Tässä:
   Argumentti     Argumentin määritys
   ---------------------------------------------------------------------

   hakuarvo  Matriisin ensimmäisestä sarakkkeesta etsittävä arvo.

   taulukkomatriisi  Tietotaulukko, josta tietoja haetaan.

   sarakkeen_numero    Sen taulukkomatriisin sarakkeen numero, jolle
                tulee palauttaa vastaava arvo.

   hakualue  Looginen arvo, joka määrittää, halutaanko löytää
                tarkka vastaavuus vai likimääräinen vastaavuus.
                Jos arvo on TOSI tai jätetty pois, palautetaan likimääräinen vastaavuus.
                Toisin sanoen, jos tarkkaa vastaavuutta ei löydy, palautetaan
                seuraavaksi suurempi arvo, joka on pienempi kuin
                hakuarvo. Jos arvo on EPÄTOSI, PHAKU löytää tarkan vastaavuuden.
                Jos tarkkaa vastaavuutta ei löydy, palautetaan #PUUTTUU-virhearvo.
				
Huomautus Jos hakualue on TOSI tai jätetty pois (likimääräinen vastaavuus), taulukkomatriisin ensimmäisen sarakkeen arvot on lajiteltava nousevasti. Jos hakualue on EPÄTOSI (tarkka vastaavuus), taulukkomatriisia ei tarvitse lajitella.

Esimerkki EPÄTOSI-arvon käyttämisestä hakualue-argumenttina

Seuraavassa luettelossa on hedelmiä ja niiden värejä. Huomaa, ettei ensimmäistä saraketta ole lajiteltu:
   A1: Hedelmä    B1: Väri  
   A2: Kiivi     B2: Vihreä 
   A3: Banaani   B3: Keltainen 
   A4: Rypäle    B4: Violetti  
   A5: Omena    B5: Punainen   
				
Seuraava kaava löytää värin (Punainen), joka vastaa hedelmää Omena. Voit kirjoittaa kaavan mihin tahansa laskentataulukon soluun:
=PHAKU("Omena",A2:B5,2,EPÄTOSI)
				
Huomaa, että jos muutat hakualue-argumentiksi TOSI, Excel palauttaa #PUUTTUU-virheen, koska ensimmäistä saraketta ei ole lajiteltu.

VHAKU-funktio

=VHAKU(hakuarvo,taulukkomatriisi,rivin_numero,hakualue)
				
Tässä:
   Argumentti     Argumentin määritys
   ---------------------------------------------------------------------

   hakuarvo  Matriisin ensimmäisestä sarakkkeesta etsittävä arvo.

   taulukkomatriisi  Tietotaulukko, josta tietoja haetaan.

   rovin_numero    Sen taulukkomatriisin rivin numero, jolle
                tulee palauttaa vastaava arvo.

   hakualue  Looginen arvo, joka määrittää, halutaanko löytää
                tarkka vastaavuus vai likimääräinen vastaavuus.
                Jos arvo on TOSI tai jätetty pois, palautetaan likimääräinen vastaavuus.
                Toisin sanoen, jos tarkkaa vastaavuutta ei löydy, palautetaan
                seuraavaksi suurempi arvo, joka on pienempi kuin
                hakuarvo. Jos arvo on EPÄTOSI, PHAKU löytää tarkan vastaavuuden.
                Jos tarkkaa vastaavuutta ei löydy, palautetaan #PUUTTUU-
                virhearvo.
				
Huomautus Jos hakualue on TOSI tai jätetty pois (likimääräinen vastaavuus), taulukkomatriisin ensimmäisen rivin arvot on lajiteltava nousevasti. Jos hakualue on EPÄTOSI (tarkka vastaavuus), taulukkomatriisia ei tarvitse lajitella.

Esimerkki EPÄTOSI-arvon käyttämisestä hakualue-argumenttina

Seuraavassa luettelossa on hedelmiä ja niiden värejä. Huomaa, ettei ensimmäistä saraketta ole lajiteltu:
   A1: Hedelmä    B1: Väri
   A2: Kiivi     B2: Vihreä 
   A3: Banaani   B3: Keltainen
   A4: Rypäle    B4: Violetti
   A5: Omena    B5: Punainen
				
Seuraava kaava löytää Väri-sarakkeen ja palauttaa Keltainen-otsikon kolmannen kohteen (-1). Voit kirjoittaa kaavan mihin tahansa laskentataulukon soluun:
=VHAKU("Vär",A1:B5,3,EPÄTOSI)
				
Huomaa, että jos muutat hakualue-argumentiksi TOSI, Excel palauttaa #PUUTTUU-virheen, koska ensimmäistä saraketta ei ole lajiteltu.

Suositukset

Saat lisätietoja HAKU-funktioiden käyttämisestä Microsoft Excelissä napsauttamalla seuraavia artikkelien numeroita, jolloin pääset lukemaan artikkelit Microsoft Knowledge Base -tietokannassa:
181212 XL: Lajittelemattomien tietojen haun tekeminen Excelissä (tämä artikkeli saattaa olla englanninkielinen)
214264 XL: Isot ja pienet kirjaimet eri merkeiksi tunnistavan haun tekeminen (tämä artikkeli saattaa olla englanninkielinen)
214069 XL: Matriisin ensimmäisen tai viimeisen vastaavuuden palauttaminen (tämä artikkeli saattaa olla englanninkielinen)
181201 XL: VHAKU, PHAKU ja HAKU palauttavat virheellisiä arvoja (tämä artikkeli saattaa olla englanninkielinen)
213476 XL: Tulokset ovat odottamattomat, kun hakutaulukossa on sekä tekstiä että numeroita (tämä artikkeli saattaa olla englanninkielinen)
280094 XL: Esimerkki kaavavirheet piilottavasta käyttäjän määrittämästä funktiosta (tämä artikkeli saattaa olla englanninkielinen)
Saat lisätietoja VHAKU-funktiosta valitsemalla Ohje-valikosta Microsoft Excelin ohje, kirjoittamalla Office-avustajaan tai vastaustoimintoon VHAKU-laskentataulukkofunktio ja valitsemalla sitten Etsi, jolloin näyttöön tulee aiheeseen liittyviä tietoja.
Saat lisätietoja PHAKU-funktiosta valitsemalla Ohje-valikosta Microsoft Excelin ohje, kirjoittamalla Office-avustajaan tai vastaustoimintoon PHAKU-laskentataulukkofunktio ja valitsemalla sitten Etsi, jolloin näyttöön tulee aiheeseen liittyviä tietoja.

Ominaisuudet

Artikkelin tunnus: 181213 - Viimeisin tarkistus: 25. kesäkuuta 2007 - Versio: 3.1
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Hakusanat: 
kbhowto KB181213

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com