Cómo crear un formato condicional para ocultar errores en Excel

Seleccione idioma Seleccione idioma
Id. de artículo: 182189 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

En Microsoft Excel, puede crear formato condicional en una celda o en un rango de celdas para que los valores de error no se muestren en las celdas.

Más información

En las versiones de Excel anteriores a Microsoft Excel 97, no podía crear un formato condicional personalizado para ocultar los valores de error que la fórmula de una celda devolvía a la celda.

Por ejemplo, se devuelve #¡DIV/0! a la celda A1 si escribe los datos siguientes en la hoja de cálculo:
Contraer esta tablaAmpliar esta tabla
A1: =B1/C1B1: 5C1: 0
Para ocultar el valor de error, puede cambiar la fórmula de la celda A1 a la fórmula siguiente:
=SI(ESERROR(B1/C1)",",B1/C1)
En estos ejemplos, esta fórmula devuelve la cadena vacía ("").

En Microsoft Office Excel 2007, puede utilizar la función SI.ERROR para simplificar esta fórmula, de la manera siguiente:
=SI.ERROR(B1/C1,"")
Tenga en cuenta que hay otras técnicas para ocultar valores de error que puede utilizar en versiones de Excel anteriores a Excel 97.

El formato condicional le permite utilizar lo más sencillo de las dos fórmulas en la celda A1 e impedir que el valor de error aparezca en la celda A1.

Para utilizar formato condicional con el fin de ocultar valores de error devueltos por fórmulas de celdas, utilice uno de los procedimientos de ejemplo siguientes, según la versión de Excel que esté ejecutando.

Microsoft Office Excel 2003 y versiones anteriores de Excel

  1. Escriba los datos siguientes en una hoja de cálculo:
    Contraer esta tablaAmpliar esta tabla
    A1: =B1/C1B1: 5C1: 0
    A2: =nofunction()*B2B2: 6C2: 0
    Nota: la celda A1 devuelve el valor de error #¡DIV/0! y la celda A2 devuelve el valor de error #¿NOMBRE? Esto se debe a que la función nofunction() que se utiliza en la celda A2 no es una función válida.
  2. Seleccione la columna A.
  3. En el menú Formato, haga clic en Formato condicional.
  4. En el cuadro de diálogo Formato condicional, haga clic en Condición 1 y, a continuación, haga clic en Fórmula.
  5. En el cuadro de edición situado a la derecha de Condición 1, escriba la fórmula siguiente:
    =ESERROR(A1)
  6. Haga clic en el botón Formato. En el cuadro de diálogo Formato de celdas, haga clic en Color y, a continuación, haga clic en el cuadrado Blanco.
  7. Haga clic en Aceptar en el cuadro de diálogo Formato de celdas y, a continuación, haga clic en Aceptar en el cuadro de diálogo Formato condicional.

    Nota: como seleccionó la columna A en el paso 2, todas las celdas de la columna A recibieron este formato condicional. Por tanto, todas las demás celdas de la columna A que devuelven valores de error no mostrarán el valor de error.

Microsoft Office Excel 2007

  1. Escriba los datos siguientes en una hoja de cálculo:
    Contraer esta tablaAmpliar esta tabla
    A1: =B1/C1B1: 5C1: 0
    A2: =nofunction()*B2B2: 6C2: 0
    Nota: la celda A1 devuelve el valor de error #¡DIV/0! y la celda A2 devuelve el valor de error #¿NOMBRE? Esto se debe a que la función nofunction() que se utiliza en la celda A2 no es una función válida.
  2. Seleccione la columna A.
  3. En la ficha Inicio, haga clic en la flecha situada junto a Formato condicional en el grupo Estilos y, a continuación, haga clic en Nueva regla.
  4. En el cuadro de diálogo Nueva regla de formato, haga clic en Utilizar una fórmula para determinar en qué celdas desea aplicar el formato.
  5. En el cuadro Editar una descripción de regla, escriba la fórmula siguiente en el campo Dar formato a los valores donde esta fórmula sea verdadera:
    =ESERROR(A1)
  6. Haga clic en el botón Formato.
  7. En el cuadro de diálogo Formato de celdas, haga clic en la ficha Fuente y, a continuación, haga clic en el cuadrado Blanco en la lista Color.
  8. Haga clic en Aceptar y, después, haga clic en Aceptar en el cuadro de diálogo Nueva regla de formato.

    Nota: como seleccionó la columna A en el paso 2, todas las celdas de la columna A recibieron este formato condicional. Por tanto, todas las demás celdas de la columna A que devuelven valores de error no mostrarán el valor de error.

Propiedades

Id. de artículo: 182189 - Última revisión: martes, 25 de marzo de 2008 - Versión: 5.0
La información de este artículo se refiere a:
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 97 Standard Edition
Palabras clave: 
kbhowto KB182189

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com