Comment faire pour créer une mise en forme conditionnelle pour masquer les erreurs dans Excel

Traductions disponibles Traductions disponibles
Numéro d'article: 182189 - Voir les produits auxquels s'applique cet article
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Agrandir tout | Réduire tout

Sommaire

Résumé

Dans Microsoft Excel, vous pouvez créer une mise en forme conditionnelle sur une cellule ou une plage de cellules de sorte que les valeurs d'erreur ne soient pas affichées dans la ou les cellules.

Plus d'informations

Dans les versions d'Excel antérieures à Microsoft Excel 97, vous ne pouviez pas créer de mise en forme conditionnelle personnalisée pour masquer les valeurs d'erreur retournées par la formule d'une cellule.

Par exemple, la cellule A1 retourne l'erreur #DIV/0! si vous entrez les données suivantes dans la feuille de calcul :
   A1 : =B1/C1   B1 : 5   C1 : 0
				
Pour masquer la valeur d'erreur, vous pouvez modifier la formule de la cellule A1 en la formule suivante :
=SI(ESTERREUR(B1/C1),"",B1/C1)
Dans cet exemple, la formule retourne une chaîne vide ("").

Dans Microsoft Office Excel 2007, vous pouvez utiliser la fonction SIERREUR pour simplifier cette formule comme suit :
=SIERREUR(B1/C1,"")
Notez que vous disposez d'autres techniques pour masquer les valeurs d'erreur si vous utilisez une version d'Excel antérieure à Excel 97.

La mise en forme conditionnelle vous permet d'utiliser la formule la plus simple des deux dans la cellule A1 et d'empêcher l'affichage de la valeur d'erreur dans la cellule A1.

Pour utiliser la mise en forme conditionnelle pour masquer les valeurs d'erreur retournées par les formules de cellules, utilisez l'une des procédures d'exemple ci-dessous, selon la version d'Excel exécutée sur votre ordinateur.

Microsoft Office Excel 2003 et versions antérieures d'Excel

  1. Entrez les données suivantes dans une feuille de calcul :
       A1 : =B1/C1           B1 : 5   C1 : 0
       A2 : =nofunction()*B2   B2 : 6   C2 : 0
    						
    Remarque La cellule A1 retourne la valeur d'erreur #DIV/0! et la cellule A2 la valeur d'erreur #NOM? . Ceci se produit car la fonction nofunction() utilisée dans la cellule A2 n'est pas valide.
  2. Sélectionnez la colonne A.
  3. Dans le menu Format, cliquez sur Mise en forme conditionnelle.
  4. Dans la boîte de dialogue Mise en forme conditionnelle, cliquez sur Condition 1, puis sur La formule est.
  5. Dans la zone d'édition à droite de Condition 1, tapez la formule suivante :
    =ESTERREUR(A1)
  6. Cliquez sur le bouton Format. Dans la boîte de dialogue Format de cellule, cliquez sur Couleur, puis sur la mosaïque Blanc.
  7. Cliquez sur OK dans la boîte de dialogue Format de cellule, puis à nouveau sur OK dans la boîte de dialogue Mise en forme conditionnelle.

    Remarque Étant donné que vous avez sélectionné la colonne A à l'étape 2, toutes les cellules de la colonne A ont été mises en forme avec cette mise en forme conditionnelle. Par conséquent, toute autre cellule de la colonne A retournant une valeur d'erreur n'affichera pas cette valeur d'erreur.

Microsoft Office Excel 2007

  1. Entrez les données suivantes dans une feuille de calcul :
       A1 : =B1/C1           B1 : 5   C1 : 0
       A2 : =nofunction()*B2   B2 : 6   C2 : 0
    						
    Remarque La cellule A1 retourne la valeur d'erreur #DIV/0! et la cellule A2 la valeur d'erreur #NOM? . Ceci se produit car la fonction nofunction() utilisée dans la cellule A2 n'est pas valide.
  2. Sélectionnez la colonne A.
  3. Sous l'onglet Accueil, cliquez sur la flèche en regard de Mise en forme conditionnelle dans le groupe Styles, puis cliquez sur Nouvelle règle.
  4. Dans la boîte de dialogue Nouvelle règle de mise en forme, cliquez sur Utiliser une formule pour déterminer pour quelles cellules le format sera appliqué.
  5. Dans la zone Modifier la description de la règle, tapez la formule suivante dans le champ Appliquer une mise en forme aux valeurs pour lesquelles cette formule est vraie :
    =ESTERREUR(A1)
  6. Cliquez sur le bouton Format.
  7. Dans la boîte de dialogue Format de cellule, cliquez sur l'onglet Police, puis cliquez sur la mosaïque Blanc dans la liste Couleur.
  8. Cliquez sur OK, puis à nouveau sur OK dans la boîte de dialogue Nouvelle règle de mise en forme.

    Remarque Étant donné que vous avez sélectionné la colonne A à l'étape 2, toutes les cellules de la colonne A ont été mises en forme avec cette mise en forme conditionnelle. Par conséquent, toute autre cellule de la colonne A qui retourne une valeur d'erreur n'affichera pas cette valeur d'erreur.

Propriétés

Numéro d'article: 182189 - Dernière mise à jour: vendredi 4 janvier 2008 - Version: 5.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2000 Standard
  • Microsoft Excel 2002
  • Microsoft Excel 97 Standard
Mots-clés : 
kbhowto KB182189
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com