Posizione in cui nel Registro di sistema per Word 2000 vengono memorizzate delle impostazioni

Traduzione articoli Traduzione articoli
Identificativo articolo: 212242 - Visualizza i prodotti a cui si riferisce l?articolo.
Per la una versione di Microsoft Word 97 di questo articolo, vedere 157464.
importante : questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo sono elencate impostazioni nel Registro di sistema relative a Word 2000. Questo articolo Ŕ suddivido nelle seguenti sezioni:
  • Percorsi principali delle impostazioni di Word
  • Impostazioni nelle seguenti chiavi del Registro di sistema di Windows:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word

    HKEY\CURRENT_USER\Software\Microsoft\Office\9.0\Common

    HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools
  • Impostazioni varie
  • Utilizzando la macro RegOptions

Informazioni

avviso : se si utilizza Editor del Registro di sistema in modo non corretto, si potrebbero provocare problemi gravi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce la che Ŕ possibile risolvere i problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. Utilizzare Editor del Registro di sistema a proprio rischio.

Principali percorsi delle impostazioni di Word

Quasi tutte le impostazioni di Word sono memorizzate nella seguente chiave del Registro di sistema:
HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word
Le modifiche apportate alla chiave HKEY_CURRENT_USER del Registro di sistema vengono riflesse nella seguente chiave del Registro di sistema:
HKEY_USERS\Default\Software\Microsoft\Office\9.0\Word
La differenza tra le due chiavi Ŕ che il primo elemento si applica solo all'utente corrente del sistema e l'altro Ŕ il valore predefinito per tutti gli utenti. Le voci di Word sono gli stessi per entrambi, impostazione, tuttavia, in modo che qualsiasi modifica apportata a una automaticamente Ŕ riflessa in altro.

Per resto di questo articolo, tutti i riferimenti per il sottoalbero HKEY_CURRENT_USER applicano anche alla sottostruttura HKEY_USERS, tranne quando indicato diversamente.

Impostazioni in HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word

Le impostazioni che potrebbe essere utile esaminare durante la risoluzione dei problemi si trovano in questa chiave. La chiave Data e della chiave Options sono le aree modificate pi¨ di frequente.

Chiave Data

HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data

Questa chiave contiene informazioni binarie per ultimi file usati gli elenchi di (MRU), quali l'elenco di file dei file e l'elenco MRU della Rubrica. Contiene inoltre altre informazioni quali le impostazioni di Revisioni e Modifica le impostazioni.

Chiave Options

HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options

In questa chiave sono memorizzate le opzioni che Ŕ possibile impostare da Word, sia cambiando le opzioni di menu che eseguendo la macro RegOptions. Si tratta delle opzioni modificabili.

Le impostazioni rientrano in due gruppi: predefiniti per le impostazioni e le impostazioni facoltative. Le impostazioni predefinite vengono stabilite durante l'installazione, ed Ŕ possibile modificarli modificando le opzioni in Word. Le impostazioni facoltative non vengono create durante l'installazione e vengono aggiunte eseguendo la macro RegOptions, descritta pi¨ avanti.

Le impostazioni predefinite nella chiave Options e lo scopo, sono i seguenti:

Nota : pi¨ delle seguenti impostazioni non sono presenti nel Registro di sistema finchÚ non si apporta una modifica in Word e quindi chiudere Word.

Data e ora

Per individuare la seguente opzione in Word, scegliere Data e ora dal menu Inserisci , selezionare un formato e quindi fare clic su predefinito .
DefaultDateFormat: Contiene il formato di data predefinito di Word.

Modifica

Per individuare le seguenti opzioni in Word, scegliere Opzioni dal menu Strumenti e quindi scegliere la scheda Modifica .
PICEDITCLASS: Contiene gli utilizzi di Word in Editor di immagini per la modifica di immagini.

Opzioni di posta elettronica

ReplyMessageComment: Contiene il nome utente per "Contrassegna i commenti con". Scegliere Opzioni dal menu Strumenti . Nella scheda Generale , fare clic sul pulsante Opzioni di posta elettronica e fare clic sulla scheda modelli .

Percorso di WordMail: Contiene il percorso di directory di WordMail.

Posizioni dei file

Per individuare le seguenti opzioni in Word, scegliere Opzioni dal menu Strumenti e quindi scegliere la scheda Directory predefinite :
PERCORSO di salvataggio automatico: Contiene il percorso della cartella per i documenti di salvataggio automatico.

DOC-Path: Contiene il percorso della cartella per i documenti salvati in Word.

INI-PATH: Contiene il percorso della cartella per le opzioni utente.

IMMAGINE-PATH: Contiene il percorso della cartella per la ClipArt.

PROGRAMDIR: Contiene il percorso della cartella per cartella di programma di Word.

Startup-Path: Contiene il percorso di cartella per la cartella esecuzione automatica.

TOOLS-PATH: Posizione della cartella altro per gli strumenti di correzione.
Nota : l'utente e gruppo di lavoro le posizioni del Registro di sistema modello sono disponibile le seguenti:
HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\General

UserTemplates: Cartella posizione modelli utente.

SharedTemplates: Posizione cartella Modelli gruppo di lavoro.

Stampa

Per individuare le seguenti opzioni in Word, scegliere Opzioni dal menu Strumenti e quindi fare clic sulla scheda Stampa :
BackgroundPrint: Attiva la stampa in background o disattiva.

Salvataggio

Per individuare le seguenti opzioni in Word, scegliere Opzioni dal menu Strumenti e quindi fare clic sulla scheda Salva :
BackgroundSave: Attiva il salvataggio o la disattivazione di sfondo.

DefaultFormat: In questa chiave Ŕ imposta il formato predefinito per il salvataggio dei documenti. ╚ possibile modificare il formato predefinito modificando l'impostazione di Salva file di Word come in Word.

Controllo ortografia e grammatica

Per individuare le seguenti opzioni in Word, scegliere Opzioni dal menu Strumenti e quindi scegliere il ortografia e grammatica scheda:
AutoSpell: Attiva il controllo ortografico automatico o disattivare.

AutoGrammar: Attiva il controllo grammaticale automatico o disattivare.

UpdateDictionaryNumber: Imposta l'ordine predefinito per i dizionari personalizzati.

Varie

FirstRun: Consente di determinare se Ŕ la prima volta che si esegue Word dopo l'installazione.

NoEditTime: Attiva e Disattiva registrazione di tempo di modifica nelle statistiche.

PlainTextAutoFormat: Set formattazione automatica per i documenti di WordMail.

StartWhatIsNew: Attiva "Qual Ŕ nuovo schermo" e disattivare all'avvio.
Impostazioni facoltative che possono essere create manualmente o mediante l'utilizzo della macro RegOptions sono:
-Estensione bak: Contiene l'estensione predefinita per i file di backup.

BitMapMemory: Contiene la memoria per cache grafica interno.

CacheSize: Contiene cache testo interna del documento di Word.

Estensione di documento: Contiene l'estensione predefinita per i documenti di Word.

Punto di estensione: Contiene l'estensione predefinita per i modelli in Word.

OleDot: Contiene il modello predefinito utilizzato per creare gli oggetti documento in Word o in altre applicazioni OLE.

SlowShading: Per stampanti con funzioni speciali di disegno, consente di sfondo di elementi grafici.

Chiave Stationery

HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Stationery

Questa chiave contiene il percorso predefinito per il modello per WordMail e i collegamenti per trovare il modello.

Sono quattro impostazioni:
Percorso file cfg: Contiene il percorso della cartella WordMail.

Modello predefinito: Contiene il percorso per il modello (per impostazione predefinita Email.dot).

DlgDefTpl: Contiene un collegamento per il modello predefinito.

Opzione: Contiene un collegamento per il modello predefinito.

Tabella di chiave dell'autoritÓ

HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Table di categorie di autoritÓ
In questa chiave nell'elenco categoria visualizzato nell'elenco Delle fonti sono memorizzate quando si preme ALT + MAIUSC + I o si fare clic su Segna citazione nella finestra di dialogo Delle fonti . La finestra di dialogo Delle fonti accessibili da scegliendo indici e sommario dal menu Inserisci .

Ad esempio:
   Category 1     "Cases"
   Category 2     "Statutes"
   Category 10    "10"
					

Chiave Wizards

HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Wizards

Tutte le impostazioni predefinite delle procedure guidate sono memorizzate in questo percorso. La prima volta che si esegue una procedura guidata vengono create da queste impostazioni.

Impostazioni in HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common

Questa chiave viene utilizzata da altri programmi Microsoft, quali i programmi di Office,. Analogamente, queste impostazioni sono condivise tra programmi. Le modifiche apportate nelle impostazioni di un programma visualizzate anche negli altri programmi.
Assistente: Contiene informazioni scelto Assistente.

FileNew: Contiene i percorsi dei modelli in locali e condivisi.

Internet: Contiene impostazioni per siti FTP e icone.

Apri ricerca: Archivi impostazioni predefinite per finestre di dialogo Apri e Salva in Microsoft Word, inclusi corrente visualizzazione e il nome file ed elenchi di file pi¨ recenti.

Barre degli strumenti: Set ToolTips o disattivare e set pulsante dimensioni per le barre degli strumenti.

UserInfo: Contiene informazioni utente, quali indirizzo, nome e iniziali.

UserTemplates: Contiene il percorso della cartella di modelli utente.

SharedTemplates: Contiene il percorso della cartella di modelli gruppo di lavoro.

Impostazioni in HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools

Questa chiave contiene i percorsi per tutte le applet Windows quali Equation, WordArt e Microsoft Graph. In questa posizione sono registrati anche i filtri per la grafica e i convertitori di testo. Esistono due metodi qui che riguardano soprattutto Word. Uno Ŕ la chiave di filtri grafici, quali l'importazione e i filtri di esportazione e l'altro Ŕ i convertitori di testo chiave, che registra importazione ed esportazione di convertitori di registri. Inoltre, ogni filtro e il convertitore Ŕ registrato singolarmente. Un elenco di client che utilizzano un filtro, il convertitore o applet Ŕ elencato sotto ogni strumento.

Impostazioni varie

L'estensione doc Ŕ registrato in HKEY_CLASSES_ROOT in diversi modi e Ŕ disponibili nelle radici del Registro di sistema seguente:
HKEY_CLASSES_ROOT

HKEY_LOCAL_MACHINE
Opzioni di Equation Editor descritte nella macro RegOptions sono registrate nella seguente chiave:
HKEY_CURRENT_USER\Software\Microsoft\Equation Editor\3.0\Options\General
Nota : impostazioni per le opzioni della scheda Generale (dal menu Strumenti , fare clic su Opzioni e quindi scegliere la scheda Generale ) non vengono visualizzati a meno che non sono state modificate o impostare opzioni.

Utilizzo della Macro RegOptions

La macro RegOptions (opzioni del Registro di sistema) pu˛ essere utilizzata per esaminare il Registro di sistema di Windows o apportare modifiche alle impostazioni di Word sono memorizzate. Per ulteriori informazioni sulla macro RegOptions, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
237356HOW TO: Access macro di esempio per Word 2000

ProprietÓ

Identificativo articolo: 212242 - Ultima modifica: lunedý 13 settembre 2004 - Revisione: 1.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Word 2000 Standard Edition
Chiavi:á
kbmt kbhowto kbregistry kbfaq kbinfo KB212242 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 212242
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com